Mantis Bugtracker          
testlink.org

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0003849TestLinkCustom fieldspublic2010-10-05 04:582010-10-09 08:00
Reporterskilletaudio 
Assigned Tofman 
PriorityhighSeveritymajorReproducibilityalways
StatusclosedResolutionfixed 
PlatformFirefox3 + PostgresOSWindows VistaOS Version
Product Versiontestlink_1_9_rc1-qa-20100926 
Fixed in Version1.9 RC 1 
Summary0003849: Edit test case fails to save
DescriptionRelated to TL-148 - assign keywords to case (when assigned by editing test case)

Assigning keywords works fine through Assign Keywords tool.

Fails by editing and saving test - keyword assignments not saved (along with any other edits to the test case)

DB trace printed, looks like query specifies test case twice in the query.
Steps To ReproduceCreate a test cat, create keywords.
Edit test case, assign keywords and save.

Additional Information ==============================================================================

 DB Access Error - debug_print_backtrace() OUTPUT START

 ==============================================================================

#0 database->exec_query( UPDATE tcversions tcversions SET summary='', updater_id=1, modification_ts = '2010-10-03 17:39:22', execution_type=1, importance=2, preconditions='' WHERE tcversions.id = 18) called at [/var/www/html/tl19/lib/functions/testcase.class.php:1008]
#1 testcase->update(17, 18, fff, , , , 1, 6, 0, 1, 2) called at [/var/www/html/tl19/lib/testcases/testcaseCommands.class.php:302]
0000002 testcaseCommands->doUpdate(stdClass Object ([assigned_keywords_list] => 6,[container_id] => 0,[tcase_id] => 17,[tcversion_id] => 18,[name] => fff,[summary] => ,[preconditions] => ,[steps] => ,[expected_results] => ,[new_container_id] => 0,[old_container_id] => 0,[has_been_executed] => 0,[exec_type] => 1,[importance] => 2,[doAction] => doUpdate,[move_copy_tc] => 0,[delete_tc_version] => 0,[do_move] => 0,[do_copy] => 0,[do_create_new_version] => 0,[do_delete_tc_version] => 0,[do_activate_this] => 0,[do_deactivate_this] => 0,[target_position] => bottom,[copy] => Array ([keyword_assignments] => ,[requirement_assignments] => ),[show_mode] => show,[step_number] => 0,[step_id] => 0,[step_set] => ,[tcaseSteps] => ,[testproject_id] => 1,[user_id] => 1,[refreshTree] => 1,[opt_requirements] => 1,[basehref] => http://10.1.17.113/tl19/,[goback_url] [^] => ), Array ([testcase_id] => 17,[tcversion_id] => 18,[version] => 1,[doAction] => doUpdate,[show_mode] => show,[testcase_name] => fff,[summary] => ,[preconditions] => ,[exec_type] => 1,[importance] => 2,[custom_field_0_6] => ,[custom_field_0_5] => ,[ot_removedLeft] => 6,[ot_removedRight] => ,[ot_addedLeft] => ,[ot_addedRight] => 6,[ot_newLeft] => 7,5,[ot_newRight] => 6,[ys-tproject_1_ext-comp-1001] => a:s%3A/1/3^s%3A/1/2^s%3A/1/6/16,[TL_lastTestPlanForUserID_1] => 5,[ys-planaddtc_1_1_ext-comp-1001] => a:s%3A/1/3^s%3A/1/9^s%3A/1/6,[ys-tproject_2_ext-comp-1001] => a:s%3A/2,[ys-planaddtc_2_1_ext-comp-1001] => a:s%3A/2/4^s%3A/2,[ys-requirement_spec12_ext-comp-1001] => a:s%3A/12,[ys-tproject_12_ext-comp-1001] => a:s%3A/12/13,[ys-planaddtc_12_1_ext-comp-1001] => a:s%3A/12/13^s%3A/12,[ys-undefinedext-comp-1001] => a:s%3A/12/13^s%3A/17/19^s%3A/1/6,[TL_execSetResults_tpn_view_status] => 1,[TL_execSetResults_bn_view_status] => 0,[TL_execSetResults_platform_notes_view_status] => 0,[TL_execSetResults_tsdetails_view_status] => 0,[TL_lastTestProjectForUserID_1] => 23,[ys-tproject_17_ext-comp-1001] => a:s%3A/17/19,[ys-planaddtc_17_1_ext-comp-1001] => a:s%3A/17/19,[ys-tproject_18_ext-comp-1001] => a:s%3A/18/34/24,[ys-tproject_23_ext-comp-1001] => a:s%3A/23,[ys-requirement_spec1_ext-comp-1001] => a:s%3A/1/2,[TL_user1_proj1_testPlanId] => 16,[ys-tl_table_results_by_status] => {"columns":[],"sort":{"field":"id_platform","direction":"DESC"},"group":"id_th_build"},[ys-tl_table_results_tc] => {"columns":[{"id":2,"width":67,"hidden":true}],"sort":{"field":"id_priority","direction":"DESC"},"group":"id_platform"},[ys-tl_table_results_by_tester_per_build] => {"columns":[{"id":0,"width":96,"hidden":true}],"sort":{"field":"id_progress","direction":"DESC"},"group":"id_build"},[ys-tl_table_tc_assigned_to_user_for_tplan_5] => {"columns":[{"id":0,"width":103,"hidden":true}],"sort":{"field":"id_Priority","direction":"DESC"},"group":"id_Build"},[PHPSESSID] => 8hki1mbp5scp8fl5g4ghkpui31,[ys-1_ext-comp-1001] => a:s%3A/1)) called at [/var/www/html/tl19/lib/testcases/tcEdit.php:90]

 ==============================================================================
TagsNo tags attached.
Database (MySQL,Postgres,etc)postgres
Browserff 3
PHP Version5.2.1
TestCaseID
QA Team - Task Workflow Status
Attached Filespatch file icon TestLink_0003849_1.patch [^] (1,667 bytes) 2010-10-05 06:13 [Show Content]

- Relationships
has duplicate 0004204closedfman Error query using prefix table 

-  Notes
(0011620)
amitkhullar (reporter)
2010-10-05 05:55

I am unable to reproduce this issue. Please elaborate more.
(0011621)
haba713 (reporter)
2010-10-05 06:14
edited on: 2010-10-05 06:25

See the patch http://mantis.testlink.org/file_download.php?file_id=1830&type=bug [^] for fixing the issue.

PostgreSQL 8.1 does not support table name alias in an update statement: http://www.postgresql.org/docs/8.1/static/sql-update.html [^]

PostgreSQL 8.2 (and later) has support for it:
http://www.postgresql.org/docs/8.2/static/sql-update.html [^]

(0011622)
amitkhullar (reporter)
2010-10-05 06:41

Thanks, i can read the error in code , "double table name" but it works fine on mysql but fails on postgres.(dont have it in my env, so it worked ;-))
(0011623)
amitkhullar (reporter)
2010-10-05 06:47

checked in cvs
(0011686)
fman (administrator)
2010-10-08 17:50

Patch does not work with Postgres -> crash
(0011691)
fman (administrator)
2010-10-09 08:00

Release 1.9 RC1

- Issue History
Date Modified Username Field Change
2010-10-05 04:58 skilletaudio New Issue
2010-10-05 05:55 amitkhullar Note Added: 0011620
2010-10-05 06:13 haba713 File Added: TestLink_0003849_1.patch
2010-10-05 06:14 haba713 Note Added: 0011621
2010-10-05 06:16 haba713 Note Edited: 0011621 View Revisions
2010-10-05 06:16 haba713 Note Edited: 0011621 View Revisions
2010-10-05 06:25 haba713 Note Edited: 0011621 View Revisions
2010-10-05 06:41 amitkhullar Note Added: 0011622
2010-10-05 06:47 amitkhullar Note Added: 0011623
2010-10-05 06:47 amitkhullar Status new => resolved
2010-10-05 06:47 amitkhullar Fixed in Version => 1.9 RC 1
2010-10-05 06:47 amitkhullar Resolution open => fixed
2010-10-05 06:47 amitkhullar Assigned To => amitkhullar
2010-10-08 17:50 fman Note Added: 0011686
2010-10-08 17:50 fman Status resolved => new
2010-10-08 18:28 fman Assigned To amitkhullar => fman
2010-10-08 18:28 fman Status new => assigned
2010-10-08 18:28 fman Status assigned => resolved
2010-10-09 08:00 fman Note Added: 0011691
2010-10-09 08:00 fman Status resolved => closed
2011-02-05 16:14 fman Relationship added has duplicate 0004204



Copyright © 2000 - 2020 MantisBT Team
Powered by Mantis Bugtracker