Mantis Bugtracker          
testlink.org

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0003847TestLinkTest Plan (builds, milestones, test assign)public2010-10-05 04:492012-09-01 19:58
Reporterskilletaudio 
Assigned Tofman 
PrioritynormalSeveritymajorReproducibilityalways
StatusclosedResolutionfixed 
PlatformFirefox3 + PostgresOSWindows VistaOS Version
Product Versiontestlink_1_9_rc1-qa-20100926 
Fixed in Version1.9.3 (2011 Q3 - bug fixing) 
Summary0003847: TL-34 Create plan as copy copies options not specified
DescriptionTL-34, test case - create test plan as copy OPTION A

1) Plan-specified test case priorities copied to new test plan although not specified
2) User roles copied to new test plan although not specified
Steps To ReproduceCreate test plan with all features expressed (user roles overriding inherited rols, tests with test plan priorities, test assignments, etc).

Create test plan, using original plan as copy. Select Copy Test Cases, Builds, Platfor Links only.

TagsNo tags attached.
Database (MySQL,Postgres,etc)postgres
BrowserFF 3
PHP Version5.2.1
TestCaseID
QA Team - Task Workflow StatusTBD
Attached Files

- Relationships
related to 0004016assignedfman Test Plan COPY AS - Add logic to FORCE some OPTIONS no matter user choice 
related to 0004017closedfman TL-34 Create plan as copy - Priorities are ALWAYS COPIED 

-  Notes
(0012441)
skilletaudio (reporter)
2010-11-14 02:14

Reproduced with RC1, per test plan TL-34.


1) Plan-specified test case priorities copied to new test plan although not specified

This is still true as indicated above.



2) User roles copied to new test plan although not specified

This behavior has changed, still failure - user that has 'Senior Test' role has 'No Rights' after copying test plan (without user roles options).
(0012445)
fman (administrator)
2010-11-14 09:36

TC 1

  1. Create Test Plan (SOURCE TESTPLAN)
  2. Create ONE BUILD
  3. DO NOT ASSIGN ANY test case to test plan -> test plan is EMPTY
  4. Assign specific Roles to users
  5. Create new TEST PLAN as copy
  6. Select ONLY COPY BUILDS
  7. Copy is done as REQUESTED -> Just BUILDS, Users has ONLY INHERITED ROLES
(0012446)
fman (administrator)
2010-11-14 09:47

TC 2

  1. Create Platforms
  2. Create Test Plan (SOURCE TESTPLAN)
  3. Create ONE BUILD
  4. Assign 3 Platforms to Test Plan
  5. DO NOT ASSIGN ANY test case to test plan -> test plan is EMPTY
  6. Assign specific Roles to users
  7. Create new TEST PLAN as copy
  8. Select ONLY COPY BUILDS
  9. Copy is done as REQUESTED -> Just BUILDS, Users has ONLY INHERITED ROLES
(0012447)
fman (administrator)
2010-11-14 09:52
edited on: 2010-11-14 09:53

TC 3

  1. Create Platforms
  2. Create Test Plan (SOURCE TESTPLAN)
  3. Create ONE BUILD
  4. Assign 3 Platforms to Test Plan
  5. ASSIGN test case to test plan + PLATFORM
  6. Assign specific Roles to users
  7. Create new TEST PLAN as copy
  8. Select ONLY COPY TEST CASES


      Result:
      ALSO PLATFORMS ARE COPIED because you can not copy test case assignment without having the platform links

(0012448)
fman (administrator)
2010-11-14 09:56
edited on: 2010-11-14 10:00

TC 4

  1. Create Platforms
  2. Create Test Plan (SOURCE TESTPLAN)
  3. Create ONE BUILD
  4. ASSIGN test case to test plan
  5. Assign 3 Platforms to Test Plan
  6. Assign specific Roles to users
  7. Create new TEST PLAN as copy
  8. Select ONLY COPY TEST CASES


      Result:
      ALSO PLATFORMS ARE COPIED =>

      REASON
      Since the addition of Platforms, test case versions are linked to Test Plan AND Platforms.
      this means, that not matter user choice, we will force Platforms COPY.
      This is a lazy approach, instead of complex one that requires understand what Platforms have been used on SOURCE Test Plan.

(0017260)
fman (administrator)
2012-09-01 19:58

1.9.4 released

- Issue History
Date Modified Username Field Change
2010-10-05 04:49 skilletaudio New Issue
2010-11-14 02:14 skilletaudio Note Added: 0012441
2010-11-14 09:36 fman Note Added: 0012445
2010-11-14 09:47 fman Note Added: 0012446
2010-11-14 09:52 fman Note Added: 0012447
2010-11-14 09:53 fman Note Edited: 0012447 View Revisions
2010-11-14 09:56 fman Note Added: 0012448
2010-11-14 10:00 fman Note Edited: 0012448 View Revisions
2010-11-14 10:17 fman Relationship added related to 0004016
2010-11-14 10:52 fman Issue cloned: 0004017
2010-11-14 10:52 fman Relationship added related to 0004017
2012-08-17 19:10 fman Task Workflow Status => TBD
2012-08-17 19:10 fman Status new => resolved
2012-08-17 19:10 fman Fixed in Version => 1.9.3 (2011 Q3 - bug fixing)
2012-08-17 19:10 fman Resolution open => fixed
2012-08-17 19:10 fman Assigned To => fman
2012-09-01 19:58 fman Note Added: 0017260
2012-09-01 19:58 fman Status resolved => closed



Copyright © 2000 - 2018 MantisBT Team
Powered by Mantis Bugtracker