Mantis Bugtracker          
testlink.org

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0003845TestLinkTest Project Managementpublic2010-10-05 04:372010-11-14 12:07
Reporterskilletaudio 
Assigned Toamitkhullar 
PrioritynormalSeveritymajorReproducibilityalways
StatusclosedResolutionfixed 
PlatformFirefox3 + PostgresOSWindows VistaOS Version
Product Versiontestlink_1_9_rc1-qa-20100926 
Fixed in Version1.9 (Prague) 
Summary0003845: TL-43 Delete Test Project creates DB backtrace
DescriptionTL-43 test case.
RESULTS:
 * Test project appeared to delete, but database error was reported and stacktrace printed.



Steps To Reproduce*Created test project with all enhance features enabled, active and public
*Defined a custom field (string on test case)
*Assigned custom field to test project
*Created Keyword
*Created Platform
*Test Specification:
  - Created test suite, with keyword assigned
  - Created test case with custom field defined and keyword set
* created test plan
* Assigned platform to test plan
* Assigned test case to test plan on the platform
* created build
* Executed test case with result = PASS.
* Delete test project
TagsNo tags attached.
Database (MySQL,Postgres,etc)Postgres
BrowserFirefox 3
PHP Version5.2.1
TestCaseID
QA Team - Task Workflow Status
Attached Fileslog file icon pg.log [^] (99,161 bytes) 2010-10-27 10:14
txt file icon error_and_backtrace.txt [^] (334,948 bytes) 2010-10-30 15:59
txt file icon error_and_backtrace-rc1.txt [^] (99,343 bytes) 2010-10-30 16:39 [Show Content]

- Relationships

-  Notes
(0011624)
amitkhullar (reporter)
2010-10-05 06:51

Please attach the error logs it will help in debug and save time.
(0011630)
fman (administrator)
2010-10-05 10:12

do not paste error log on note attach text file
(0011687)
amitkhullar (reporter)
2010-10-09 04:21

Please attach logs for more analysis to be done.
(0011851)
skilletaudio (reporter)
2010-10-11 03:06

Will confirm in RC1 and update with appropriate logs.
(0011876)
fman (administrator)
2010-10-13 12:50

Reminder sent to: amitkhullar

any news?
(0011900)
fman (administrator)
2010-10-14 12:24

Reminder sent to: amitkhullar

still watining for news
(0012094)
amitkhullar (reporter)
2010-10-27 10:21
edited on: 2010-10-27 10:28

Was able to replicate the issue , the DB Access Error - debug_print_backtrace() OUTPUT START is coming on Test Project Deletion on Postgres DB only. Reason unknown as of now.

The delete query executed though works fine for deletion otherwise. One reason which comes in my mind could be a postgres bug. Not sure though.

(0012103)
fman (administrator)
2010-10-27 18:39

what about Foreing Keys ?
(0012171)
fman (administrator)
2010-10-30 09:43

Reminder sent to: amitkhullar

Solving this is URGENT
(0012174)
amitkhullar (reporter)
2010-10-30 14:37

Closing this as of now, no error found otherwise apart from the stack trace print on Postgres only.
(0012175)
fman (administrator)
2010-10-30 15:11

Let me understand this:
each time project is deleted user will get dbtrace ?
(0012176)
skilletaudio (reporter)
2010-10-30 15:59

Hello all, please excuse my delay in replying, sorry for reopening but I want to provide this data.


I have re-created this in my environment (not in the RC1 yet, but the rc1-qa-20100926 build as before).

The project has all features enabled.

The project was not successfully deleted after the error in this case (still available in Project Management)

Attaching a txt file containing the backtrace and the errors generated by Postgres.
(0012177)
fman (administrator)
2010-10-30 16:03

We need a test on RC1
(0012182)
amitkhullar (reporter)
2010-10-30 16:14

I tested on RC 1 only but I am not sure what all is there on the reporter database. Probably we can request a copy of his database and then try looking into it. When I replicated this issue only the stack trace was there but the project got deleted as per the steps provided by reporter . Please provide your input Fman
(0012183)
skilletaudio (reporter)
2010-10-30 16:38

test results with RC1: Backtraces printed, but project deleted. Please discount latest report of project not deleting as being from an earlier build and an unclear environment.


I have installed RC1 and performed the test. The environment is a snapshotted VM before and after the deletion, so I can provide any data needed from the system.


Steps taken:
-Create test project with all features enabled.
-Create inventory
-Create and assign custom fields to project
-Create keywords
-Create requirements
-Create platform
-Create test cases, assign keywords, requirements to test cast.
-Create test plan
-Assign platform to test plan
-Assign test cases to platforms in test plan
-Assign requirements to test cases.
-Create build and execute test case on build.

Then attempt to delete the project.
Backtrace printed, test project page rendered below backtrace.

Attaching db errors and backtrace output.
(0012184)
amitkhullar (reporter)
2010-10-30 17:02

Thanks for the input its much clear now.
(0012187)
amitkhullar (reporter)
2010-10-30 18:21

Still I am unable to reproduce the error you have mentioned.

The only thing Fman I could find is custom fields table was not deleted on the deletion of the Test Project.

Fman : Could you look at that part? I was unable to find any code which causes the custom field table to deleted
(0012191)
fman (administrator)
2010-10-30 21:40
edited on: 2010-10-30 21:42

no need to ask for DB to user.
I've say on some previous note:
have you check delete order, because on postgres we are using FK.
If I have to look to suggested part => this mean I will work to fix the issue and this is not my intention because I've other work to do in order to release 1.9.

Can you read the attached logs CAREFULLY, please.

(0012194)
amitkhullar (reporter)
2010-10-31 08:12

Fixed the issue in cvs head
(0012195)
fman (administrator)
2010-10-31 09:09

On log:
ERROR: update or delete on "builds" violates foreign key constraint "executions_build_id_fkey" on "executions"
DETAIL: Key (id)=(1) is still referenced from table "executions".
ERROR: update or delete on "testplans" violates foreign key constraint "builds_testplan_id_fkey" on "builds"
DETAIL: Key (id)=(9) is still referenced from table "builds".
ERROR: update or delete on "nodes_hierarchy" violates foreign key constraint "testplans_id_fkey" on "testplans"
DETAIL: Key (id)=(9) is still referenced from table "testplans".

Please explain how deleting CF solves this Foreing Key Problems
(0012197)
amitkhullar (reporter)
2010-10-31 13:45

Fman,

You misunderstood this, the issue wasnot fixed by the custom field deletion.

That is a separate observation I had as a query for you since we are not deleting the custom fields anywhere while deleting the project. Saw a code comment which I posted for your inputs


This issue was fixed by the order of the tables being deleted in Postgres.
(0012199)
fman (administrator)
2010-10-31 15:07

Amit:
please try to write things in a way we do not waste time becasue we do not understand what is happening.
(0012201)
amitkhullar (reporter)
2010-10-31 17:05

That was just an observation that I wanted to understand how should it be implemented, if required. The comments in code say otherwise.

This is still an open item though not related to this bug, that upon deletion of a test project ( or the last project ) the custom fields still exist in the database and are not deleted. As soon as u reach a point that there is no project in the TL and u recreate a new Project the custom fields created earlier already exist and can be straight away assigned to the new created test project.
(0012202)
fman (administrator)
2010-10-31 17:12

Amit:
please explain me why CF has to be deleted ?
As an example:
Why we do not delete users when we delete all test project on system ?
can you find any parallel between both situations ?
(0012516)
fman (administrator)
2010-11-14 12:07

1.9 (Prague) Released

- Issue History
Date Modified Username Field Change
2010-10-05 04:37 skilletaudio New Issue
2010-10-05 06:51 amitkhullar Note Added: 0011624
2010-10-05 10:12 fman Note Added: 0011630
2010-10-05 10:12 fman Assigned To => amitkhullar
2010-10-05 10:12 fman Status new => assigned
2010-10-09 04:21 amitkhullar Note Added: 0011687
2010-10-09 04:21 amitkhullar Status assigned => feedback
2010-10-11 03:06 skilletaudio Note Added: 0011851
2010-10-11 03:06 skilletaudio Status feedback => assigned
2010-10-13 12:50 fman Note Added: 0011876
2010-10-14 12:24 fman Note Added: 0011900
2010-10-27 10:14 amitkhullar File Added: pg.log
2010-10-27 10:21 amitkhullar Note Added: 0012094
2010-10-27 10:28 amitkhullar Note Edited: 0012094 View Revisions
2010-10-27 18:39 fman Note Added: 0012103
2010-10-30 09:43 fman Note Added: 0012171
2010-10-30 14:37 amitkhullar Note Added: 0012174
2010-10-30 14:37 amitkhullar Status assigned => resolved
2010-10-30 14:37 amitkhullar Resolution open => no change required
2010-10-30 15:11 fman Note Added: 0012175
2010-10-30 15:59 skilletaudio Note Added: 0012176
2010-10-30 15:59 skilletaudio Status resolved => assigned
2010-10-30 15:59 skilletaudio Resolution no change required => reopened
2010-10-30 15:59 skilletaudio File Added: error_and_backtrace.txt
2010-10-30 16:03 fman Note Added: 0012177
2010-10-30 16:14 amitkhullar Note Added: 0012182
2010-10-30 16:38 skilletaudio Note Added: 0012183
2010-10-30 16:39 skilletaudio File Added: error_and_backtrace-rc1.txt
2010-10-30 17:02 amitkhullar Note Added: 0012184
2010-10-30 18:21 amitkhullar Note Added: 0012187
2010-10-30 21:40 fman Note Added: 0012191
2010-10-30 21:41 fman Note Edited: 0012191 View Revisions
2010-10-30 21:42 fman Note Edited: 0012191 View Revisions
2010-10-31 08:12 amitkhullar Note Added: 0012194
2010-10-31 08:12 amitkhullar Status assigned => resolved
2010-10-31 08:12 amitkhullar Fixed in Version => 1.9 (Prague)
2010-10-31 08:12 amitkhullar Resolution reopened => fixed
2010-10-31 09:09 fman Note Added: 0012195
2010-10-31 09:10 fman Status resolved => feedback
2010-10-31 13:45 amitkhullar Note Added: 0012197
2010-10-31 15:07 fman Note Added: 0012199
2010-10-31 17:05 amitkhullar Note Added: 0012201
2010-10-31 17:12 fman Note Added: 0012202
2010-10-31 17:12 amitkhullar Status feedback => resolved
2010-11-14 12:07 fman Note Added: 0012516
2010-11-14 12:07 fman Status resolved => closed



Copyright © 2000 - 2020 MantisBT Team
Powered by Mantis Bugtracker