Mantis Bugtracker          
testlink.org

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0003831TestLinkInventory / Platformspublic2010-10-02 21:082011-03-18 19:08
Reporterdifool 
Assigned Tofman 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSWindowsOS VersionXP SP3
Product Version 
Fixed in Version1.9 (Prague) 
Summary0003831: TL19RC1 - Platforms Management - Create Platform with Existent NAME - Lack of controls.
DescriptionMinor bug

Exactly same name is controlled.
Using space character at beginning or end is controlled.
Using empty character at beginning or end is not controlled.

Use of special char not controlled (e.g. chr(255) instead of chr(32) ) so you can create the followings platforms:
ptf1
ptf1 (notice the chr(255) at the end).
ptf1 (notice the chr(255) at the beginning).
Steps To Reproduce 
Additional InformationFor the following TC:
http://testlink.bplaced.net/linkto.php?tprojectPrefix=TL&item=testcase&id=TL-14 [^]
TagsNo tags attached.
Database (MySQL,Postgres,etc)MySQL 5.1.49
BrowserMozilla/5.0 (Windows; U; Windows NT 5.1; fr; rv:1.9.2.10) Gecko/20100914 Firefox/3.6.10 ( .NET CLR 3.5.30729).
PHP VersionPHP 5.3.3
TestCaseID
QA Team - Task Workflow Status
Attached Files

- Relationships

-  Notes
(0011588)
fman (administrator)
2010-10-03 09:37

>> Using space character at beginning or end is controlled.
>> Using empty character at beginning or end is not controlled.
has to be removed using trim()
(0011589)
fman (administrator)
2010-10-03 09:39

regarding char(255), on internet I've found (http://htmlhelp.com/reference/charset/iso224-255.html [^])
255 yuml y umlaut

then is not space
(0011591)
fman (administrator)
2010-10-03 09:46
edited on: 2010-10-03 09:49

Tested on CVS code.

create platform
insert following string
 '    NAME  '
(' are used here to signal start and end of string)
save
Edit platform
spaces has been removed

Create a new platform with name
 'NAME  '
(' are used here to signal start and end of string)
save
Got message Platform name NAME already exists

=> works for me

I'm not able to insert char(255)

(0011592)
difool (reporter)
2010-10-03 09:48

chr(255) is well known for old geek .. type on alt+255 on your keyboard and you will get the invisible character, often used in past to put secret space.

This is the end character of standard ASCII table, not unicode/ansi table.

I've to do nothing peculiar to insert this, just typing ALTGR+255 to have it, this is not a special trick to access it. Of course could depends on your OS and current regional settings.
(0011593)
fman (administrator)
2010-10-03 09:50

I know very well the ALT + number way to add special chars, but on my keyword I'm unable to create
(0011594)
difool (reporter)
2010-10-03 09:54

Ok so can't be easily managed unless checking string after normalization. Assuming that if people use this char, it's at their responsibility and could involve in confusing name .. but this is extreme testing ;)

So it works for normal usage, entry bug can be closed for me.
(0011596)
fman (administrator)
2010-10-03 09:59

I appreciate extreme testing, absolutely, but we need to understand effort needed to cope with 'evil users' :)

thanks for your work
(0014025)
fman (administrator)
2011-03-18 19:08

release - 1.9.2 - 20110320

- Issue History
Date Modified Username Field Change
2010-10-02 21:08 difool New Issue
2010-10-03 09:37 fman Note Added: 0011588
2010-10-03 09:39 fman Note Added: 0011589
2010-10-03 09:46 fman Note Added: 0011591
2010-10-03 09:46 fman Note Edited: 0011591 View Revisions
2010-10-03 09:48 difool Note Added: 0011592
2010-10-03 09:49 fman Note Edited: 0011591 View Revisions
2010-10-03 09:50 fman Note Added: 0011593
2010-10-03 09:54 difool Note Added: 0011594
2010-10-03 09:59 fman Note Added: 0011596
2010-10-03 10:40 fman Assigned To => fman
2010-10-03 10:40 fman Status new => assigned
2010-12-19 16:19 fman Status assigned => resolved
2010-12-19 16:19 fman Fixed in Version => 1.9 (Prague)
2010-12-19 16:19 fman Resolution open => fixed
2011-03-18 19:08 fman Note Added: 0014025
2011-03-18 19:08 fman Status resolved => closed



Copyright © 2000 - 2020 MantisBT Team
Powered by Mantis Bugtracker