Mantis Bugtracker          
testlink.org

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0003818TestLinkKeywordspublic2010-09-30 15:132010-10-09 08:00
Reportergkarcher 
Assigned Toasimon 
PrioritynormalSeverityminorReproducibilityhave not tried
StatusclosedResolutionfixed 
Platformwindows XP (client)OSTestlink deployed in RhelOS Version5update4
Product Version1.9 Beta 6 
Fixed in Version1.9 RC 1 
Summary0003818: Filtering Keywords on add/remove testcase is not working well
DescriptionHi there,

This ticket to track that the filtering on add/remove testcases (in a testplan) seems not working fine.
Steps To ReproduceI've created several testcases (5 tests)
I've created a noreg keyword (for non regression)
I've assigned this keyword to 3 of the 5 testcases.

I've created a testplan.

When I try to add testcases into this new testplan, I can see the 5 ones.
When I select in the filter box (dropdown list) only the noreg and click on apply I get 0 results (I tried with both logical 'And' and 'Or')

I add a screenshot...
Additional InformationI'm logged in as admin role.
TagsNo tags attached.
Database (MySQL,Postgres,etc)mysql
BrowserFirefox 3.x
PHP Version5.2
TestCaseID
QA Team - Task Workflow Status
Attached Filespng file icon screenshot01.png [^] (20,743 bytes) 2010-09-30 15:13

- Relationships
duplicate of 0003814closedasimon 'And' doesn't work when filtering by keywords 

-  Notes
(0011550)
asimon (developer)
2010-10-01 06:59

There has been a recent fix for the keyword filtering on CVS. See issue 3814.
I can not reproduce this bug on current code, so I think it has been solved with that fix.
Please wait for next available public release and then retest. Open a new issue if you should find that the bug is still persisting.
(0011727)
fman (administrator)
2010-10-09 08:00

Release 1.9 RC1

- Issue History
Date Modified Username Field Change
2010-09-30 15:13 gkarcher New Issue
2010-09-30 15:13 gkarcher File Added: screenshot01.png
2010-10-01 06:56 asimon Relationship added duplicate of 0003814
2010-10-01 06:59 asimon Note Added: 0011550
2010-10-01 06:59 asimon Status new => resolved
2010-10-01 06:59 asimon Fixed in Version => 1.9 RC 1
2010-10-01 06:59 asimon Resolution open => fixed
2010-10-01 06:59 asimon Assigned To => asimon
2010-10-09 08:00 fman Note Added: 0011727
2010-10-09 08:00 fman Status resolved => closed



Copyright © 2000 - 2020 MantisBT Team
Powered by Mantis Bugtracker