Mantis Bugtracker          
testlink.org

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0003765TestLinkRequirement Managementpublic2010-09-09 09:442011-03-18 19:07
Reporteramitkhullar 
Assigned Toasimon 
PriorityhighSeveritymajorReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version1.9 Beta 6 
Fixed in Version1.9.2 (2011 Q2 - bug fixing) 
Summary0003765: Req. Spec Doc ID disappears when you filter requirements
DescriptionFilter the requirements on the basis of Req. Type and Req. Spec Type. It shows as an empty value int he tree before the :: , see attached image for more details once the filter is applied.
TagsNo tags attached.
Database (MySQL,Postgres,etc)1.9.6
Browser
PHP Version
TestCaseID
QA Team - Task Workflow Status
Attached Filesjpg file icon req_error.jpg [^] (182,856 bytes) 2010-09-09 09:44

- Relationships

-  Notes
(0011308)
asimon (developer)
2010-09-09 15:51

I am not able to reproduce this error, it works fine for me.
(0011310)
amitkhullar (reporter)
2010-09-09 16:05
edited on: 2010-09-09 16:06

May be this issue is linked to http://mantis.testlink.org/view.php?id=3764, [^] what I did was assigned those specific req spec as system function which do get displayed after applying the filter. as shown in pic

(0011318)
amitkhullar (reporter)
2010-09-09 18:20

I verified that the req tree structure need to have similar nodes below it as in the image.
(0011319)
fman (administrator)
2010-09-09 21:23

>> what I did was assigned those specific req spec
>> as system function which do get displayed after
>> applying the filter. as shown in pic

Please explain clearly what this sentence means.
(0011322)
amitkhullar (reporter)
2010-09-10 03:27

What I meant was that I assigned a Req. Type = System Function to some requirements and then use the filter in the tree to search those requirements having that req. type , and it then disappears the req. spec id from the tree as shown in the figure and this happens only when you have similar req. spec nodes under the main node as the problem explained in the bug 0003764.
(0011339)
Julian (reporter)
2010-09-13 12:28

@amit: is this one also fixed, as 0003764 has been fixed?
(0011340)
amitkhullar (reporter)
2010-09-13 13:16

Nope, actually I am not that familiar with the tree code so dint attempt it yet.
(0012244)
asimon (developer)
2010-11-02 10:52

I think this was caused by 3764, so can it be resolved?
(0012253)
fman (administrator)
2010-11-03 06:34

NO user feedback -> resolve
(0012467)
fman (administrator)
2010-11-14 12:07

1.9 (Prague) Released
(0013852)
Julian (reporter)
2011-03-11 12:57

issue exists for req specs with no direct requirement children but another req spec that has direct requirement children:

. req spec 1
.. req spec 2
... req 1

-> doc id for req spec 1 won't be shown.
(0013853)
Julian (reporter)
2011-03-11 13:42

fixed.

master: http://gitorious.org/testlink-ga/testlink-code/commit/91c9c70f9d5839fa05791e5e5ce3b060929dcbf0 [^]

1.9 branch: http://gitorious.org/testlink-ga/testlink-code/commit/a0ddca85eeb02b48c70070211c041f14e13cde3e [^]
(0013918)
fman (administrator)
2011-03-18 19:07

release - 1.9.2 - 20110320

- Issue History
Date Modified Username Field Change
2010-09-09 09:44 amitkhullar New Issue
2010-09-09 09:44 amitkhullar File Added: req_error.jpg
2010-09-09 15:51 asimon Note Added: 0011308
2010-09-09 16:05 amitkhullar Note Added: 0011310
2010-09-09 16:05 amitkhullar Note Edited: 0011310 View Revisions
2010-09-09 16:06 amitkhullar Note Edited: 0011310 View Revisions
2010-09-09 18:19 amitkhullar Relationship added related to 0003764
2010-09-09 18:20 amitkhullar Note Added: 0011318
2010-09-09 21:23 fman Note Added: 0011319
2010-09-09 21:24 fman Relationship deleted related to 0003764
2010-09-10 03:27 amitkhullar Note Added: 0011322
2010-09-13 12:28 Julian Note Added: 0011339
2010-09-13 13:16 amitkhullar Note Added: 0011340
2010-11-02 10:52 asimon Note Added: 0012244
2010-11-03 06:34 fman Note Added: 0012253
2010-11-03 06:34 fman Status new => resolved
2010-11-03 06:34 fman Fixed in Version => 1.9 (Prague)
2010-11-03 06:34 fman Resolution open => fixed
2010-11-03 06:34 fman Assigned To => fman
2010-11-14 12:07 fman Note Added: 0012467
2010-11-14 12:07 fman Status resolved => closed
2011-03-11 12:50 Julian Assigned To fman => asimon
2011-03-11 12:50 Julian Status closed => assigned
2011-03-11 12:57 Julian Note Added: 0013852
2011-03-11 13:42 Julian Note Added: 0013853
2011-03-11 13:42 Julian Status assigned => resolved
2011-03-11 13:49 Julian Fixed in Version 1.9 (Prague) => 1.9.2 (2011 Q2 - bug fixing)
2011-03-18 19:07 fman Note Added: 0013918
2011-03-18 19:07 fman Status resolved => closed



Copyright © 2000 - 2019 MantisBT Team
Powered by Mantis Bugtracker