Mantis Bugtracker          
testlink.org

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0003751TestLinkExport/Importpublic2010-09-06 14:342010-10-09 08:00
Reportertwelve 
Assigned Tofman 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version1.9 Beta 6 
Fixed in Version1.9 RC 1 
Summary0003751: New attribute "execution type" makes old XML import files incompatible
DescriptionThe fix for Bug 0003543 introduced a new attribute called "execution_type" into the data structure of XML files with which you can import test results. However the way this new attribute was implemented made it mandatory. That means that all XML files without "execution_type" elements can no longer be imported into Testlink 1.9 Beta 6.
Steps To ReproduceTry to import test results with a XML file that has no execution_type child elements. Very simple example:

<results>
  <testcase id="1">
    <result>p</result>
  </testcase>
</results>

This gives you the error message: "Execution type code 0 is not valid"
Additional InformationIn lib/results/resultsImport.php in line 450 the value of "$xmlTCExec->execution_type" is read and then typecasted to int. Since no execution_type was specified in the example above this means the result is 0.
Then in line 619 it is checked if execution_type has been set. This check returns always TRUE, since isset() of any number returns TRUE.

Besides checking if execution_type has been set, it must also be checked if it is != 0, something like:

// BUGID 3543
if($checks['status_ok'] && isset($execValues['execution_type']) && $execValues['execution_type'] )
{
TagsNo tags attached.
Database (MySQL,Postgres,etc)Mysql
Browser
PHP Version5.2.10
TestCaseID
QA Team - Task Workflow Status
Attached Files

- Relationships
has duplicate 0003975closedfman Problem in import "result.xml" 

-  Notes
(0011286)
fman (administrator)
2010-09-06 20:02

then we will set to MANUAL
(0011743)
fman (administrator)
2010-10-09 08:00

Release 1.9 RC1

- Issue History
Date Modified Username Field Change
2010-09-06 14:34 twelve New Issue
2010-09-06 20:02 fman Note Added: 0011286
2010-09-06 20:03 fman Assigned To => fman
2010-09-06 20:03 fman Status new => assigned
2010-09-26 15:26 fman Fixed in Version => 1.9 RC 1
2010-09-26 15:26 fman Status assigned => resolved
2010-09-26 15:26 fman Resolution open => fixed
2010-10-09 08:00 fman Note Added: 0011743
2010-10-09 08:00 fman Status resolved => closed
2010-11-03 19:45 fman Relationship added has duplicate 0003975



Copyright © 2000 - 2019 MantisBT Team
Powered by Mantis Bugtracker