Mantis Bugtracker          
testlink.org

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0003729TestLinkDatabase Generalpublic2010-08-30 19:492010-08-31 20:26
Reporterrtessier 
Assigned Tofman 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionfixed 
PlatformFirefox 3.6.8OSUbuntuOS Version10.04
Product Version 
Fixed in Version1.9 Beta 6 
Summary0003729: testcase::get_by_name fails to get test cases with titles longer than 100 characters
DescriptionTest cases with titles longer than 100 characters can be added through the API (GUI limits entries to 100 characters), however the title gets truncated to 100 characters since the table entry in nodes_hierarchy is defined as a varchar(100).

If calling the get_by_name method (note that this applies to all entries in nodes_hierarchy, not just test cases) with the same test case name, it will return an empty record set.

What I did to fix this locally is to use the 'substr' function to limit the length of the title used to search the database.
Steps To Reproduce1- Create a test case with a title longer than 100 characters through the API (createTestCase).
2- Call the testcase::get_by_name method with the title used above.
TagsNo tags attached.
Database (MySQL,Postgres,etc)mysql Ver 14.14 Distrib 5.1.41
Browser
PHP Version
TestCaseID
QA Team - Task Workflow Status
Attached Files

- Relationships

-  Notes
(0011008)
fman (administrator)
2010-08-31 20:26

Release BETA 6 - 20100831

- Issue History
Date Modified Username Field Change
2010-08-30 19:49 rtessier New Issue
2010-08-31 18:12 fman Assigned To => fman
2010-08-31 18:12 fman Status new => assigned
2010-08-31 20:14 fman Status assigned => resolved
2010-08-31 20:14 fman Fixed in Version => 1.9 Beta 6
2010-08-31 20:14 fman Resolution open => fixed
2010-08-31 20:26 fman Note Added: 0011008
2010-08-31 20:26 fman Status resolved => closed



Copyright © 2000 - 2019 MantisBT Team
Powered by Mantis Bugtracker