Mantis Bugtracker          
testlink.org

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0003723TestLinkReportspublic2010-08-27 09:392010-08-31 20:26
ReporterJulian 
Assigned Tofman 
PriorityhighSeverityminorReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version1.9 Beta 5 
Fixed in Version1.9 Beta 6 
Summary0003723: Test Cases without Tester Assignment shows test cases multiple times
DescriptionTest Cases without Tester Assignment shows some test cases multiple times
Steps To Reproducecant provide information how to reproduce. error occurs on our migrated db used in live system.

if someone else encountered this problem please let us know.
TagsNo tags attached.
Database (MySQL,Postgres,etc)MySQL
Browser
PHP Version
TestCaseID
QA Team - Task Workflow Status
Attached Filesjpg file icon issue-3723-06.jpg [^] (23,902 bytes) 2010-08-30 10:26

- Relationships

-  Notes
(0010996)
Julian (reporter)
2010-08-30 07:56

seems to be related to execution.
sql results contains multiple exec_ids.

report should check all test cases that
1) have not been executed
and are currently
2) not assigned
for the selected test plan from reports.
(0010997)
fman (administrator)
2010-08-30 10:26
edited on: 2010-08-30 10:28

In order to understand how to solve this we need what information (column by column) has to be displayed.
I've taking as model output from report: Test Case Assignment Overview

please give a look at attached immage and let me know if this is the outcome you expect.

Please explain why STATUS has to be not run, and if you means ON ALL Builds or last (created) build.

(0010998)
Julian (reporter)
2010-08-30 14:13
edited on: 2010-08-30 15:18

Report will be changed to show:

1) if platforms are not used
test cases that have never been executed for test plan (-> not executed for any build within test plan) AND are not assigned to ANY build

2) if platforms are enabled
test cases that have never been executed for each platform AND are not assigned to any build

Example for 2)

1. Test case "tc1" is added for 3 platforms "mac","linux","win"
-> report shows tc1 three times: "tc1 - mac", "tc1 - linux", "tc1 -win". (tc1 is not assigned and not executed for any platform)

2. assign tc1 for execution on platform linux
-> report shows tc1 two times: "tc-1 - mac", "tc1 - win" (tc1 is assigned for execution on linux, tc1 is not assigned for execution and not executed for mac and win)

3. assign tc1 for execution on platform win and execute
-> report shows tc1 one time: "tc1 - mac" (tc1 is assigned for execution on linux, tc1 is assigned AND executed for win, tc1 is not assigned for execution and not executed for mac)

4. remove execution assignment of tc1 for platform win
-> report shows tc1 one time: "tc1 - mac" (tc1 is assigned for execution on linux, tc1 is executed for win, tc1 is not assigned for execution and not executed for mac)

(0011001)
Eloff (reporter)
2010-08-31 08:01

It would be good to have a short description of this in the report, because it is not obvious to users, and wasn't to me either
(0011002)
Julian (reporter)
2010-08-31 08:02

already done:

This report shows all test cases, which have not been executed for any build of the test plan and have not been assigned to any build for execution. If platforms are assigned to this test plan, the condition has to be fulfilled for each platform seperately.
(0011003)
Eloff (reporter)
2010-08-31 08:09

great :)
(0011009)
fman (administrator)
2010-08-31 20:26

Release BETA 6 - 20100831

- Issue History
Date Modified Username Field Change
2010-08-27 09:39 Julian New Issue
2010-08-30 07:56 Julian Note Added: 0010996
2010-08-30 08:03 fman Assigned To => fman
2010-08-30 08:03 fman Status new => assigned
2010-08-30 10:26 fman Note Added: 0010997
2010-08-30 10:26 fman File Added: issue-3723-06.jpg
2010-08-30 10:27 fman Note Edited: 0010997 View Revisions
2010-08-30 10:28 fman Note Edited: 0010997 View Revisions
2010-08-30 14:13 Julian Note Added: 0010998
2010-08-30 15:18 fman Note Edited: 0010998 View Revisions
2010-08-31 08:01 Eloff Note Added: 0011001
2010-08-31 08:02 Julian Note Added: 0011002
2010-08-31 08:09 Eloff Note Added: 0011003
2010-08-31 19:41 Julian Status assigned => resolved
2010-08-31 19:41 Julian Fixed in Version => 1.9 Beta 6
2010-08-31 19:41 Julian Resolution open => fixed
2010-08-31 20:26 fman Note Added: 0011009
2010-08-31 20:26 fman Status resolved => closed



Copyright © 2000 - 2019 MantisBT Team
Powered by Mantis Bugtracker