Mantis Bugtracker          
testlink.org

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0003722TestLinkReportspublic2010-08-27 08:352010-08-31 20:26
ReporterJulian 
Assigned ToJulian 
PrioritynormalSeveritymajorReproducibilityhave not tried
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version 
Fixed in Version1.9 Beta 6 
Summary0003722: Not run Test Cases report requires review
DescriptionAs we changed assignment of test cases at build level we have to think this report over again.

test case can be assigned on 3 builds to different testers -> build column is rquired. (asuming option 1. [see below] is the right one)

if option 2. is the right one it is only necessary to show a test case once.

Please let me also know what this report should express.

1. show test cases that have NOT been executed for at least 1 build -> show test cases as unexecuted for all fitting builds.
2. show test cases that have NO execution for all builds. (not executed in test plan) -> if test case has been executed for at least 1 build -> do not show here


//edit: read next comment too
Steps To Reproduce1. Create Test project issue 3722
2. Create Test Suite
3. Create 2 test cases
4. create test plan
5. create 2 builds
6. add test cases to plan
7. open not run report: 2 test cases shown -> OK
8. assign test cases to same user for both builds
9. open not run report: every test case is shown 2 times. (see attached screenshot 1) -> build is missing to understand
10. execute test case for 1 build
11. open not run report: test case completely disappears -> Option 2 seems to be used right now: show test cases that have NO execution (see attached screenshot 2)
TagsNo tags attached.
Database (MySQL,Postgres,etc)MySQL
Browser
PHP Version
TestCaseID
QA Team - Task Workflow Status
Attached Filespng file icon 1.PNG [^] (13,254 bytes) 2010-08-27 09:15


png file icon 2.PNG [^] (11,605 bytes) 2010-08-27 09:15

- Relationships

-  Notes
(0010967)
Julian (reporter)
2010-08-27 11:40

after thinking about this for a while i would prefer this solution:

if platforms are not used in testplan:
show test case only once if it has status not run for ALL builds
<->
if test case has been executed with at least 1 build -> do not show in report

=> no build column necessary

if platforms are used in testplan:
show test case for each platform for which status is not run for ALL builds.
<->
if test case has been executed with at least 1 build for specific platform -> do not show in report for this platform
(0011007)
Julian (reporter)
2010-08-31 13:20

not run test cases report has been refactored and now should work again.
feel free to reopen if you encounter any problems.

function getNotExecutedLinkedTCVersionsDetailed used for this report before has been marked as deprecated on testplan.class.php as it was only used for this report
(0011018)
fman (administrator)
2010-08-31 20:26

Release BETA 6 - 20100831

- Issue History
Date Modified Username Field Change
2010-08-27 08:35 Julian New Issue
2010-08-27 09:14 Julian Description Updated View Revisions
2010-08-27 09:14 Julian Steps to Reproduce Updated View Revisions
2010-08-27 09:15 Julian Steps to Reproduce Updated View Revisions
2010-08-27 09:15 Julian File Added: 1.PNG
2010-08-27 09:15 Julian File Added: 2.PNG
2010-08-27 11:40 Julian Note Added: 0010967
2010-08-27 11:41 Julian Summary Not run Test Cases report requires Build Column => Not run Test Cases report requires review
2010-08-27 11:41 Julian Description Updated View Revisions
2010-08-31 09:39 Julian Assigned To => Julian
2010-08-31 09:39 Julian Status new => assigned
2010-08-31 13:20 Julian Note Added: 0011007
2010-08-31 13:20 Julian Status assigned => resolved
2010-08-31 13:20 Julian Fixed in Version => 1.9 Beta 6
2010-08-31 13:20 Julian Resolution open => fixed
2010-08-31 14:25 asimon Relationship added related to 0003676
2010-08-31 20:26 fman Note Added: 0011018
2010-08-31 20:26 fman Status resolved => closed



Copyright © 2000 - 2019 MantisBT Team
Powered by Mantis Bugtracker