Mantis Bugtracker          
testlink.org

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0003716TestLinkUser Interface Generalpublic2010-08-26 00:442010-11-14 12:07
Reporteristream 
Assigned Toasimon 
PrioritynormalSeverityfeature requestReproducibilityalways
StatusclosedResolutionfixed 
PlatformALLOSALLOS VersionALL
Product Version1.9 Beta 5 
Fixed in Version1.9 (Prague) 
Summary0003716: Dates pull downs should be changed to calendar interface everywhere, for exampl in filters etc.
DescriptionCurrently the pull down menu for date ranges is crude, a real calendar interface like in most web interfaces available today would be useful.
TagsNo tags attached.
Database (MySQL,Postgres,etc)None
Browser
PHP Version
TestCaseID
QA Team - Task Workflow Status
Attached Filespng file icon tl-dateproblems.png [^] (4,987 bytes) 2010-10-23 15:25


png file icon tl-date-pickerproblems.png [^] (10,897 bytes) 2010-10-23 15:29

- Relationships

-  Notes
(0012019)
asimon (developer)
2010-10-21 14:58

I just replaced the old inputs by ext js calendar for req search, tc search and build editing pages.
(0012022)
Julian (reporter)
2010-10-21 18:05
edited on: 2010-10-21 18:07

requirements for this change:

must have
1) calender like used on event viewer has to be reused (ext.datepicker) - reuse code
2) input field has to allow manual input -> needs to be validated
3) use calender icon to open calender

nice to have
4) labels within calender should be multilanguage (http://dev.sencha.com/deploy/dev/docs/?class=Ext.DatePicker [^] - options to achieve this are available)

locations where this calender should be available
- Event Viewer
- Req Search
- TC Search
- Build creation
- Custom fields
- Milestones
- Report -> Query Metrics
- ...

(0012030)
Julian (reporter)
2010-10-22 09:36

4) has been done by fixing 0003924 - localization of ext components
(0012036)
asimon (developer)
2010-10-22 14:28

Now also done for milestone creation/editing and query metrics.
(0012053)
fman (administrator)
2010-10-23 15:24
edited on: 2010-10-23 15:25

locatization has problems -> see attached image -> date displayed in MM/DD/YYYY

(0012054)
Julian (reporter)
2010-10-23 15:42
edited on: 2010-10-23 15:43

date format is always the same, it does not concider localization settings as it has always been on event viewer before - you request a new feature

(0012055)
fman (administrator)
2010-10-23 15:45
edited on: 2010-10-23 15:45

I'm not asking for a new feature:
Before this change I got three inputs in the right order following locatization -> and this is what has to coninue to be -> need to be urgently fixed before next week end because i blocking 1.9 release.

(0012532)
fman (administrator)
2010-11-14 12:07

1.9 (Prague) Released

- Issue History
Date Modified Username Field Change
2010-08-26 00:44 istream New Issue
2010-08-27 17:59 fman Priority high => normal
2010-08-27 17:59 fman Summary istream: Dates pull downs should be changed to calendar interface everywhere, for exampl in filters etc. => Dates pull downs should be changed to calendar interface everywhere, for exampl in filters etc.
2010-10-21 14:58 asimon Note Added: 0012019
2010-10-21 15:50 Julian Assigned To => asimon
2010-10-21 15:50 Julian Status new => assigned
2010-10-21 18:05 Julian Note Added: 0012022
2010-10-21 18:07 Julian Note Edited: 0012022 View Revisions
2010-10-22 09:36 Julian Note Added: 0012030
2010-10-22 14:28 asimon Note Added: 0012036
2010-10-23 15:24 fman Note Added: 0012053
2010-10-23 15:25 fman File Added: tl-dateproblems.png
2010-10-23 15:25 fman Note Edited: 0012053 View Revisions
2010-10-23 15:26 fman Relationship added parent of 0003930
2010-10-23 15:29 fman File Added: tl-date-pickerproblems.png
2010-10-23 15:42 Julian Note Added: 0012054
2010-10-23 15:43 Julian Note Edited: 0012054 View Revisions
2010-10-23 15:45 fman Note Added: 0012055
2010-10-23 15:46 fman Note Edited: 0012055 View Revisions
2010-10-27 13:26 asimon Status assigned => resolved
2010-10-27 13:26 asimon Fixed in Version => 1.9 (Prague)
2010-10-27 13:26 asimon Resolution open => fixed
2010-11-14 12:07 fman Note Added: 0012532
2010-11-14 12:07 fman Status resolved => closed



Copyright © 2000 - 2019 MantisBT Team
Powered by Mantis Bugtracker