Mantis Bugtracker          
testlink.org

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0003708TestLinkCustom fieldspublic2010-08-25 08:052010-08-31 20:26
ReporterJulian 
Assigned Tofman 
PriorityhighSeverityminorReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version1.9 Beta 5 
Fixed in Version1.9 Beta 6 
Summary0003708: Usability improvements for Custom Field Creation/Editing
DescriptionCustom Field Combinations:

Available for "Test Suite":
- Test Suite / Test Spec Design:
-> OK, but not necessary to offer "Enable on" Field, when chosing "Test Suite"
->Should behave like when selecting "Requirement" -> "Enable on" Field gets hidden.

Available for "Test Plan":
- Test Plan / Test Spec Design (CF is shown when editing/creating test plan):
-> Combination should be called "Test Plan / Test Plan Design" and it is not necessary to offer "Enable on" Field, when choosing "Test Suite"
->Should behave like when selecting "Requirement" -> "Enable on" Field gets hidden.

Available for "Test Case":
- Test Case / Test Execution -> OK (CF is shown on execution)
- Test Case / Test Spec Design -> OK (CF is shown when editing/creating TC)
- Test Case / Test Plan Design:
-> does not make sense in my eyes. Custom Field is not shown for test cases and not shown for test plans. -> do not allow this combination

Available for Req. Spec. -> OK (CF is shown when editing/creating a req. spec.)

Available for Req -> OK (CF is shown when editing/creating a req.)

Conclusion:
1. Do only show "Enable on" Field if more than 1 value exists.
2. remove posible combination "Test Case / Test Plan Design"
Steps To Reproduce1. Click on "Define custom fields"
2. click on an exisiting custom field or click Create Button
3. examine all possible combinations of "Available for", "Enable on"
TagsNo tags attached.
Database (MySQL,Postgres,etc)MySQL
Browser
PHP Version
TestCaseID
QA Team - Task Workflow Status
Attached Files

- Relationships
related to 0003707closedfman Custom Field edit/create not working right on Internet Explorer 

-  Notes
(0010925)
fman (administrator)
2010-08-25 09:29

>> - Test Case / Test Plan Design:
>> -> does not make sense in my eyes. Custom Field is not shown for test cases and >> not shown for test plans. -> do not allow this combination

this is OK, because this fields has been added as a user request (look on mantis) to insert data that can be used for tes automation purposes
(0010926)
Julian (reporter)
2010-08-25 09:31

i had this in mind but did not find where this CF is shown. so the error is that it does not show up ?
(0010932)
fman (administrator)
2010-08-25 10:38

Has to be displayed WHEN creating Test Plan -> LINK TEST CASES to test plan
(0010980)
fman (administrator)
2010-08-28 15:25

As stated on related issue, will review this and use as implementation guide.

Thanks
(0010985)
fman (administrator)
2010-08-29 09:27

Please test and resolve if OK
(0010989)
Julian (reporter)
2010-08-29 09:57

found another issue in this context:

edit a test suite/test plan/Req Spec/Req CF
-> Enable on Box is shown with no content
(0010994)
fman (administrator)
2010-08-29 14:10

ok will see
thaks
(0010995)
fman (administrator)
2010-08-29 17:53

please retest (TC added on testlink for testlink)
(0011020)
fman (administrator)
2010-08-31 20:26

Release BETA 6 - 20100831

- Issue History
Date Modified Username Field Change
2010-08-25 08:05 Julian New Issue
2010-08-25 09:29 fman Note Added: 0010925
2010-08-25 09:30 fman Assigned To => fman
2010-08-25 09:30 fman Status new => assigned
2010-08-25 09:31 Julian Note Added: 0010926
2010-08-25 10:38 fman Note Added: 0010932
2010-08-28 15:24 fman Relationship added related to 0003707
2010-08-28 15:25 fman Note Added: 0010980
2010-08-29 09:27 fman Note Added: 0010985
2010-08-29 09:27 fman Status assigned => feedback
2010-08-29 09:57 Julian Note Added: 0010989
2010-08-29 09:57 Julian Status feedback => assigned
2010-08-29 14:10 fman Note Added: 0010994
2010-08-29 17:53 fman Note Added: 0010995
2010-08-29 18:53 Julian Note View State: 0010989: public
2010-08-29 18:54 Julian Status assigned => resolved
2010-08-29 18:54 Julian Fixed in Version => 1.9 Beta 6
2010-08-29 18:54 Julian Resolution open => fixed
2010-08-31 20:26 fman Note Added: 0011020
2010-08-31 20:26 fman Status resolved => closed



Copyright © 2000 - 2019 MantisBT Team
Powered by Mantis Bugtracker