Mantis Bugtracker          
testlink.org

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0003692TestLinkTest Executepublic2010-08-19 12:312011-08-23 06:42
Reporterfbally 
Assigned Toasimon 
PrioritynormalSeveritymajorReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version1.9 Beta 5 
Fixed in Version1.9 Beta 6 
Summary0003692: DB error when selecting a folder under menu "execute"
DescriptionUnder "Test Execution", when selecting a folder on the left panel, a DB error occurs (displayed where normally the test description is displayed):

 ==============================================================================

 DB Access Error - debug_print_backtrace() OUTPUT START

 ==============================================================================

#0 database->exec_query(SELECT * FROM builds WHERE id = ) called at [/var/www/html/testlink/lib/functions/testplan.class.php:3812]
#1 build_mgr->get_by_id() called at [/var/www/html/testlink/lib/execute/execSetResults.php:1137]
0000002 initializeGui(database Object ([db] => ADODB_postgres7 Object ([databaseType] => postgres7,[hasLimit] => 1,[ansiOuter] => 1,[charSet] =>
Steps To Reproduce1) go to the "test execution" part (whatever the user rights)
2) the test plan is displayed in the left panel, a general information ("Purpose: Allows user to execute Test cases"...) is displayed in the right panel.
3) on the left panel, select a folder
4) the error message is displayed (see above)
Additional InformationIn the events part, the following messages are displayed:
19/08/2010 14:23:47 ERROR ERROR ON exec_query() - database.class.php
0 - - SELECT * FROM builds WHERE id =
THE MESSAGE : SQL [14] executed [took 0.0248 secs][all took 0.0888 secs]: SELECT * FROM builds WHERE id = Query failed: errorcode[0] errormsg:
TagsNo tags attached.
Database (MySQL,Postgres,etc)PostgreSQL 8.3.11
BrowserFirefox
PHP VersionPHP 5.3.2 (cli) (built: Apr 27 2010 20:34:18)
TestCaseID
QA Team - Task Workflow Status
Attached Files

- Relationships
duplicate of 0003574closedasimon Crash when clicking on top level node on execution tree. 
duplicate of 0003626closedasimon Testlink Execution . Suite click reports DB Error 
has duplicate 0003608closedasimon Error in test execution 

-  Notes
(0011063)
fman (administrator)
2010-08-31 20:27

Release BETA 6 - 20100831
(0015733)
fman (administrator)
2011-08-22 21:16

Reminder sent to: asimon

please update status
(0015737)
Julian (reporter)
2011-08-23 06:42

What is the problem here?
Issue has been fixed 1 year ago.

Andreas asked me to answer you so he does not have to reopen the issue due to missing rights.

- Issue History
Date Modified Username Field Change
2010-08-19 12:31 fbally New Issue
2010-08-19 16:28 asimon Relationship added duplicate of 0003574
2010-08-19 16:29 asimon Relationship added duplicate of 0003626
2010-08-19 16:29 asimon Relationship added has duplicate 0003608
2010-08-19 16:30 asimon Status new => resolved
2010-08-19 16:30 asimon Fixed in Version => 1.9 Beta 6
2010-08-19 16:30 asimon Resolution open => fixed
2010-08-19 16:30 asimon Assigned To => asimon
2010-08-31 20:27 fman Note Added: 0011063
2010-08-31 20:27 fman Status resolved => closed
2011-08-22 21:16 fman Description Updated View Revisions
2011-08-22 21:16 fman Note Added: 0015733
2011-08-23 06:42 Julian Note Added: 0015737



Copyright © 2000 - 2019 MantisBT Team
Powered by Mantis Bugtracker