Mantis Bugtracker          
testlink.org

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0003672TestLinkReportspublic2010-08-12 15:282010-08-31 20:27
Reporterrtessier 
Assigned Toasimon 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionfixed 
PlatformFirefox 3.6.8OSUbuntuOS Version10.4
Product Version1.9 Beta 5 
Fixed in Version1.9 Beta 6 
Summary0003672: Problem with fix for issue 0003590
DescriptionThe code is in execSetResults.php, at line 470 (and 477) the variable will always be set to a numeric value (intval or 0), so the next condition at line 472 (and 479) will always be false.

When I look at the link in the result matrix report, the build_id shows a valid value (i.e. 149), but when I click on the link, I get a "Build is closed" page. However, if I change the lines 470 (and 477) to replace 0 with 'null', it works fine.
TagsNo tags attached.
Database (MySQL,Postgres,etc)mysql Ver 14.14 Distrib 5.1.41
Browser
PHP Version
TestCaseID
QA Team - Task Workflow Status
Attached Files

- Relationships

-  Notes
(0010847)
asimon (developer)
2010-08-12 16:55

Thanks for this report.
It's fixed now in CVS.
(0011076)
fman (administrator)
2010-08-31 20:27

Release BETA 6 - 20100831

- Issue History
Date Modified Username Field Change
2010-08-12 15:28 rtessier New Issue
2010-08-12 16:55 asimon Note Added: 0010847
2010-08-12 16:55 asimon Assigned To => asimon
2010-08-12 16:55 asimon Status new => assigned
2010-08-12 16:56 asimon Status assigned => resolved
2010-08-12 16:56 asimon Fixed in Version => 1.9 Beta 6
2010-08-12 16:56 asimon Resolution open => fixed
2010-08-31 20:27 fman Note Added: 0011076
2010-08-31 20:27 fman Status resolved => closed



Copyright © 2000 - 2019 MantisBT Team
Powered by Mantis Bugtracker