Mantis Bugtracker          
testlink.org

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0003605TestLinkAPI - XMLRPCpublic2010-07-15 08:042010-08-31 20:28
Reporterbrainbug 
Assigned Tofman 
PrioritynormalSeveritymajorReproducibilityalways
StatusclosedResolutionfixed 
PlatformlinuxOSubuntuOS Version
Product Version1.9 Beta 5 
Fixed in Version1.9 Beta 6 
Summary0003605: TL API - call of tl.getTestSuitesForTestSuite when no sub-testsuite exists results in invalid sql
DescriptionWhen you call tl.getTestSuitesForTestSuite via API for a testsuite which does NOT have a sub-testsuite, the get_by_id function does not get an id which ends in an invalid sql statement:

testsuite->get_by_id(, ORDER BY node_order) called at [/usr/local/testlink_19b5/lib/functions/testsuite.class.php:1379]

(detailed log is attached)
TagsNo tags attached.
Database (MySQL,Postgres,etc)
Browserfirefox
PHP VersionPHP Version 5.2.6-2ubuntu4.6
TestCaseID
QA Team - Task Workflow Status
Attached Filestxt file icon trace.txt [^] (3,414 bytes) 2010-07-15 08:04 [Show Content]

- Relationships

-  Notes
(0010661)
fman (administrator)
2010-07-15 16:47

tested on CVS code -> unable to reproduce
(0011144)
fman (administrator)
2010-08-31 20:28

Release BETA 6 - 20100831

- Issue History
Date Modified Username Field Change
2010-07-15 08:04 brainbug New Issue
2010-07-15 08:04 brainbug File Added: trace.txt
2010-07-15 10:13 fman Assigned To => fman
2010-07-15 10:13 fman Status new => assigned
2010-07-15 16:34 fman Summary call of tl.getTestSuitesForTestSuite when no sub-testsuite exists results in invalid sql => TL API - call of tl.getTestSuitesForTestSuite when no sub-testsuite exists results in invalid sql
2010-07-15 16:47 fman Note Added: 0010661
2010-07-15 16:47 fman Status assigned => resolved
2010-07-15 16:47 fman Fixed in Version => 1.9 Beta 6
2010-07-15 16:47 fman Resolution open => fixed
2010-08-31 20:28 fman Note Added: 0011144
2010-08-31 20:28 fman Status resolved => closed
2013-04-25 17:30 fman Category TL API => XMLRPC API
2013-04-25 17:30 fman Category XMLRPC API => API - XMLRPC



Copyright © 2000 - 2020 MantisBT Team
Powered by Mantis Bugtracker