Mantis Bugtracker          
testlink.org

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0003590TestLinkReportspublic2010-07-09 07:192010-08-31 20:28
Reporterterryzuo 
Assigned Toasimon 
PrioritynormalSeveritymajorReproducibilityalways
StatusclosedResolutionopen 
PlatformOSOS Version
Product Version1.9 Beta 5 
Fixed in Version1.9 Beta 6 
Summary0003590: Test result matrix:Click the test case link will cause DB access error
DescriptionCan not open the test case link in the test result martix page
1.Select Test result matrix page in the "Report and Martix"
2.Click the test case link, it will cause" DB Access Error - debug_print_backtrace() OUTPUT START "...,
Fatal error: Call to a member function MoveNext() on a non-object in ...\testlink\lib\functions\database.class.php on line 224
3. This feature is OK with 1.9b4 version.
4.Maybe the code change should be reviewed in execSetResults.php file.
TagsNo tags attached.
Database (MySQL,Postgres,etc)
BrowserIE8
PHP Version
TestCaseID
QA Team - Task Workflow Status
Attached Files

- Relationships
duplicate of 0003567closedasimon Failing to display testcase when clicking on the testcase in the Test result matrix report 
has duplicate 0003619closedasimon Testlink fatal error occur if click case try to view detail in Test result matrix GUI 

-  Notes
(0010593)
asimon (developer)
2010-07-09 09:14

This is not really related to 3574. The error message is the same, but the problem causing it is completely different.

The real error is a bit more complex, here it seems to be that the link to test case generated in resultsTC.php starting at line 125 does not have a build ID in it. This happens for the test cases which have not been run yet in any build, because usually the build ID of last execution is inserted there. So execSetResults.php does not know which build to load of course.

Since I will anyway have to refactor the results display because of the changes to the user assignments per build, I don't think we can/will really fix this one before the changes for the assignments have been finished.
(0010743)
asimon (developer)
2010-07-23 14:16

Is fixed in CVS and should not happen again.
Please retest in next public beta and feel free to reopen issue if bug should persist.
(0011128)
fman (administrator)
2010-08-31 20:28

Release BETA 6 - 20100831

- Issue History
Date Modified Username Field Change
2010-07-09 07:19 terryzuo New Issue
2010-07-09 08:26 Julian Relationship added duplicate of 0003574
2010-07-09 09:14 asimon Note Added: 0010593
2010-07-09 09:18 asimon Relationship deleted 0003574
2010-07-09 09:20 asimon Assigned To => asimon
2010-07-09 09:20 asimon Status new => work in progress
2010-07-09 09:32 Falcon1 Note Added: 0010595
2010-07-09 09:32 Falcon1 File Added: no_build_error.png.png
2010-07-09 09:33 Falcon1 Note Edited: 0010595 View Revisions
2010-07-09 09:38 Falcon1 Note Added: 0010596
2010-07-09 09:42 Falcon1 Note Deleted: 0010595
2010-07-09 09:42 Falcon1 Note Deleted: 0010596
2010-07-09 09:42 Falcon1 Note Added: 0010598
2010-07-09 09:45 asimon File Deleted: no_build_error.png.png
2010-07-09 13:05 Falcon1 Note Deleted: 0010598
2010-07-09 13:19 Julian Relationship added duplicate of 0003567
2010-07-23 07:45 asimon Relationship added has duplicate 0003619
2010-07-23 14:16 asimon Note Added: 0010743
2010-07-23 14:16 asimon Status work in progress => assigned
2010-07-23 14:16 asimon Fixed in Version => 1.9 Beta 6
2010-07-23 14:16 asimon Status assigned => resolved
2010-08-31 20:28 fman Note Added: 0011128
2010-08-31 20:28 fman Status resolved => closed



Copyright © 2000 - 2019 MantisBT Team
Powered by Mantis Bugtracker