Mantis Bugtracker          
testlink.org

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0003585TestLinkTest Specificationpublic2010-07-07 10:562010-08-31 20:28
ReporterFalcon1 
Assigned Tofman 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionfixed 
PlatformWAMP on Windows SystemOSWindowsOS Version2003 Server
Product Version1.9 Beta 5 
Fixed in Version1.9 Beta 6 
Summary0003585: Delete test case gives "DB Access Error - debug_print_backtrace", although it seams that the data have been successfully deleted
DescriptionDelete test case gives DB Access Error - debug_print_backtrace() OUTPUT START, although it seams that the data have been successfully deleted.

Is it only a trace printing?
Steps To ReproduceCreate a new project.
Create a new test suite.
Create a new test case.
Try to delete the test case created.
TagsNo tags attached.
Database (MySQL,Postgres,etc)
Browser
PHP Version
TestCaseID
QA Team - Task Workflow Status
Attached Files

- Relationships
duplicate of 0003573closedfman Crash whe deleting Test case specification 

-  Notes
(0010572)
Falcon1 (reporter)
2010-07-07 10:57

I have the same error when I delete the test suite, and sometimes when I delete the entire project.
(0010573)
Falcon1 (reporter)
2010-07-07 11:00

Other information.

When I tried to delete a test case in the right panel I had this trace:

==============================================================================
DB Access Error - debug_print_backtrace() OUTPUT START
==============================================================================
#0 database->exec_query(/* Class:testcase - Method: _blind_delete */ DELETE FROM user_assignments UA WHERE UA.feature_id in ( SELECT id FROM testplan_tcversions WHERE tcversion_id IN (27))) called at [C:\wamp\www\testlink19b5\lib\functions\testcase.class.php:1257]


I did another test, in which I checked the table testplan_tcversions before deleting the test case, and when I deleted the test case I found out that there didn't were rows with the tcversion_id in the WHERE clause.

Then I tried to assign test case to a test plan. In this case the rows with the tcversion_id were in the table testplan_tcversions, but I had again the DB Access Error - debug_print_backtrace() OUTPUT START, although they had been successfully deleted.
(0010579)
Falcon1 (reporter)
2010-07-07 15:20

Yes I tried. Problem solved with 0003573 patch.
(0011153)
fman (administrator)
2010-08-31 20:28

Release BETA 6 - 20100831

- Issue History
Date Modified Username Field Change
2010-07-07 10:56 Falcon1 New Issue
2010-07-07 10:57 Falcon1 Note Added: 0010572
2010-07-07 11:00 Falcon1 Note Added: 0010573
2010-07-07 12:07 Julian Relationship added duplicate of 0003573
2010-07-07 15:20 Falcon1 Note Added: 0010579
2010-07-08 09:30 fman Status new => resolved
2010-07-08 09:30 fman Fixed in Version => 1.9 Beta 6
2010-07-08 09:30 fman Resolution open => fixed
2010-07-08 09:30 fman Assigned To => fman
2010-08-31 20:28 fman Note Added: 0011153
2010-08-31 20:28 fman Status resolved => closed



Copyright © 2000 - 2019 MantisBT Team
Powered by Mantis Bugtracker