Mantis Bugtracker          
testlink.org

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0003583TestLinkTest Specificationpublic2010-07-06 13:192012-09-01 20:00
Reporterdifool 
Assigned ToJulian 
PrioritynormalSeverityfeature requestReproducibilityN/A
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version1.9 Beta 5 
Fixed in Version1.9.4 (2012 Q3 - bug fixing) 
Summary0003583: [Contribution] A small change to add a more visible step separation (horizontal layout).
DescriptionIf you want to have a more visible step separation in horizontal layout, you can modify the \lib\gui\templates\inc_steps.tpl (search for "<!-- Begin of steps separator -->").
TagsNo tags attached.
Database (MySQL,Postgres,etc)
Browser
PHP Version
TestCaseID
QA Team - Task Workflow Status
Attached Filesjpg file icon steps_separator.jpg [^] (226,672 bytes) 2010-07-06 13:19


jpg file icon tc_steps.jpg [^] (596,289 bytes) 2011-03-29 10:07
? file icon inc_steps.tpl [^] (6,050 bytes) 2011-03-29 10:14
png file icon bulk_tc_delete.png [^] (18,460 bytes) 2011-04-07 09:53


? file icon inc_steps.tpl.new [^] (6,238 bytes) 2011-07-05 09:32

- Relationships
has duplicate 0003869closedJulian Separation between step action 
child of 0004382closedJulian Usability: Improve simple table for better readability (row background color, hovering effects, horizontal seperators ...) 

-  Notes
(0010558)
Julian (reporter)
2010-07-06 14:31

please do not copy/paste such an amount of code.
attach as document.
(0010559)
difool (reporter)
2010-07-06 14:37

Would be useful if the bug reporter can edit his issue ...

inc_steps.tpl attached.
(0012224)
difool (reporter)
2010-11-01 09:15

In standard, would be interesting to add a more visibility between steps by this solution or any another one (e.g. background color ?). Several people asked for.
(0014281)
difool (reporter)
2011-03-25 09:34
edited on: 2011-03-25 09:42

This is still interesting even with steps implemented because when executing test case the steps haven't separtors leading sometimes to a difficult reading of the test case.

(0014342)
Julian (reporter)
2011-03-29 08:09

Amit - as you seem to be interested in this issue - please check the solution and maybe try to find a better way to seperate. i dont like the white stripe very much :)
(0014346)
fman (administrator)
2011-03-29 13:26

@Amit:
please attach resulting image
(0014349)
amitkhullar (reporter)
2011-03-29 14:15

tc_steps is already attached with the bug
(0014361)
difool (reporter)
2011-03-30 05:45
edited on: 2011-03-30 05:48

A div with alternative light background color is perhaps also a good solution (with the cycle color option) ?

Why white strip (or any light color) ? Because a lot of black is already here (text) and separation must be subtile, just enough to let the brain understand there is a separation. If you add again black then your screen become heavier to your eyes.

But of course, my screenshot is when we just started that. Now separation is a lot thiner, i agree that on my screenshot it's quite "disgraceful".

(0014363)
Julian (reporter)
2011-03-30 09:06
edited on: 2011-03-30 09:19

needs to be improved:

1. fix also for vertical layout if it makes sense (please check config to change step layout)

2. lines are shown in test specification (test case view) AND test execution mode -> colspan has to be set according. for test specification it should be:
{if $session['testprojectOptions']->automationEnabled}
    <td colspan=6>
{else}
   <td colspan=7>
{/if}

3. last line below last step should not be shown

4. Seperators should also be shown in step edit view

(0014428)
amitkhullar (reporter)
2011-04-04 18:36

1: Not required for Vertical layout and works as expected.
2: Info corrected for colspan
3: Last line below step : U mean only 2 lines in between 3 steps, if this is what it means I will correct it.
4: Do we really need them.
(0014429)
Julian (reporter)
2011-04-04 18:43

3: Last line below step : U mean only 2 lines in between 3 steps, if this is what it means I will correct it.
- 2 steps 2 lines...

step1
-----
step2
-----

line below step2 looks cruel as table ends there too


4: Do we really need them.
- i would say yes
(0014443)
difool (reporter)
2011-04-05 20:05

Could color of separation be easily fixed by user choice or it will be set by css ?

What about the cycle color ? No need to control if final line needed.
(0014445)
Julian (reporter)
2011-04-05 20:42

Issue starts to consume too much time.
Make some proposals and we will decide.
(0014452)
Julian (reporter)
2011-04-06 09:45
edited on: 2011-04-06 10:01

i think we should somehow extend simple table to adjust for different usage.

check for example "Test Reports -> General Test Plan Metric:
if many table rows for a report exist it really is very hard to find the right values
-> alternating row background colors would be the perfect solution

check test case steps
-> alternating row background colors would look cruel -> horizontal seperators are a good choice


Could imagine 3 types of simple tables
1. simple table with alternating row background colors (should be used for single line rows)
2. simple table with horizontal seperators (should be used for multiple line rows, like steps)
3. simple table as is now (should be used for small tables)


in addition we could use Franciscos solution from Bug 0004246:

<tr onMouseOver="this.bgColor='#CDDEF3';" onMouseOut="this.bgColor='#EEEEEE';">

(0014453)
fman (administrator)
2011-04-06 10:34

I agree with Julian suggestions (note 14452) but this implementation has to be thinked very, very well.
(0014477)
Julian (reporter)
2011-04-07 09:53

i fixed 0004382 -> some tables do now have a tableruler when hovering a row.

Please try to find a simple solution to add horizontal seperators to tables with multi-line rows. your solution is ok, when it can be easily adapted to Bulk test case delete (test suite -> test case operations -> delete [define multiple platforms]). See attachment - there should be a horizontal seperator between the two test cases.
(0014555)
Julian (reporter)
2011-04-11 13:01

Reminder sent to: amitkhullar

Do you plan to continue work here?
(0015469)
amitkhullar (reporter)
2011-07-05 09:33

Attached a new file with some better handling of separators. Please delete the old ones since I dont have any rights.
(0015470)
Julian (reporter)
2011-07-05 10:10

If you add the seperator to step edit mode i am fine with the solution.

Seperatur should not be shown before and after the step that is currently edited - what do you think ?
(0015471)
amitkhullar (reporter)
2011-07-06 03:33

IMHO the separator should be only on the display page. In Edit Mode the Editor is active so there is already no confusion.
(0015473)
Julian (reporter)
2011-07-06 06:47

Other steps except the one in editor are not seperated... seperator should be in both places. could you please give it a look - should not take too long.
(0015736)
jetmore (reporter)
2011-08-23 02:22

I don't know if this is useful, but I solved this problem in a different way tonight. I wanted alternating row colors when viewing steps, so the testers could visually separate the steps, and also so they eye could easily correlate the step and the result.

I am running 1.9.3.

First, I added the following to gui/themes/default/custom.css:

.row_color_1 {
    background-color: #DDDDDD;
}
.row_color_2 {
    background-color: #CCCCCC;
}

Then I patched gui/templates/testcases/inc_steps.tpl like so:

--- inc_steps.tpl.dist 2011-08-22 21:08:21.000000000 -0500
+++ inc_steps.tpl 2011-08-22 21:13:02.000000000 -0500
@@ -45,7 +45,7 @@
        </tr>
        {* BUGID 3376 *}
        {foreach from=$steps item=step_info}
- <tr id="step_row_{$step_info.step_number}">
+ <tr id="step_row_{$step_info.step_number}" class="{cycle values="row_color_1,row_color_2"}">
                <td style="text-align:left;">
                        <span class="order_info" style='display:none'>
                        <input type="text" name="step_set[{$step_info.id}]" id="step_set_{$step_info.id}"

That was all it took to make my testers much happier...
(0015766)
Julian (reporter)
2011-08-31 13:22

Sorry jetmore. Your solution will make the UI look clumsy in my eyes. I prefer Amits solution. Thanks anyway for your contribution.

@Amit: Do you plan to try to add the row in step edit mode? please let me know
(0015767)
jetmore (reporter)
2011-08-31 13:32

No worries. I needed a solution _right then_. I'll use my solution until I can evaluate Amit's in an actual release. Thanks for looking at it.
(0015768)
Julian (reporter)
2011-08-31 13:34

You can see a screenshot in issue 0004727: Attachment: edit_step_via_icon.png - VIEW Mode
(0015785)
Julian (reporter)
2011-09-01 12:05

Commited and tested Amits changes to 1.9 and master.
Also added horizontal rows in step edit mode.

1.9:
http://gitorious.org/testlink-ga/testlink-code/commit/c0743157bc08245668618fba0c20782704595d8f [^]

Master:
http://gitorious.org/testlink-ga/testlink-code/commit/e22a83c1a5f7d6ac59ddd19255b9104b0bfcea39 [^]
(0017370)
fman (administrator)
2012-09-01 20:00

1.9.4 released

- Issue History
Date Modified Username Field Change
2010-07-06 13:19 difool New Issue
2010-07-06 13:19 difool File Added: steps_separator.jpg
2010-07-06 14:31 Julian Note Added: 0010558
2010-07-06 14:36 difool File Added: inc_steps.tpl
2010-07-06 14:37 difool Note Added: 0010559
2010-07-06 14:42 Julian Description Updated View Revisions
2010-10-08 14:42 Julian Relationship added has duplicate 0003869
2010-11-01 09:15 difool Note Added: 0012224
2011-03-25 09:34 difool Note Added: 0014281
2011-03-25 09:42 difool Note Edited: 0014281 View Revisions
2011-03-29 08:09 Julian Note Added: 0014342
2011-03-29 10:07 amitkhullar File Added: tc_steps.jpg
2011-03-29 10:13 amitkhullar File Deleted: inc_steps.tpl
2011-03-29 10:14 amitkhullar File Added: inc_steps.tpl
2011-03-29 10:16 amitkhullar Assigned To => amitkhullar
2011-03-29 10:16 amitkhullar Status new => work in progress
2011-03-29 13:26 fman Note Added: 0014346
2011-03-29 14:15 amitkhullar Note Added: 0014349
2011-03-30 05:45 difool Note Added: 0014361
2011-03-30 05:48 difool Note Edited: 0014361 View Revisions
2011-03-30 09:06 Julian Note Added: 0014363
2011-03-30 09:19 Julian Note Edited: 0014363 View Revisions
2011-04-04 18:36 amitkhullar Note Added: 0014428
2011-04-04 18:43 Julian Note Added: 0014429
2011-04-05 20:05 difool Note Added: 0014443
2011-04-05 20:42 Julian Note Added: 0014445
2011-04-06 09:45 Julian Note Added: 0014452
2011-04-06 10:01 Julian Note Edited: 0014452 View Revisions
2011-04-06 10:34 fman Note Added: 0014453
2011-04-06 10:47 Julian Relationship added child of 0004382
2011-04-07 09:53 Julian Note Added: 0014477
2011-04-07 09:53 Julian File Added: bulk_tc_delete.png
2011-04-11 13:01 Julian Note Added: 0014555
2011-07-05 09:32 amitkhullar File Added: inc_steps.tpl.new
2011-07-05 09:33 amitkhullar Note Added: 0015469
2011-07-05 10:10 Julian Note Added: 0015470
2011-07-06 03:33 amitkhullar Note Added: 0015471
2011-07-06 06:47 Julian Note Added: 0015473
2011-08-23 02:22 jetmore Note Added: 0015736
2011-08-31 13:22 Julian Note Added: 0015766
2011-08-31 13:32 jetmore Note Added: 0015767
2011-08-31 13:34 Julian Note Added: 0015768
2011-09-01 12:04 Julian Assigned To amitkhullar => Julian
2011-09-01 12:04 Julian Status work in progress => new
2011-09-01 12:05 Julian Note Added: 0015785
2011-09-01 12:05 Julian Status new => resolved
2011-09-01 12:05 Julian Fixed in Version => 1.9.4 (2012 Q3 - bug fixing)
2011-09-01 12:05 Julian Resolution open => fixed
2012-09-01 20:00 fman Note Added: 0017370
2012-09-01 20:00 fman Status resolved => closed



Copyright © 2000 - 2018 MantisBT Team
Powered by Mantis Bugtracker