Mantis Bugtracker          
testlink.org

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0003581TestLinkTest Plan (builds, milestones, test assign)public2010-07-06 13:052010-08-31 20:28
Reporternzamfir 
Assigned Tofman 
PrioritylowSeverityminorReproducibilityalways
StatusclosedResolutionfixed 
PlatformanyOSOS Version
Product Version1.9 Beta 5 
Fixed in Version1.9 Beta 6 
Summary0003581: release date setting for builds
Descriptionu can set the "release date" setting for builds to any value, including values that should not be possible like 30-31 of February; this makes the sql command to fail(postgres) or the date registered to become 1/1/1970(mysql)
probable reason could be because the release_date column in builds table is setup-ed as sql date format.
Steps To Reproducein edit or create builds set the release date to a impossible value and then press save
Additional Informationdatabase used was a PostgreSQL 8.2.1/MySQL 5.x
TagsNo tags attached.
Database (MySQL,Postgres,etc)
Browserany
PHP Version5.2.13/5.2.5
TestCaseID
QA Team - Task Workflow Status
Attached Filesjpg file icon tl_official-bug1_1.JPG [^] (134,804 bytes) 2010-07-06 13:05


zip file icon fix-3581.zip [^] (37,769 bytes) 2010-07-06 18:29

- Relationships
child of 0003570closedfman Availables Fixes for 1.9 Beta 5 

-  Notes
(0010557)
Julian (reporter)
2010-07-06 13:52
edited on: 2010-07-06 14:30

a workaround would be to enter valid dates ;)

another nice feature would be to set release to "today" as default

(0010563)
fman (administrator)
2010-07-06 16:18

>> another nice feature would be to set release to "today" as default
do not think is a good solution, because when you create a build in advance you need to clean the date
(0010569)
fman (administrator)
2010-07-06 18:30

please use attached fix and give feedback
(0010577)
nzamfir (reporter)
2010-07-07 13:59
edited on: 2010-07-07 14:00

checked; fix is working; you can set the bug as accepted

(0010581)
amitkhullar (reporter)
2010-07-07 20:06

Just a suggestion , can't we add a calendar widget/control/toolkit which gives a popup and the user can select the correct date. This ways no chances of any error and this can be implemented across the system.
(0011152)
fman (administrator)
2010-08-31 20:28

Release BETA 6 - 20100831

- Issue History
Date Modified Username Field Change
2010-07-06 13:05 nzamfir New Issue
2010-07-06 13:05 nzamfir File Added: tl_official-bug1_1.JPG
2010-07-06 13:52 Julian Note Added: 0010557
2010-07-06 14:30 Julian Note Edited: 0010557 View Revisions
2010-07-06 16:18 fman Note Added: 0010563
2010-07-06 16:18 fman Assigned To => fman
2010-07-06 16:18 fman Status new => assigned
2010-07-06 18:29 fman File Added: fix-3581.zip
2010-07-06 18:30 fman Note Added: 0010569
2010-07-06 18:30 fman Status assigned => feedback
2010-07-06 18:30 fman Relationship added child of 0003570
2010-07-07 13:59 nzamfir Note Added: 0010577
2010-07-07 13:59 nzamfir Status feedback => assigned
2010-07-07 14:00 nzamfir Note Edited: 0010577 View Revisions
2010-07-07 20:06 amitkhullar Note Added: 0010581
2010-07-08 13:42 fman Status assigned => resolved
2010-07-08 13:42 fman Fixed in Version => 1.9 Beta 6
2010-07-08 13:42 fman Resolution open => fixed
2010-08-31 20:28 fman Note Added: 0011152
2010-08-31 20:28 fman Status resolved => closed



Copyright © 2000 - 2019 MantisBT Team
Powered by Mantis Bugtracker