Mantis Bugtracker          
testlink.org

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0003573TestLinkDatabase MySQLpublic2010-07-06 09:412010-08-31 20:28
Reporterdifool 
Assigned Tofman 
PriorityhighSeveritycrashReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS VersionXP sp3
Product Version1.9 Beta 5 
Fixed in Version1.9 Beta 6 
Summary0003573: Crash whe deleting Test case specification
DescriptionWhen deleting a test case under a test suite, a database crash occurs.
    
Steps To ReproduceCreate a test suite.
Create a test case.
Delete this test case.
Additional InformationTo correct must modify the function _blind_delete() in \lib\fuctions\testcase.class.php


        $sql[]="/* $debugMsg */ DELETE FROM {$this->tables['user_assignments']} UA" .
               " WHERE UA.feature_id in (" .
               " SELECT id FROM {$this->tables['testplan_tcversions']} " .


The UA alias causes the error. Removing it fix the problem.


        $sql[]="/* $debugMsg */ DELETE FROM {$this->tables['user_assignments']} " .
               " WHERE feature_id in (" .
               " SELECT id FROM {$this->tables['testplan_tcversions']} " .

    }
TagsNo tags attached.
Database (MySQL,Postgres,etc)
BrowserFirefox 3.6.6 and IE 7.0.5730
PHP VersionPHP Version PHP 5.2.8 + Apache 2.2.11 + Mysql 5.1.3 and PHP 5.2.11 + Apache 2.0 + MySql 5.1.39
TestCaseID
QA Team - Task Workflow Status
Attached Filesjpg file icon delete_crash.jpg [^] (247,477 bytes) 2010-07-06 09:41


zip file icon fix-3573.zip [^] (34,942 bytes) 2010-07-06 16:55

- Relationships
duplicate of 0003635closedasimon DB error on deleting test suite 
has duplicate 0003585closedfman Delete test case gives "DB Access Error - debug_print_backtrace", although it seams that the data have been successfully deleted 
has duplicate 0003652closedfman Error when delete a Test Case 
child of 0003570closedfman Availables Fixes for 1.9 Beta 5 

-  Notes
(0010561)
fman (administrator)
2010-07-06 15:43

Will test on Postres to understand if is a Mysql specific problem
(0010565)
fman (administrator)
2010-07-06 16:50

Works ok with Postgres, anyway alias will be removed
(0011154)
fman (administrator)
2010-08-31 20:28

Release BETA 6 - 20100831

- Issue History
Date Modified Username Field Change
2010-07-06 09:41 difool New Issue
2010-07-06 09:41 difool File Added: delete_crash.jpg
2010-07-06 15:43 fman Note Added: 0010561
2010-07-06 16:50 fman Note Added: 0010565
2010-07-06 16:55 fman File Added: fix-3573.zip
2010-07-06 16:55 fman Status new => resolved
2010-07-06 16:55 fman Resolution open => fixed
2010-07-06 16:55 fman Assigned To => fman
2010-07-06 16:55 fman Product Version 1.9 Beta 5 => 1.9 Beta 6
2010-07-06 16:55 fman Relationship added child of 0003570
2010-07-07 12:07 Julian Relationship added has duplicate 0003585
2010-07-07 14:43 Julian Status resolved => assigned
2010-07-07 14:43 Julian Resolution fixed => reopened
2010-07-07 14:44 Julian Product Version 1.9 Beta 6 => 1.9 Beta 5
2010-07-07 14:44 Julian Fixed in Version => 1.9 Beta 6
2010-07-07 14:44 Julian Status assigned => resolved
2010-07-07 14:44 Julian Resolution reopened => fixed
2010-08-04 14:17 fman Relationship added duplicate of 0003635
2010-08-08 18:43 fman Relationship added has duplicate 0003652
2010-08-31 20:28 fman Note Added: 0011154
2010-08-31 20:28 fman Status resolved => closed



Copyright © 2000 - 2019 MantisBT Team
Powered by Mantis Bugtracker