Mantis Bugtracker          
testlink.org

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0003569TestLinkRequirement Managementpublic2010-07-05 15:282010-08-31 20:27
Reporterfbally 
Assigned Toasimon 
PrioritynormalSeveritymajorReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version1.9 Beta 5 
Fixed in Version1.9 Beta 6 
Summary0003569: Requirement based report displays passed requirements in "failed" section
DescriptionSome requirements are created, a new test plan is created and requirements are assigned to this test plan. Then the test plan is executed and all the tests are "passed".
When displaying the requirement-based report, all the requirement are mentionned as "passed" under the "failed" category (see attachment).
Steps To Reproduce1) create a new test plan
2) create 3 requirements req1, req2 and req3
3) assign 5 tests from an existing test specification, to this test plan
4) assign requirements to tests: req1 with test 1, req2 with test 2 and req3 with test 3
5) create a build
6) execute all the 5 tests "passed"
7) display the requirement-based report
---> the three requirements are set as "passed" under the "failed category".
See attachment.
TagsNo tags attached.
Database (MySQL,Postgres,etc)
Browserfirefox 3.6.4
PHP Version5.3.1
TestCaseID
QA Team - Task Workflow Status
Attached Filesjpg file icon requirements.JPG [^] (39,143 bytes) 2010-07-05 15:28

- Relationships
duplicate of 0003439closedasimon Requirement based report is incorrect. 
related to 0003261closedasimon Requirements based Report NEED REFACTOR due to req version feature 

-  Notes
(0010548)
terryzuo (reporter)
2010-07-06 01:53

duplicated with 0003488
(0010884)
asimon (developer)
2010-08-19 16:25

Requirement based report feature has been completely redesigned/rewritten.
Please wait for next available public beta and retest.
(0011066)
fman (administrator)
2010-08-31 20:27

Release BETA 6 - 20100831

- Issue History
Date Modified Username Field Change
2010-07-05 15:28 fbally New Issue
2010-07-05 15:28 fbally File Added: requirements.JPG
2010-07-06 01:53 terryzuo Note Added: 0010548
2010-07-06 07:47 Julian Relationship added duplicate of 0003439
2010-08-18 07:46 asimon Relationship added related to 0003261
2010-08-19 16:25 asimon Note Added: 0010884
2010-08-19 16:25 asimon Status new => resolved
2010-08-19 16:25 asimon Fixed in Version => 1.9 Beta 6
2010-08-19 16:25 asimon Resolution open => fixed
2010-08-19 16:25 asimon Assigned To => asimon
2010-08-31 20:27 fman Note Added: 0011066
2010-08-31 20:27 fman Status resolved => closed



Copyright © 2000 - 2019 MantisBT Team
Powered by Mantis Bugtracker