Mantis Bugtracker          
testlink.org

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0003565TestLinkAPI - XMLRPCpublic2010-07-02 08:252010-08-31 20:28
Reporterschm 
Assigned Tofman 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSWindowsOS Version7
Product Version1.9 Beta 4 
Fixed in Version1.9 Beta 6 
Summary0003565: tl.createTestPlan will add a database entry even if user has not sufficient rights
DescriptionAn if statement checks whether sufficient rights are given, but does not prevent further execution if no rights are given. Also, there seems to be a typo (breack instead of break).
Steps To ReproduceAdd a test plan via tl.createTestPlan with a user, that has not sufficient rights to do that (= no admin privileges).
Additional InformationFix adds else statement that sets status_ok to false, if rights check fails. Corrects the typo.
TagsNo tags attached.
Database (MySQL,Postgres,etc)
BrowserK-Meleon and Firefox
PHP Version5.3.0
TestCaseID
QA Team - Task Workflow Status
Attached Files

- Relationships

-  Notes
(0010532)
fman (administrator)
2010-07-04 11:42

thanks
(0011157)
fman (administrator)
2010-08-31 20:28

Release BETA 6 - 20100831

- Issue History
Date Modified Username Field Change
2010-07-02 08:25 schm New Issue
2010-07-02 08:25 schm File Added: xmlrpc.class.php
2010-07-04 11:42 fman File Deleted: xmlrpc.class.php
2010-07-04 11:42 fman Note Added: 0010532
2010-07-04 11:42 fman Status new => resolved
2010-07-04 11:42 fman Fixed in Version => 1.9 Beta 6
2010-07-04 11:42 fman Resolution open => fixed
2010-07-04 11:42 fman Assigned To => fman
2010-08-31 20:28 fman Note Added: 0011157
2010-08-31 20:28 fman Status resolved => closed
2013-04-25 17:30 fman Category TL API => XMLRPC API
2013-04-25 17:30 fman Category XMLRPC API => API - XMLRPC



Copyright © 2000 - 2019 MantisBT Team
Powered by Mantis Bugtracker