Mantis Bugtracker          
testlink.org

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0003554TestLinkKeywordspublic2010-06-28 16:382012-09-01 19:59
Reportertbennett 
Assigned Tofman 
PrioritynormalSeveritymajorReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version1.8.2 
Fixed in Version1.9.4 (2012 Q3 - bug fixing) 
Summary0003554: Assigning keywords to a Test Suite assigns all keywords in Assigned listbox
DescriptionAttempting to assign a keyword to a Test Suite. The right-hand listbox shows all keywords which are assigned to the test cases within the suite.

Example TestCase1: keyword_A
        TestCase2: keyword_B
Assigned Keywords shows keyword_A and keyword_B.

When I go to assign a new keyword to all testcases in this suite (keyword_C), now ALL testcases in this suite have ALL keywords. I just wanted to assign the new keyword to the testcases.
Steps To ReproduceHome->Assign Keywords. Select a Test Suite, and the right-hand listbox (Assigned Keywords) shows all keywords which are currently assigned to various testcases within the suite. Select a new keyword from left-hand listbox (Available Keywords), and add it to right listbox, then click Save.
TagsNo tags attached.
Database (MySQL,Postgres,etc)
BrowserIE 8
PHP Version
TestCaseID
QA Team - Task Workflow Status
Attached Files

- Relationships
duplicate of 0005074closedfman Bulk Keyword assignment - All keywords are assigned to the test case instead of the selected keyword 

-  Notes
(0010452)
fman (administrator)
2010-06-29 17:22

1.8.2 is unsupported, please update to 1.8.5b and retest
(0010456)
tbennett (reporter)
2010-06-29 17:32

ok, I tested in 1.8.5 (is it 'b'? I can't tell). Same behaviour.
(0010534)
fman (administrator)
2010-07-04 15:32
edited on: 2010-07-04 15:40

Solution can be:
Always show right pane empty => use it to assign not also for display what was assigned to test cases.

In this way we loose possibility to remove in bulk mode (i.e. on all contained test cases ) one or more keywords.

May be UI for this case has to be rethinked:
A couple of panels (like the current one):
one for adding keywords (right panel will be initialized empty), and one for
removing (right panel will be initialized as done today).

(0010535)
fman (administrator)
2010-07-04 15:41

Reminder sent to: Julian

please give a look, your opinion is needed.
(0010542)
Julian (reporter)
2010-07-05 09:36

how about only to initalize right panel with keywords present on all test cases in the whole test suite (and sub-suites?).

Example:
--------

Suite1
-TC1 (KW1, KW2, KW3)
-TC2 (KW1, KW4)
-TC3 (KW1, KW3)

-> Assigned Keywords for Suite1: KW1

Example2 (incl sub-suite):
--------------------------

Suite1
-TC1 (KW1, KW2, KW3)
-TC2 (KW1, KW4)
-TC3 (KW1, KW3)
-Suite2
--TC4 (KW5, KW2)
--TC5 (KW5, KW3)

-> No Assigned Keywords for Suite1
(-> Assigned Keywords for Suite2: KW5)
(0017326)
fman (administrator)
2012-09-01 19:59

1.9.4 released

- Issue History
Date Modified Username Field Change
2010-06-28 16:38 tbennett New Issue
2010-06-29 17:22 fman Note Added: 0010452
2010-06-29 17:32 tbennett Note Added: 0010456
2010-07-04 15:32 fman Note Added: 0010534
2010-07-04 15:40 fman Note Edited: 0010534 View Revisions
2010-07-04 15:41 fman Note Added: 0010535
2010-07-05 09:36 Julian Note Added: 0010542
2011-06-03 16:32 fman Category Test Specification => Keywords
2011-06-03 16:41 fman Status new => assigned
2011-06-03 16:41 fman Assigned To => fman
2012-06-23 17:41 fman Relationship added duplicate of 0005074
2012-07-14 07:33 fman Status assigned => resolved
2012-07-14 07:33 fman Resolution open => fixed
2012-07-14 07:33 fman Fixed in Version => 1.9.4 (2012 Q3 - bug fixing)
2012-09-01 19:59 fman Note Added: 0017326
2012-09-01 19:59 fman Status resolved => closed



Copyright © 2000 - 2018 MantisBT Team
Powered by Mantis Bugtracker