Mantis Bugtracker          
testlink.org

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0003553TestLinkTest Executepublic2010-06-28 11:572010-08-31 20:28
ReporterElana08 
Assigned Toasimon 
PriorityhighSeveritymajorReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version1.9 Beta 4 
Fixed in Version1.9 Beta 5 
Summary0003553: The creation of a new build causes a display problem on the tree and on the tests to run.
DescriptionAfter working on a build (Passed / Failed / Blocked / Not run cases), you can make a new build. But when you want to execute, you can see that the tree has the colors of the old build.

I try the version 1.9 beta 5 of the 06/28/2010 but the problem seems to be more important, because now some not-run tests are not marked in the tree counters.
Steps To Reproduce1. Create a test campaign with more than 5 tests cases.
2. Create a build (for example test1).
3. Execute some tests (1 of each status for example). Tests cases has been executed and didn't have any problem.
4. Create a new build (for example test2). There isn't any importance if the other build is closed or not.
5. Go in execution test.
6. The tree shows the color of the last build and you can see that, when you go on the test case concerned, you have "Date : 28/06/2010 12:29:26 - Tested by : admin - Build : test1 - Status : Passed" instead of test2. If you execute the test one more time, you can see "Date : 28/06/2010 12:35:02 - Tested by : admin - Build : test2 - Status : Passed". For example. I try to change filter value but the problem is persistant.
Additional InformationI use the testlink version 1.9 beta 5 with any personal modifications (except the database). Sorry but I can't joined any screen. I didn't find this problem report in Mantis.

TagsNo tags attached.
Database (MySQL,Postgres,etc)
Browser
PHP Version5.3.0
TestCaseID
QA Team - Task Workflow Status
Attached Files

- Relationships
duplicate of 0003450closedasimon Tree is colored according to latest exec result <-> Testlink 1.8.x did color tree according to results on chosen build for exec 

-  Notes
(0010451)
fman (administrator)
2010-06-29 17:22

>> I use the testlink version 1.9 beta 5
this is near impossible because beta 5 has not been released.
(0010458)
Elana08 (reporter)
2010-06-30 07:25

Not Beta 5, but the version with corrections that I download on Mantis. Testlink shows Beta 5 on the title :). It was the version of 06/28/2010.
(0010459)
fman (administrator)
2010-06-30 09:11

We do not accept issues report from CVS code
(0010460)
Elana08 (reporter)
2010-07-01 07:01

Obviously, this problem also exists with version 1.9 beta 4 :)
(0010530)
fman (administrator)
2010-07-04 11:36

Reminder sent to: asimon, Julian

Please give a look, is this the OLD issue/topic regarding coloring according this or that exec result ?
Would you mind to give answer to user ?
(0010533)
Julian (reporter)
2010-07-04 12:54

could be the problem.

Elana08 would you mind installing Testlink 1.9beta5 to check if coloring of the tree is as you expect now.

Coloring can be controlled via config:

// ENABLED -> test cases will be coloured according to execution status on build selected for execution
// DISABLED -> test cases will be coloured according status on latest execution regardless of selected build
// see http://mantis.testlink.org/view.php?id=3450 [^] for more details
$tlCfg->exec_cfg->testcases_colouring_by_selected_build = ENABLED;
(0010570)
Elana08 (reporter)
2010-07-07 10:44

Thank for your coments. It is the same problem like this http://mantis.testlink.org/view.php?id=3450 [^] :) I'll try the modification as soon as.
(0010571)
Julian (reporter)
2010-07-07 10:51

thanks for your feedback.
(0011137)
fman (administrator)
2010-08-31 20:28

Release BETA 6 - 20100831

- Issue History
Date Modified Username Field Change
2010-06-28 11:57 Elana08 New Issue
2010-06-29 17:22 fman Note Added: 0010451
2010-06-30 07:25 Elana08 Note Added: 0010458
2010-06-30 09:11 fman Note Added: 0010459
2010-07-01 07:01 Elana08 Note Added: 0010460
2010-07-04 11:36 fman Note Added: 0010530
2010-07-04 12:54 Julian Note Added: 0010533
2010-07-07 10:44 Elana08 Note Added: 0010570
2010-07-07 10:51 Julian Note Added: 0010571
2010-07-07 10:51 Julian Relationship added duplicate of 0003450
2010-07-07 10:51 Julian Status new => resolved
2010-07-07 10:51 Julian Fixed in Version => 1.9 Beta 5
2010-07-07 10:51 Julian Resolution open => fixed
2010-07-07 10:51 Julian Assigned To => asimon
2010-08-31 20:28 fman Note Added: 0011137
2010-08-31 20:28 fman Status resolved => closed



Copyright © 2000 - 2020 MantisBT Team
Powered by Mantis Bugtracker