Mantis Bugtracker          
testlink.org

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0003552TestLinkExport/Importpublic2010-06-28 10:382010-10-09 08:00
ReporterKathrinMarkus 
Assigned Tofman 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version1.9 Beta 4 
Fixed in Version1.9 RC 1 
Summary0003552: TC import failed by select option "create new Version"
DescriptionTestlink gives error message by import testcases

 ==============================================================================

 DB Access Error - debug_print_backtrace() OUTPUT START

 ==============================================================================

#0 database->exec_query(/* Class:testcase - Method: get_last_version_info */ SELECT MAX(version) AS version FROM tcversions TCV, nodes_hierarchy NH WHERE NH.id = TCV.id AND NH.parent_id = ) called at [C:\EasyWAMP\www\lib\functions\database.class.php:518]
#1 database->fetchFirstRow(/* Class:testcase - Method: get_last_version_info */ SELECT MAX(version) AS version FROM tcversions TCV, nodes_hierarchy NH WHERE NH.id = TCV.id AND NH.parent_id = ) called at [C:\EasyWAMP\www\lib\functions\database.class.php:500]
0000002 database->fetchFirstRowSingleColumn(/* Class:testcase - Method: get_last_version_info */ SELECT MAX(version) AS version FROM tcversions TCV, nodes_hierarchy NH WHERE NH.id = TCV.id AND NH.parent_id = , version) called at [C:\EasyWAMP\www\lib\functions\testcase.class.php:1548]
0000003 testcase->get_last_version_info(, Array ([output] => minimun)) called at [C:\EasyWAMP\www\lib\functions\testcase.class.php:263]
0000004 testcase->create(10665, METH-1 : methods with return type void,
Steps To Reproduceopen testlink
create any testcase
export this testcase
go the test suite of testcase
import testcase
select option "create new version"
select the exported testcase file
import => failed (NOK)
TagsNo tags attached.
Database (MySQL,Postgres,etc)
Browser
PHP Version
TestCaseID
QA Team - Task Workflow Status
Attached Filesjpg file icon tl1.jpg [^] (23,948 bytes) 2010-07-04 15:47


jpg file icon tl2.jpg [^] (24,077 bytes) 2010-07-04 15:51

- Relationships

-  Notes
(0010450)
fman (administrator)
2010-06-29 17:20

Explained lot of times, adding this amount of text on an issue makes the issue difficult to read.
Avoid this kind of posting, because I planning to delete in future issues reported this way
(0010536)
fman (administrator)
2010-07-04 15:46
edited on: 2010-07-04 15:50

Tested this way ON 1.9 BETA 5
Test Case #1

  1. choose an existent test case with only version 1
         TEST CASE HAS NO STEPS
  2. export this testcase
  3. go the test suite of testcase
  4. button import testcase
  5. see attached image (tl1.jpg) for options
  6. import OK


Test Case 0000002

  1. choose an existent test case with only version 1
         TEST CASE HAS NO STEPS
  2. export this testcase
  3. go the test suite of testcase
  4. button import testcase
  5. see attached image (tl2.jpg) for options
  6. import OK


(0011576)
fman (administrator)
2010-10-02 17:32

no more user feedback
(0011716)
fman (administrator)
2010-10-09 08:00

Release 1.9 RC1

- Issue History
Date Modified Username Field Change
2010-06-28 10:38 KathrinMarkus New Issue
2010-06-29 17:20 fman Note Added: 0010450
2010-06-29 17:21 fman Description Updated View Revisions
2010-07-04 15:46 fman Note Added: 0010536
2010-07-04 15:47 fman File Added: tl1.jpg
2010-07-04 15:48 fman Note Edited: 0010536 View Revisions
2010-07-04 15:50 fman Note Edited: 0010536 View Revisions
2010-07-04 15:51 fman File Added: tl2.jpg
2010-07-04 15:52 fman Assigned To => fman
2010-07-04 15:52 fman Status new => feedback
2010-10-02 17:32 fman Note Added: 0011576
2010-10-02 17:32 fman Status feedback => resolved
2010-10-02 17:32 fman Fixed in Version => 1.9 RC 1
2010-10-02 17:32 fman Resolution open => fixed
2010-10-09 08:00 fman Note Added: 0011716
2010-10-09 08:00 fman Status resolved => closed



Copyright © 2000 - 2019 MantisBT Team
Powered by Mantis Bugtracker