Mantis Bugtracker          
testlink.org

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0003532TestLinkGeneralpublic2010-06-16 12:112010-08-31 20:26
ReporterJulian 
Assigned Toasimon 
PrioritynormalSeverityminorReproducibilityhave not tried
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version1.9 Beta 4 
Fixed in Version1.9 Beta 6 
Summary0003532: New Config Parameter to define Test Case Steps Web-Editor
Descriptionright now it is only possible to define editor for "design" -> test case summary, precodition, steps.

editor for steps has less space as two editors are side by side. -> huge toolbars do not fit

how about changing
$tlCfg->gui->text_editor['design']
to
$tlCfg->gui->text_editor['testcase'] (design is not easy to understand -> name it testcase)
$tlCfg->gui->text_editor['testcase_steps']

This will allow users to define better fitting toolbars for test steps editor.

Example:
$tlCfg->gui->text_editor['testcase'] = array('type' => 'fckeditor', 'toolbar' => 'tl_default', 'configFile' => 'cfg/tl_fckeditor_config.js');
$tlCfg->gui->text_editor['testcase_steps'] = array('type' => 'fckeditor', 'toolbar' => 'tl_mini', 'configFile' => 'cfg/tl_fckeditor_config.js');
TagsNo tags attached.
Database (MySQL,Postgres,etc)
Browser
PHP Version
TestCaseID
QA Team - Task Workflow Status
Attached Files

- Relationships

-  Notes
(0010340)
fman (administrator)
2010-06-16 16:31
edited on: 2010-06-16 16:32

IMHO if execution is clear, same applies to design.
is better to maintain design word, because may be one they we will have notes fro individual steps exec

then my suggestion
change design -> testcase_design
add steps_design

What is not clear in documentation if this config applies TO ALL EDITOR PRESENT ON SCREEN ( a different config for each editor is an OVERKILL => WILL NOT BE DONE)

(0011016)
fman (administrator)
2010-08-31 20:26

Release BETA 6 - 20100831

- Issue History
Date Modified Username Field Change
2010-06-16 12:11 Julian New Issue
2010-06-16 16:31 fman Note Added: 0010340
2010-06-16 16:32 fman Note Edited: 0010340 View Revisions
2010-06-16 16:32 fman Assigned To => Julian
2010-06-16 16:32 fman Status new => assigned
2010-06-17 07:36 Julian Assigned To Julian => asimon
2010-08-31 14:19 asimon Status assigned => resolved
2010-08-31 14:19 asimon Fixed in Version => 1.9 Beta 6
2010-08-31 14:19 asimon Resolution open => fixed
2010-08-31 20:26 fman Note Added: 0011016
2010-08-31 20:26 fman Status resolved => closed



Copyright © 2000 - 2020 MantisBT Team
Powered by Mantis Bugtracker