Mantis Bugtracker          
testlink.org

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0003511TestLinkAPI - XMLRPCpublic2010-06-09 15:292010-07-02 18:35
Reporterqdvcm 
Assigned Tofman 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSUbuntuOS Version
Product Version1.9 Beta 4 
Fixed in Version1.9 Beta 5 
Summary0003511: reportTCResult does not update tcversion
DescriptionTestLink API reportTCResult does not update test case version, only the first version is excecuted.
Steps To Reproduce1. run API client to report test result: OK. Web interface showed result for version 1
2. created a version 2 of the test case, run it manually, Web interface showed result for version 2.
3. run API client again: OK. But Web interface still showed result for version 1.

Additional Information- Tried creating several new versions, but only version 1 is executed.
- No option for providing reportTCResult with TCversion.
TagsNo tags attached.
Database (MySQL,Postgres,etc)
BrowserFirefox
PHP Version
TestCaseID
QA Team - Task Workflow Status
Attached Fileszip file icon fix-3511.zip [^] (27,525 bytes) 2010-06-09 19:04

- Relationships

-  Notes
(0010252)
fman (administrator)
2010-06-09 19:05

>> No option for providing reportTCResult with TCversion.
this has not be changed.

try with attached fix and let us know
(0010315)
qdvcm (reporter)
2010-06-14 23:53

I tested and the issue is fixed, thanks so much!
(0010483)
fman (administrator)
2010-07-02 18:35

1.9 Beta 5 released

- Issue History
Date Modified Username Field Change
2010-06-09 15:29 qdvcm New Issue
2010-06-09 16:10 fman Assigned To => fman
2010-06-09 16:10 fman Status new => assigned
2010-06-09 19:04 fman File Added: fix-3511.zip
2010-06-09 19:05 fman Note Added: 0010252
2010-06-09 19:05 fman Status assigned => feedback
2010-06-09 19:36 fman Platform 1.9 Beta 4 =>
2010-06-09 19:36 fman Product Version => 1.9 Beta 4
2010-06-14 23:53 qdvcm Note Added: 0010315
2010-06-14 23:53 qdvcm Status feedback => assigned
2010-06-15 14:17 fman Status assigned => resolved
2010-06-15 14:17 fman Fixed in Version => 1.9 Beta 5
2010-06-15 14:17 fman Resolution open => fixed
2010-07-02 18:35 fman Note Added: 0010483
2010-07-02 18:35 fman Status resolved => closed
2013-04-25 17:30 fman Category TL API => XMLRPC API
2013-04-25 17:30 fman Category XMLRPC API => API - XMLRPC



Copyright © 2000 - 2019 MantisBT Team
Powered by Mantis Bugtracker