Mantis Bugtracker          
testlink.org

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0003507TestLinkUsers and Rightspublic2010-06-08 11:582010-08-31 20:28
Reporterkeeyou 
Assigned Tofman 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionfixed 
PlatformlinuxOSOS Version
Product Version1.8.5 (bug fixing) 
Fixed in Version1.9 Beta 4 
Summary0003507: User locale cannot be set with option "Personal"
DescriptionUser cannot change his own locale with function "Personal". You can only change user's locale as administrator using "User Administration" function.
Steps To Reproduce1. Log in to TestLink
2. Click "Personal"
3. Choose any locale other than "Czech" (Czech is first in a combo list)
4. Click "Save"
5. Locale hasn't been saved - in combo list value fliped back to "Czech".
Additional InformationI found the cause of the problem. If you edit the file:
lib/usermanagement/userInfo.php
and check the function init_args, you will notice, that one of the table $key2loop elements is missing:

Line 105 looks like this:
    $key2loop = array('firstName','lastName','emailAddress');
but should look like that:
    $key2loop = array('firstName','lastName','emailAddress','locale');
TagsNo tags attached.
Database (MySQL,Postgres,etc)
Browserany
PHP Version5.2.9
TestCaseID
QA Team - Task Workflow Status
Attached Files

- Relationships

-  Notes
(0010244)
fman (administrator)
2010-06-08 15:40

thanks, will check on 1.9
(0011165)
fman (administrator)
2010-08-31 20:28

Release BETA 6 - 20100831

- Issue History
Date Modified Username Field Change
2010-06-08 11:58 keeyou New Issue
2010-06-08 15:40 fman Note Added: 0010244
2010-06-09 19:06 fman Status new => resolved
2010-06-09 19:06 fman Fixed in Version => 1.9 Beta 4
2010-06-09 19:06 fman Resolution open => fixed
2010-06-09 19:06 fman Assigned To => fman
2010-08-31 20:28 fman Note Added: 0011165
2010-08-31 20:28 fman Status resolved => closed



Copyright © 2000 - 2019 MantisBT Team
Powered by Mantis Bugtracker