Mantis Bugtracker          
testlink.org

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0003503TestLinkEvent viewerpublic2010-06-03 17:262010-08-31 20:27
Reporteraostad 
Assigned Tofman 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionfixed 
PlatformWindowsOSVistaOS Version
Product Version1.8.5 (bug fixing) 
Fixed in Version1.9 Beta 5 
Summary0003503: The filter of Event viewer does not work
DescriptionAs long as no filtering is applied all events are shown properly, however, any filtering to the result ended to a blank report. Please look at the attached screenshots.
TagsNo tags attached.
Database (MySQL,Postgres,etc)
Browser
PHP Version
TestCaseID
QA Team - Task Workflow Status
Attached Filesjpg file icon Event viewer-no filtering.jpg [^] (201,661 bytes) 2010-06-03 17:26


jpg file icon Event viewer- with filtering.jpg [^] (45,827 bytes) 2010-06-03 17:26

- Relationships

-  Notes
(0010796)
piers.taylor (reporter)
2010-08-04 14:53

This is due to an error in the template file:

gui/templates/events/eventviewer.tpl

Line 133:

<select size="5" multiple="multiple" name="logLevel[]">

Has the SELECT NAME incorrectly set to "logLevel[]".

This should be set to "logLevel".

When the [] characters are removed from this line, the filtering works correctly.
(0010799)
fman (administrator)
2010-08-04 15:16

Ok, I will check. Thanks
(0010800)
piers.taylor (reporter)
2010-08-04 15:26

Cool - sorry, I forgot to post the version I patched locally...
Version is: TestLink 1.8.5
Downloaded as: testlink_1.8.5b.tgz yesterday at 9:07 BST
(0010803)
brainbug (reporter)
2010-08-05 15:41

...and i thought its a problem on my machine... :-)
i removed the [] as piers.taylor recommended and yes, now it works. thanks.
(tested in same version - 1.8.5b)

I checked it on my 1.9b5 installation and found (quite) the same passage in line 135:
<select name="logLevel[]" size="5" multiple="multiple" >

=> but here, it works (with and without [])

...I am getting an database error when I filter on user, but that's an other issue (have to check if it is already logged...)

regards,
BrainBug
(0011086)
fman (administrator)
2010-08-31 20:27

Release BETA 6 - 20100831

- Issue History
Date Modified Username Field Change
2010-06-03 17:26 aostad New Issue
2010-06-03 17:26 aostad File Added: Event viewer-no filtering.jpg
2010-06-03 17:26 aostad File Added: Event viewer- with filtering.jpg
2010-08-04 14:53 piers.taylor Note Added: 0010796
2010-08-04 15:16 fman Note Added: 0010799
2010-08-04 15:16 fman Assigned To => fman
2010-08-04 15:16 fman Status new => assigned
2010-08-04 15:26 piers.taylor Note Added: 0010800
2010-08-05 15:41 brainbug Note Added: 0010803
2010-08-10 16:54 fman Status assigned => resolved
2010-08-10 16:54 fman Fixed in Version => 1.9 Beta 5
2010-08-10 16:54 fman Resolution open => fixed
2010-08-31 20:27 fman Note Added: 0011086
2010-08-31 20:27 fman Status resolved => closed



Copyright © 2000 - 2019 MantisBT Team
Powered by Mantis Bugtracker