Mantis Bugtracker          
testlink.org

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0003491TestLinkTest Specificationpublic2010-05-27 03:272010-07-02 18:35
Reporterterryzuo 
Assigned Tofman 
PriorityhighSeveritymajorReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version1.9 Beta 4 
Fixed in Version1.9 Beta 5 
Summary0003491: reorder steps dose not work on internet explorer
Descriptionafter delete the steps, click "reorder steps", nothing happen.

TagsNo tags attached.
Database (MySQL,Postgres,etc)
BrowserIE8
PHP Version
TestCaseID
QA Team - Task Workflow Status
Attached Fileszip file icon reorder_failed.zip [^] (35,428 bytes) 2010-05-27 03:27
png file icon 5-27-2010 3-50-17 PM.png [^] (9,762 bytes) 2010-05-27 07:52


png file icon reorder_steps.PNG [^] (54,641 bytes) 2010-05-31 06:54


png file icon 2re-order.png [^] (15,474 bytes) 2010-06-01 01:31


zip file icon fix-3491.zip [^] (5,552 bytes) 2010-06-02 10:11

- Relationships
related to 0003392closedfman Add functionality to "insert step" between already existing steps 

-  Notes
(0010170)
Julian (reporter)
2010-05-27 05:27

please explain better
(0010171)
terryzuo (reporter)
2010-05-27 06:47
edited on: 2010-05-27 06:47

1.created test case step by step, i.e step number with 1/2/3/4
2.user deleted step1
3.and then there are 2/3/4 left
4.try to use "reorder steps" button to adjust the step number and order, but nothing happened

(0010173)
Julian (reporter)
2010-05-27 07:14

works fine for me.
i followed your instructions.
(0010175)
terryzuo (reporter)
2010-05-27 07:51

I've double checked with 1.9b4 version. Also checked with the update fix-3405 file:archiveData.php. It always pops up the following errors.

Webpage error details
Message: Object doesn't support this property or method
Line: 361
Char: 38
Code: 0
URI: testlink/lib/testcases/archiveData.php?version_id=11054&edit=testcase&id=10846
(0010176)
Julian (reporter)
2010-05-27 07:53

what is the purpose of attached screenshot?
(0010198)
terryzuo (reporter)
2010-05-31 00:53

To Julian,
Attached screenshot:there are 2 UI controls in the edit page, is it by design?
Attached zip file: there are 3 shots about this issue--reoder not work.
(0010199)
Julian (reporter)
2010-05-31 06:55

please check screenshot.

if this does not work for you try to make a new installation or give us some more details. i cannot see anything on your attached screenshots - as there are no comments in the picture or in the notes.
(0010203)
terryzuo (reporter)
2010-06-01 01:28

To Julian,
compared with your screens, I found when I click "show/hide reorders" in the first step,
yours: can see the steps field
mine: there will pop up the error:

Webpage error details
Message: Object doesn't support this property or method
Line: 361
Char: 38
Code: 0
URI: .../testlink/lib/testcases/archiveData.php?version_id=11054&edit=testcase&id=10846

so maybe I should upadte the archivedata.php file.
(0010204)
terryzuo (reporter)
2010-06-01 01:29

"show/hide reorders" means the "Arrow button" in your first screen.
(0010206)
terryzuo (reporter)
2010-06-02 02:04

It's Ok with FireFox 3.6.3; this issue really exists on IE7 and IE8.
(0010207)
Julian (reporter)
2010-06-02 05:13

this is the reason why you should fill in as many details as possible on each issue.

i can confirm that it does not work on IE8
(0010209)
terryzuo (reporter)
2010-06-02 06:41

Sure. I got it.
I'll improve the report detail in the future.
thanks.
(0010214)
fman (administrator)
2010-06-02 09:28

some similar problems on Opera
(0010215)
fman (administrator)
2010-06-02 10:11

1. remove all files on template_c directory
2. clean-up browser cache
3. install attached fix
4. retest
(0010221)
terryzuo (reporter)
2010-06-03 03:35

It dose work!! Thanks.

However, when the usr click the "Arrow" button to enbale the re-order mode,
there are still errors with the following:
Webpage error details
Message: Object doesn't support this property or method
Line: 385
Char: 38
Code: 0
URI: http://.../testlink/lib/testcases/archiveData.php?version_id=undefined&edit=testcase&id=10917 [^]
(0010222)
fman (administrator)
2010-06-03 08:36

seems to be a problem with event.stopPropagation() nothing to do with PHP code.
If you remove it from the corresponding smarty template, message will not be there
Configure IE8 to be a little more 'silent'.
(0010489)
fman (administrator)
2010-07-02 18:35

1.9 Beta 5 released

- Issue History
Date Modified Username Field Change
2010-05-27 03:27 terryzuo New Issue
2010-05-27 03:27 terryzuo File Added: reorder_failed.zip
2010-05-27 05:27 Julian Note Added: 0010170
2010-05-27 06:47 terryzuo Note Added: 0010171
2010-05-27 06:47 terryzuo Note Edited: 0010171 View Revisions
2010-05-27 07:07 Julian Additional Information Updated View Revisions
2010-05-27 07:14 Julian Note Added: 0010173
2010-05-27 07:51 terryzuo Note Added: 0010175
2010-05-27 07:52 terryzuo File Added: 5-27-2010 3-50-17 PM.png
2010-05-27 07:53 Julian Note Added: 0010176
2010-05-31 00:53 terryzuo Note Added: 0010198
2010-05-31 06:54 Julian File Added: reorder_steps.PNG
2010-05-31 06:55 Julian Note Added: 0010199
2010-06-01 01:28 terryzuo Note Added: 0010203
2010-06-01 01:29 terryzuo Note Added: 0010204
2010-06-01 01:31 terryzuo File Added: 2re-order.png
2010-06-02 02:04 terryzuo Note Added: 0010206
2010-06-02 05:13 Julian Note Added: 0010207
2010-06-02 06:41 terryzuo Note Added: 0010209
2010-06-02 08:22 Julian Browser => IE8
2010-06-02 08:22 Julian Summary reorder steps dose not work on 19b4 => reorder steps dose not work on internet explorer
2010-06-02 09:28 fman Note Added: 0010214
2010-06-02 10:11 fman Note Added: 0010215
2010-06-02 10:11 fman File Added: fix-3491.zip
2010-06-02 10:11 fman Assigned To => fman
2010-06-02 10:11 fman Status new => feedback
2010-06-03 03:35 terryzuo Note Added: 0010221
2010-06-03 03:35 terryzuo Status feedback => assigned
2010-06-03 08:36 fman Note Added: 0010222
2010-06-03 08:36 fman Status assigned => resolved
2010-06-03 08:36 fman Fixed in Version => 1.9 Beta 5
2010-06-03 08:36 fman Resolution open => fixed
2010-07-02 18:35 fman Note Added: 0010489
2010-07-02 18:35 fman Status resolved => closed
2010-08-04 14:48 fman Relationship added related to 0003392



Copyright © 2000 - 2019 MantisBT Team
Powered by Mantis Bugtracker