Mantis Bugtracker          
testlink.org

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0003484TestLinkAPI - XMLRPCpublic2010-05-24 04:542010-08-31 20:29
Reportertestlinkiscool 
Assigned Tofman 
PriorityurgentSeveritymajorReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSwindowsOS Versionwindows vista
Product Version1.8.5 (bug fixing) 
Fixed in Version1.9 Beta 4 
Summary0003484: tl.addTestCaseToTestPlan not working. no errors was shown. But Testcases not in assigned testplan after adding.
Description    public static Object[] AddTestcases(String dev_key, int tpid, int Testid,
            int excaseid, int version) {
        
        String[] params = { "devKey", "testprojectid", "testplanid",
                "testcaseexternalid", "version" };
        
        Object[] values = { DEV_KEY, tpid, Testid, excaseid, version };
    
        System.out.println("values: " + DEV_KEY + " " + tpid + " " + Testid
                + " " + excaseid + " " + version);
        Object[] result = callAddCase("tl.addTestCaseToTestPlan", params,
                values);

        return result;

    }


my method. everything is passed in correctly. i doubled checked. But testcases still could not be added.. this is an important feature for me.. any help?
TagsNo tags attached.
Database (MySQL,Postgres,etc)
Browser
PHP Version
TestCaseID
QA Team - Task Workflow Status
Attached Files

- Relationships
related to 0003489closedfman addTestCaseToTestPlan ends with : "The processing instruction target matching "[xX][mM][lL]" is not allowed" 

-  Notes
(0010133)
testlinkiscool (reporter)
2010-05-24 07:17

any idea?
(0010135)
testlinkiscool (reporter)
2010-05-24 08:11

anyway im using the java api~
(0010146)
fman (administrator)
2010-05-25 18:54
edited on: 2010-05-25 18:58

1. edit database.class.php
look for
$errorMsg = "ERROR ON exec_query() - database.class.php
" . $this->error(htmlspecialchars($p_query)) .
"
THE MESSAGE : $message ";
reportFatal($errorMsg); WRONG!!!
replace with $this->reportFatal($errorMsg);

2. add missing column author_id (copy column spec for other table with same kind of column) on testplan_tcversions table

3. add missing column creation_ts (copy column spec for other table with same kind of column) on testplan_tcversions table

now things has to work.
Please let us know

(0010150)
testlinkiscool (reporter)
2010-05-26 01:47

ok thanks fman once again..thankyou very much. i will go try it.. :D
(0010151)
testlinkiscool (reporter)
2010-05-26 04:05

nope.. not working still.. :(
(0010155)
testlinkiscool (reporter)
2010-05-26 07:52

Failed to parse servers response: Expected methodResponse element, got br

error shown
(0010157)
testlinkiscool (reporter)
2010-05-26 10:09
edited on: 2010-05-26 10:18

yeah, the problem is with it has no results in testlink. i dont think there's any problem with our coding in the client side. everything is correct..no errors..must the server side

(0010158)
fman (administrator)
2010-05-26 10:41
edited on: 2010-05-26 10:42

1. next time you need to upload code use an attachment instead of adding code on notes.

2. We need to use a method to test => common client => the PHP client provided with TestLink.
Is what I've used yesterday to find the problem.
When you have checked that with our client things go OK, then we have proof that problem is not on server side.
Till this moment we can not have any way to help.

3. I will redo my test, and check very well results and give you feedback during next days

(0010165)
fman (administrator)
2010-05-26 20:05

see sample code attached in related issue
(0010167)
testlinkiscool (reporter)
2010-05-27 02:03

1. ok i will, sorry about that!:)
2. so what you mean is that, php client is working? but I'm only interested in using the java client.. :(
3. thanks alot :)
(0010174)
fman (administrator)
2010-05-27 07:37

Test by dev team ok.
(0011183)
fman (administrator)
2010-08-31 20:29

Release BETA 6 - 20100831

- Issue History
Date Modified Username Field Change
2010-05-24 04:54 testlinkiscool New Issue
2010-05-24 05:02 testlinkiscool Note Added: 0010132
2010-05-24 06:08 testlinkiscool Note Deleted: 0010132
2010-05-24 07:17 testlinkiscool Note Added: 0010133
2010-05-24 08:11 testlinkiscool Note Added: 0010135
2010-05-25 18:54 fman Note Added: 0010146
2010-05-25 18:56 fman Note Edited: 0010146 View Revisions
2010-05-25 18:57 fman Note Edited: 0010146 View Revisions
2010-05-25 18:58 fman Note Edited: 0010146 View Revisions
2010-05-25 18:58 fman Assigned To => fman
2010-05-25 18:58 fman Status new => assigned
2010-05-25 18:58 fman Status assigned => feedback
2010-05-26 01:47 testlinkiscool Note Added: 0010150
2010-05-26 01:47 testlinkiscool Status feedback => assigned
2010-05-26 04:05 testlinkiscool Note Added: 0010151
2010-05-26 07:52 testlinkiscool Note Added: 0010155
2010-05-26 10:07 quartoxuna Note Added: 0010156
2010-05-26 10:09 testlinkiscool Note Added: 0010157
2010-05-26 10:18 testlinkiscool Note Edited: 0010157 View Revisions
2010-05-26 10:41 fman Note Added: 0010158
2010-05-26 10:41 fman Status assigned => feedback
2010-05-26 10:42 fman Note Edited: 0010158 View Revisions
2010-05-26 14:18 quartoxuna Note Added: 0010161
2010-05-26 20:03 fman Note Deleted: 0010156
2010-05-26 20:04 fman Relationship added related to 0003489
2010-05-26 20:04 fman Note Deleted: 0010161
2010-05-26 20:05 fman Note Added: 0010165
2010-05-27 02:03 testlinkiscool Note Added: 0010167
2010-05-27 02:03 testlinkiscool Status feedback => assigned
2010-05-27 07:37 fman Note Added: 0010174
2010-05-27 07:37 fman Status assigned => resolved
2010-05-27 07:37 fman Fixed in Version => 1.9 Beta 4
2010-05-27 07:37 fman Resolution open => fixed
2010-08-31 20:29 fman Note Added: 0011183
2010-08-31 20:29 fman Status resolved => closed
2013-04-25 17:30 fman Category TL API => XMLRPC API
2013-04-25 17:30 fman Category XMLRPC API => API - XMLRPC



Copyright © 2000 - 2020 MantisBT Team
Powered by Mantis Bugtracker