Mantis Bugtracker          
testlink.org

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0003481TestLinkTest Specificationpublic2010-05-21 08:582010-08-31 20:29
Reportertwelve 
Assigned Tofman 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version1.9 Beta 3 
Fixed in Version1.9 Beta 5 
Summary0003481: Preconditions are lost when versioning testcases
DescriptionHello, it's me again.

When creating a new version of a testcase, the preconditions are not copied over, but instead get reset to an empty string, so you have to copy and paste the preconditions manually every time.
Steps To Reproduce* Create a testcase and enter some text into the preconditions textarea
* Create a new version of this testcase
* The new version does not have any preconditions anymore
Additional InformationThe function copy_tcversion in lib/functions/testcase.class.php does not take care of the preconditions. It only copies summary, importance, etc.
TagsNo tags attached.
Database (MySQL,Postgres,etc)
Browser
PHP Version
TestCaseID
QA Team - Task Workflow Status
Attached Fileszip file icon fix-3481.zip [^] (34,875 bytes) 2010-05-21 18:32

- Relationships

-  Notes
(0010105)
fman (administrator)
2010-05-21 10:44

have you checked with 1.9 beta 4 ?
(0010108)
twelve (reporter)
2010-05-21 11:20

I did not try it out on the website itself, but I looked at the source code and could not find any changes to this functionality. So I believe the problem still exists in 1.9 Beta 4.
(0010111)
Julian (reporter)
2010-05-21 11:41

i can reproduce with 1.9 head - fyi.
(0010126)
fman (administrator)
2010-05-21 18:33

please use attached fix, retest and let us know
(0010127)
Julian (reporter)
2010-05-21 21:22

works for me (tested on current head)
(0010141)
twelve (reporter)
2010-05-25 07:13

Revision 1.274 fixes the problem for me too.
(0011186)
fman (administrator)
2010-08-31 20:29

Release BETA 6 - 20100831

- Issue History
Date Modified Username Field Change
2010-05-21 08:58 twelve New Issue
2010-05-21 10:44 fman Note Added: 0010105
2010-05-21 11:20 twelve Note Added: 0010108
2010-05-21 11:41 Julian Note Added: 0010111
2010-05-21 14:30 fman Assigned To => fman
2010-05-21 14:30 fman Status new => acknowledged
2010-05-21 18:32 fman File Added: fix-3481.zip
2010-05-21 18:33 fman Status acknowledged => assigned
2010-05-21 18:33 fman Note Added: 0010126
2010-05-21 18:33 fman Status assigned => feedback
2010-05-21 21:22 Julian Note Added: 0010127
2010-05-25 07:13 twelve Note Added: 0010141
2010-05-25 07:13 twelve Status feedback => assigned
2010-05-25 08:54 fman Status assigned => resolved
2010-05-25 08:54 fman Fixed in Version => 1.9 Beta 5
2010-05-25 08:54 fman Resolution open => fixed
2010-08-31 20:29 fman Note Added: 0011186
2010-08-31 20:29 fman Status resolved => closed



Copyright © 2000 - 2019 MantisBT Team
Powered by Mantis Bugtracker