Mantis Bugtracker          
testlink.org

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0003479TestLinkCustom fieldspublic2010-05-20 09:422010-08-31 20:28
Reportertwelve 
Assigned Tofman 
PrioritynormalSeveritytweakReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version1.9 Beta 3 
Fixed in Version1.9 Beta 5 
Summary0003479: Bulk Execution - Custom Fields Bulk Assignment (Missing custom fields on testsuite level)
DescriptionYou can create custom fields and make them available for testsuites during the test execution. However these custom fields never show up.

That also means that if you have custom fields for your testcases and do a bulk test execution for the whole testsuite, the custom fields of the children all stay empty because you cannot write any value into them.
Steps To Reproduce1. Add a new custom field. Make it available for testsuites during test execution.
2. Add this custom field to your test project.
2. Execute tests. Click on the testsuite in the tree on the left side (you'll have to enable $tlCfg->exec_cfg->show_testsuite_contents to be able to do that)
4. You can add notes and set the test status (passed, failed, etc) but there's no custom field available.
TagsNo tags attached.
Database (MySQL,Postgres,etc)
Browser
PHP Version
TestCaseID
QA Team - Task Workflow Status
Attached Filespng file icon cfieldtestsuiteexecution.png [^] (3,869 bytes) 2010-05-20 10:59


diff file icon execSetResults_cfield_mgr.diff [^] (1,564 bytes) 2010-05-20 13:12 [Show Content]

- Relationships

-  Notes
(0010079)
Julian (reporter)
2010-05-20 10:43
edited on: 2010-05-20 10:43

i guess you simply misunderstood this one.

if you define a custom field for a test suite you can only edit it on test specification ("edit test suite").

execution will only SHOW content for this custom field.

(0010080)
twelve (reporter)
2010-05-20 11:06

The dialog to add custom fields allows you to add a custom field for testsuites which is available during test execution. The test execution page for the testsuite also has the space to actually display those custom fields, it's just that they aren't there, because the logic to handle custom fields on testsuite level is missing (as far as I can tell).
So this isn't a misunderstanding, but a feature request to close this gap and make the code which handles custom fields for testcases during execution also available for testsuites.
If this is not the right place to report feature requests then I'm sorry.
(0010081)
Julian (reporter)
2010-05-20 11:11
edited on: 2010-05-20 11:23

please tell me why you wish to add a custom field value for a test suite while executing test cases?
you can add custom field for test cases for each execution.

"available during test execution" - it is avaiable but not editable. it can only be edited on test suite edit.

0. i expect you already added custom field
1. "Edit Test Cases"
2. click on test suite in tree
3. click "Edit"
4. find your custom field and insert value
5. save test suite
6. click on execute
7. chose test case within test suite in execution tree
8. expand "Test Suite Details"
9. Find the value of your custom field on execution page.

(0010082)
twelve (reporter)
2010-05-20 11:53
edited on: 2010-05-20 11:53

The reasoning behind this request is that we want to write down which parameters where used while executing the testcases. Its important that we can look up this information in the history of the test results. Usually the same parameters are used for all testcases within a testsuite at our place, however the parameters may change on the next test run.
Of course we can note the parameters down in a custom field for each testcase over and over again, but this is cumbersome.

I'll give a detailed example:
We have a testsuite which contains lets say 50 testcases. Someone executes the testcases one after the other with certain parameters, for example he uses the product number 115 for his tests. Now he has to type 50 times "product # 115" in a custom field of each testcase, no matter if the testcase passed or failed.
It would be easier if he could add "product # 115" once to a custom field of the testsuite (saves typing 49 times the same information again).
Of course the product number is just a random example here, it could be any kind of information that is true for all children of a testsuite.

Defining the value of a custom field at test specification time does not help because the parameters are not static. For example at the next test run, product number 272 might be used.

(0010083)
Julian (reporter)
2010-05-20 11:58

as there are no execution results for test suites i think this request is out of focus for us. how about using different builds (or even platforms) for this purpose ?
(0010084)
twelve (reporter)
2010-05-20 12:21

Ok thanks for the feedback.

How can platforms or builds help us? Do you mean to set up a different platform for each possible value of a parameter?
(0010085)
Julian (reporter)
2010-05-20 12:38
edited on: 2010-05-20 12:40

maybe your product # 115 was just an example that made me believe that you have to test several customized solutions of your product. and this could be interpreted as a build or a platform.

anyways now it is up to you to find a clever solution :)

(0010086)
twelve (reporter)
2010-05-20 13:11
edited on: 2010-05-20 13:15

Yes it was just an example, however there are many products and we are already using platforms and builds for other purposes (the application can be startup in different modes and each mode is a platform). So this is not a solution for our problem as long as it's not possible to add multiple layers of platforms.

Our "clever" solution is to prefill each custom field of a testcase with the value that the user entered last in this field. So he only has to type "product # 115" once and then this custom field is automatically prefilled at every other testcase with whatever he entered last.
This is done by saving the value to his session.

Patch against Testlink 1.9 Beta 3 is attached for everyone who might be interested. Please note that the patch does not follow any coding guidelines and only takes care about custom fields of type string, since that's enough for us.

After Bug 0003478 will be fixed the process to enter the test execution results is going to be somewhat streamlined.

(0010087)
fman (administrator)
2010-05-20 13:27

Please
1. Do not create patches againts a version different tha 1.9 beta 4
2. If you plan to contribute, please follow our coding guidelines, because if not your code will have to be fully refactored, and these meand double work.
(0010088)
twelve (reporter)
2010-05-20 13:46

The original intent of this bug report was a feature request about execution results for test suites. After it was pointed out that this could not be easely implemented I just explained my workaround and provided a patch for other people who might face the same problem and stumble across this bug report. That's all.

By not following coding guidelines I meant that this patch is a quick hack. I don't know if those functions are the right place to put this code into, since I don't know anything about the architecture and design of the Testlink source code. Hence I'm not able to provide you with patches that can just be copied and pasted into CVS.
(0010089)
fman (administrator)
2010-05-20 15:42

this issue need to be reorganized, because contains to different issues inside.
One talking about cf for test suites, and other talking about test cases CF on bulk exec.
Please try to create as much atomic issues, in order to allow a better tracking.
Thanks for contribution
Anyway this feature will not be part of 1.9 release
(0010189)
fman (administrator)
2010-05-27 20:36

Implementation:
on bulk execution a instance of each Custom Field enabled on Execution will be present.
Values filled / setted by user will be written WITH SAME VALUE ON ALL TEST CASES
(0011135)
fman (administrator)
2010-08-31 20:28

Release BETA 6 - 20100831

- Issue History
Date Modified Username Field Change
2010-05-20 09:42 twelve New Issue
2010-05-20 10:43 Julian Note Added: 0010079
2010-05-20 10:43 Julian Note Edited: 0010079 View Revisions
2010-05-20 10:59 twelve File Added: cfieldtestsuiteexecution.png
2010-05-20 11:06 twelve Note Added: 0010080
2010-05-20 11:11 Julian Note Added: 0010081
2010-05-20 11:12 Julian Note Edited: 0010081 View Revisions
2010-05-20 11:23 Julian Note Edited: 0010081 View Revisions
2010-05-20 11:53 twelve Note Added: 0010082
2010-05-20 11:53 twelve Note Edited: 0010082 View Revisions
2010-05-20 11:58 Julian Note Added: 0010083
2010-05-20 12:21 twelve Note Added: 0010084
2010-05-20 12:38 Julian Note Added: 0010085
2010-05-20 12:40 Julian Note Edited: 0010085 View Revisions
2010-05-20 13:11 twelve Note Added: 0010086
2010-05-20 13:12 twelve File Added: execSetResults_cfield_mgr.diff
2010-05-20 13:15 twelve Note Edited: 0010086 View Revisions
2010-05-20 13:27 fman Note Added: 0010087
2010-05-20 13:46 twelve Note Added: 0010088
2010-05-20 15:42 fman Note Added: 0010089
2010-05-27 20:36 fman Note Added: 0010189
2010-05-27 20:37 fman Summary Missing custom fields on testsuite level => Bulk Execution - Custom Fields Bulk Assignment (Missing custom fields on testsuite level)
2010-05-27 20:50 fman Status new => resolved
2010-05-27 20:50 fman Fixed in Version => 1.9 Beta 5
2010-05-27 20:50 fman Resolution open => fixed
2010-05-27 20:50 fman Assigned To => fman
2010-08-31 20:28 fman Note Added: 0011135
2010-08-31 20:28 fman Status resolved => closed



Copyright © 2000 - 2019 MantisBT Team
Powered by Mantis Bugtracker