Mantis Bugtracker          
testlink.org

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0003472TestLinkReportspublic2010-05-18 13:472010-07-04 16:41
Reportertwelve 
Assigned Tofman 
PrioritynormalSeveritymajorReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version1.9 Beta 3 
Fixed in Version1.9 Beta 5 
Summary0003472: Charts do not work with platforms
DescriptionThe charts which show how many tests passed, failed, etc do not work when a testplan contains multple platforms. The reason is that the function getStatusTotalsByPlatform() in lib/functions/testplan.class.php only queries the last execution result for each testcase in this testplan testplan from the database, however it needs to get the last execution result in this testplan AND in this platform.
A possible solution is to use a mapOfMap instead of an array for the results, because mapOfMap in the get_linked_tcversions() function automatically adds a group by platform clause.
Steps To ReproduceCreate a testplan with multple platforms, run some tests for different platforms and then look at the charts. You do not see any platform specific results except for the last tested platform.
Additional InformationA patch for Testlink 1.9 Beta 3 is attached which replaces the array with a mapOfMap, the same way as getStatusTotalsByAssignedTesterPlatform() already does.
TagsNo tags attached.
Database (MySQL,Postgres,etc)
Browser
PHP Version
TestCaseID
QA Team - Task Workflow Status
Attached Filesdiff file icon testplan.class.diff [^] (2,204 bytes) 2010-05-18 13:47 [Show Content]

- Relationships

-  Notes
(0010058)
fman (administrator)
2010-05-18 17:42

please retest with 1.9 beta 4
(0010217)
fman (administrator)
2010-06-02 10:56

Please give feedback, we need to understand if can be closed
(0010218)
twelve (reporter)
2010-06-02 11:48

Upgrading is a lot of work since we have to port all our patches to a new version. Hence I'm reluctant to update to every beta version. I'll test with Beta 5.
If you can tell me which revision fixes this bug I can test just that diff.

- Issue History
Date Modified Username Field Change
2010-05-18 13:47 twelve New Issue
2010-05-18 13:47 twelve File Added: testplan.class.diff
2010-05-18 17:42 fman Note Added: 0010058
2010-05-18 18:46 fman Assigned To => fman
2010-05-18 18:46 fman Status new => feedback
2010-06-02 10:56 fman Note Added: 0010217
2010-06-02 11:48 twelve Note Added: 0010218
2010-06-02 11:48 twelve Status feedback => assigned
2010-06-02 14:09 fman Status assigned => resolved
2010-06-02 14:09 fman Fixed in Version => 1.9 Beta 5
2010-06-02 14:09 fman Resolution open => fixed
2010-07-04 16:41 fman Status resolved => closed



Copyright © 2000 - 2019 MantisBT Team
Powered by Mantis Bugtracker