Mantis Bugtracker          
testlink.org

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0003471TestLinkGeneralpublic2010-05-18 13:322010-08-31 20:29
Reportertwelve 
Assigned Tofman 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version1.9 Beta 3 
Fixed in Version1.9 Beta 5 
Summary0003471: window.open calls fail when name contains spaces
DescriptionThe javascript window.open() function takes three parameters: URL, name and features. By the DOM definition the name parameter must only contain alphanumeric characters and underscores. However in testlink often names that contain spaces are used.
All these spaces in the name parameters must be removed. If variables are used to fill in the name, care must be taken that the value of these variables must not contain spaces either.
Steps To ReproduceExample: Try to open the window to import test results via XML files in IE7 or IE8. You cannot open the window because the name parameter contains spaces.
Additional InformationIn the example given above, the javascript function openImportResult in gui/javascript/test_automation.js is called, which in turn calls window.open and passes the value of $labels.import_xml_results as the name parameter. However this string contains spaces and therefore the window.open call fails.

openLinkedReqSpecWindow in gui/javascript/testlink_library.js does the same and doesn't work either.
TagsNo tags attached.
Database (MySQL,Postgres,etc)
Browser
PHP Version
TestCaseID
QA Team - Task Workflow Status
Attached Fileszip file icon fix-3471.zip [^] (7,820 bytes) 2010-05-18 19:27

- Relationships

-  Notes
(0010056)
fman (administrator)
2010-05-18 17:40

know issue, please update to 1.9 beta 4 and retest
(0011203)
fman (administrator)
2010-08-31 20:29

Release BETA 6 - 20100831

- Issue History
Date Modified Username Field Change
2010-05-18 13:32 twelve New Issue
2010-05-18 17:40 fman Note Added: 0010056
2010-05-18 19:27 fman File Added: fix-3471.zip
2010-05-18 19:28 fman Status new => resolved
2010-05-18 19:28 fman Fixed in Version => 1.9 Beta 5
2010-05-18 19:28 fman Resolution open => fixed
2010-05-18 19:28 fman Assigned To => fman
2010-08-31 20:29 fman Note Added: 0011203
2010-08-31 20:29 fman Status resolved => closed



Copyright © 2000 - 2019 MantisBT Team
Powered by Mantis Bugtracker