Mantis Bugtracker          
testlink.org

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0003466TestLinkTest Executepublic2010-05-17 09:142010-07-02 18:35
Reportermehrich 
Assigned Tofman 
PrioritynormalSeveritymajorReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version1.9 Beta 4 
Fixed in Version1.9 Beta 5 
Summary0003466: Test Execution frame not displayed
DescriptionWhen a test case should be executed (Execute - any Testcase) the right frame remains blank.
Steps To Reproduce1. Choose Execute
2. Click on a test case in the test case tree
Additional Informationthe error probably comes from a typo in lib/execute/execNavigator.php, line 241.

Possible solution:

diff -bBudr testlink-1.9beta4/lib/execute/execNavigator.php ../testlink/lib/execute/execNavigator.php
--- testlink-1.9beta4/lib/execute/execNavigator.php 2010-04-29 16:56:22.000000000 +0200
+++ ../testlink/lib/execute/execNavigator.php 2010-05-17 11:03:15.822470215 +0200
@@ -238,7 +238,7 @@
     }
     else
     {
- $args->do_refresh = ($cfgObj->spec_cfg->automatic_tree_refresh > 0) ? "yes": "no";
+ $args->do_refresh = ($cfgObj->automatic_tree_refresh > 0) ? "yes": "no";
     }
     $_SESSION['tcspec_refresh_on_action'] = $args->do_refresh;
TagsNo tags attached.
Database (MySQL,Postgres,etc)
Browser
PHP Version
TestCaseID
QA Team - Task Workflow Status
Attached Fileszip file icon execNavigator.zip [^] (6,868 bytes) 2010-05-17 19:54

- Relationships

-  Notes
(0010026)
fman (administrator)
2010-05-17 15:59

thanks, will check
(0010028)
mehrich (reporter)
2010-05-17 16:50

Now I think the problem is at another point in the same file:

@@ -316,6 +316,7 @@
     $cfg->gui = config_get('gui');
     $cfg->exec = config_get('exec_cfg');
     $cfg->results = config_get('results');
+ $cfg->spec_cfg = config_get('spec_cfg');
     
     return $cfg;
 }

BTW, as admin I cannot reproduce the error.
(0010033)
fman (administrator)
2010-05-17 19:53

Issue has been solved on CVS, in an slight different form, try attached fiel
(0010049)
mehrich (reporter)
2010-05-18 07:52

yes, that works too. Thanks.
(0010501)
fman (administrator)
2010-07-02 18:35

1.9 Beta 5 released

- Issue History
Date Modified Username Field Change
2010-05-17 09:14 mehrich New Issue
2010-05-17 15:59 fman Note Added: 0010026
2010-05-17 16:50 mehrich Note Added: 0010028
2010-05-17 19:53 fman Note Added: 0010033
2010-05-17 19:54 fman File Added: execNavigator.zip
2010-05-17 19:54 fman Assigned To => fman
2010-05-17 19:54 fman Status new => feedback
2010-05-18 07:52 mehrich Note Added: 0010049
2010-05-18 07:52 mehrich Status feedback => assigned
2010-05-18 10:13 fman Status assigned => resolved
2010-05-18 10:13 fman Fixed in Version => 1.9 Beta 5
2010-05-18 10:13 fman Resolution open => fixed
2010-07-02 18:35 fman Note Added: 0010501
2010-07-02 18:35 fman Status resolved => closed



Copyright © 2000 - 2019 MantisBT Team
Powered by Mantis Bugtracker