Mantis Bugtracker          
testlink.org

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0003457TestLinkAPI - XMLRPCpublic2010-05-13 16:172010-07-02 18:35
Reporterbrianj 
Assigned Tofman 
PrioritynormalSeveritymajorReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version1.9 Beta 4 
Fixed in Version1.9 Beta 5 
Summary0003457: createTestcase returns an external id which isn't the external id
DescriptionWhen you look at the return value for createTestcase you get something like this:

creating new testcase...
[{'status': True, 'additionalInfo': {'new_name': '', 'version_number': 1, 'msg':
 'ok', 'status_ok': 1, 'external_id': '9095', 'id': '47093', 'has_duplicate': Fa
lse}, 'operation': 'createTestCase', 'message': 'Success!', 'id': '9095'}]


The really messed up thing is that the field called "external_id" is *not* the external id, and the last field called "id" is similarly not the id.

Maybe they should be called 'notTheExternalId' and 'notTheid' (I'm joking, but this needs to be fixed).
TagsNo tags attached.
Database (MySQL,Postgres,etc)
Browser
PHP Version
TestCaseID
QA Team - Task Workflow Status
Attached Files

- Relationships
related to 0003458closedfman createTestCase() crashed due to SQL error 

-  Notes
(0009997)
fman (administrator)
2010-05-13 16:23

>> Maybe they should be called 'notTheExternalId'
>> and 'notTheid' (I'm joking, but this needs to be fixed).
Please provide just: detailed steps to reproduce, and data that can be useful to solve issue.
(0010510)
fman (administrator)
2010-07-02 18:35

1.9 Beta 5 released

- Issue History
Date Modified Username Field Change
2010-05-13 16:17 brianj New Issue
2010-05-13 16:23 fman Note Added: 0009997
2010-05-13 18:40 fman Relationship added related to 0003458
2010-05-16 08:55 fman Status new => resolved
2010-05-16 08:55 fman Fixed in Version => 1.9 Beta 5
2010-05-16 08:55 fman Resolution open => fixed
2010-05-16 08:55 fman Assigned To => fman
2010-07-02 18:35 fman Note Added: 0010510
2010-07-02 18:35 fman Status resolved => closed
2013-04-25 17:30 fman Category TL API => XMLRPC API
2013-04-25 17:30 fman Category XMLRPC API => API - XMLRPC



Copyright © 2000 - 2020 MantisBT Team
Powered by Mantis Bugtracker