Mantis Bugtracker          
testlink.org

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0003450TestLinkasimon_thesispublic2010-05-11 20:152010-07-02 18:35
ReporterFalcon1 
Assigned Toasimon 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version1.9 Beta 4 
Fixed in Version 
Summary0003450: Tree is colored according to latest exec result <-> Testlink 1.8.x did color tree according to results on chosen build for exec
DescriptionThe tree menù displays always the result of the last execution. If in the Filters panel I choose a specific build, or Build chosen for execution, in the tree menù I see always the result of the last execution. Also when I change the Build to execute in the Settings panel, for example a new build that I added, the tree menù displays the result of the last execution instead of (x, 0, 0, 0) on the various Test suites.

Step to reproduce.
1. Create a test suite with two test case;
2. create a test plan and add the test suite created in the step 1.;
3. create at least two build;
4. execute the test cases on the first build;
5. change Build to execute in the Settings panel, or choose in the Filters panel a specific Build different from the one with executed test cases, and the tree menù will display always the result of the last execution.
TagsFilters
Database (MySQL,Postgres,etc)
Browser
PHP Version
TestCaseID
QA Team - Task Workflow Status
Attached Filespng file icon filters_on_build_01_3450.png [^] (39,368 bytes) 2010-05-11 21:28

- Relationships
has duplicate 0003553closedasimon The creation of a new build causes a display problem on the tree and on the tests to run. 
related to 0003386closedasimon Wrong test case status when selecting a new build 

-  Notes
(0009974)
Julian (reporter)
2010-05-11 20:34
edited on: 2010-05-11 20:37

i see no error here.
for me the situation is:
1. tree always shows latest execution result
2. if you use filters colors will not be changed as latest result has not changed
3. filters only influence the "amount" of shown test cases - but filters work correctly

please explain where you see an error here.

edit:
if i understand it right you want to show only colors related to results of build chosen for execution ?

-> new build with no executions -> all test cases "grey" ( not run ) ( for example)

(0009975)
Falcon1 (reporter)
2010-05-11 21:27
edited on: 2010-05-11 21:29

I have attached the image filters_on_build_01_3450.png in which I took three screenshot. I hope the image is clear. The first is taken before executing the test cases, the second after the execution on build 1.0.0 with filter on build 1.0.0 and the third with filter changed on build 1.1.0. The tree doesn't update after changing build.

I installed also the version 1.8.5, and in the version 1.8.5 the behavior is different. In fact the tree correctly correspond to chosen build.

Yes, you are correct when you say -> new build with no executions -> all test cases "grey" ( not run ) ( for example)

(0009977)
Julian (reporter)
2010-05-11 22:16

we should think about making this configurable:

1. old behaviour : show tree colors according to current build results
2. new behaviour : show tree colors according to latest result any build
(0009978)
Falcon1 (reporter)
2010-05-11 22:33

So you're saying that it is not a bug but a change in that feature?

Please consider this scenario, common to us.
We have to execute test plan to different build because we have different customer with different release.

So we have to execute a test plan with for example 100 test cases on build 2.2.6 and 2.2.8.
A tester execute it on build 2.2.6 and another tester on build 2.2.8.
If the tree shows the result of the last build, in this case 2.2.8, the tester of build 2.2.6 cannot know which is the last test case execute.

I hope it is clear.

Thanks for support.
(0010030)
Drops (reporter)
2010-05-17 19:09

I also agree with Falcon1, we also need old behavior in our job. My voice for "1. old behaviour : show tree colors according to current build results".
(0010425)
asimon (developer)
2010-06-25 11:19

Solved in CVS. Please retest with next available beta version, feel free to reopen issue if needed.

This behavior is now configurable via option $tlCfg->exec_cfg->testcases_colouring_by_selected_build in config.inc.php

If ENABLED: coloring and numbers on root node/suites are determined by results on selected build for execution (old behavior).
DISABLED: New 1.9 behavior, last execution counts (default).
(0010478)
fman (administrator)
2010-07-02 18:35

1.9 Beta 5 released

- Issue History
Date Modified Username Field Change
2010-05-11 20:15 Falcon1 New Issue
2010-05-11 20:26 Falcon1 Tag Attached: Filters
2010-05-11 20:34 Julian Note Added: 0009974
2010-05-11 20:37 Julian Note Edited: 0009974
2010-05-11 21:27 Falcon1 Note Added: 0009975
2010-05-11 21:28 Falcon1 File Added: filters_on_build_01_3450.png
2010-05-11 21:29 Falcon1 Note Edited: 0009975
2010-05-11 22:16 Julian Note Added: 0009977
2010-05-11 22:33 Falcon1 Note Added: 0009978
2010-05-12 13:05 Julian Summary Filters on Build doesn't update tree menù => Tree is colored according to latest execution <-> Testlink 1.8.x did color tree according to chosen build for execution
2010-05-17 08:02 Julian Summary Tree is colored according to latest execution <-> Testlink 1.8.x did color tree according to chosen build for execution => Tree is colored according to latest exec result <-> Testlink 1.8.x did color tree according to results on chosen build for exec
2010-05-17 19:09 Drops Note Added: 0010030
2010-05-26 11:32 Julian Assigned To => asimon
2010-05-26 11:32 Julian Status new => assigned
2010-05-26 15:22 asimon Category Test Execute => asimon_thesis
2010-06-05 09:12 fman Relationship added related to 0003386
2010-06-25 11:19 asimon Note Added: 0010425
2010-06-25 11:19 asimon Status assigned => resolved
2010-06-25 11:19 asimon Resolution open => fixed
2010-07-02 18:35 fman Note Added: 0010478
2010-07-02 18:35 fman Status resolved => closed
2010-07-07 10:51 Julian Relationship added has duplicate 0003553



Copyright © 2000 - 2019 MantisBT Team
Powered by Mantis Bugtracker