Mantis Bugtracker          
testlink.org

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0003439TestLinkasimon_thesispublic2010-05-07 00:132010-08-31 20:27
ReporterDrops 
Assigned Toasimon 
PrioritynormalSeveritymajorReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version1.9 Beta 4 
Fixed in Version1.9 Beta 6 
Summary0003439: Requirement based report is incorrect.
Description1) Requirement based report displays incorrect requrements in result sections.
Really "Passed" requirements are displayed in "Failed Requirements" and the "Passed Requirements" section is empty.

See file InvalidRequirementsReport.doc attached with screen-shorts.

2) The number of "Requirements uncovered by Test Cases" is negative number = -6.
But all requirement have at least one TestCase.
Except 6 requirements which set to "Not testable" status for the selected document node.

3)Is it possible to view all sub-child section requirements in the report?
I used "section" type for some common requirements in my specification document IS-FE-CR-ID-4-Grundig.doc-v1.2 to structurize requirements in user friendly manner.
For example Req. Spec. : [FEM-GRU-20.50] :: Option ranges and defaults.

and its children:
   FEM-GRU-20.50.10 : Follow up dictation [min]
   FEM-GRU-20.50.20 : DSS standard
   ...
In the current implementation I has to use "Requirements Specification Document" combobox to select each section but I need one report page for all requirements in the node and its sub-nodes.
Additional InformationI updated my site from TL 1.8.5 to TL 1.9 Beta 4 Developer snapshort.
I had to use the Beta4(Head of 1.9 source from cvs) in productive as need the requirements based approach in our product test.
TagsRequirements
Database (MySQL,Postgres,etc)
BrowserIE8, Firefox 3.5.9
PHP Version
TestCaseID
QA Team - Task Workflow Status
Attached Fileszip file icon InvalidRequirementsReport.zip [^] (902,169 bytes) 2010-05-07 01:10

- Relationships
has duplicate 0003488closedasimon issue# 0002292 seems re-open on 1.9b4 version. 
has duplicate 0003569closedasimon Requirement based report displays passed requirements in "failed" section 
related to 0003261closedasimon Requirements based Report NEED REFACTOR due to req version feature 

-  Notes
(0009950)
Drops (reporter)
2010-05-07 02:52

It seems point 3) is the same as 0003299.
(0010564)
fman (administrator)
2010-07-06 16:22

>>3)Is it possible to view all sub-child section requirements in the report?
>>I used "section" type for some common requirements in my specification document >>IS-FE-CR-ID-4-Grundig.doc-v1.2 to structurize requirements in user friendly >>manner.
>>For example Req. Spec. : [FEM-GRU-20.50] :: Option ranges and defaults

does not use a issue for reporting several requests => bad practice
(0010617)
howea (reporter)
2010-07-12 23:37

Removing the last elseif around line 750 of requirements.inc.php seems to make this bug go away. This code looks like it was originally added because of bug 2171, but I removed the code and couldn't reproduce 2171.
(0010886)
asimon (developer)
2010-08-19 16:26

Requirement based report feature has been completely redesigned/rewritten.
Please wait for next available public beta and retest.
(0010896)
Drops (reporter)
2010-08-20 09:31

I have updated my testlink project by the last snapshort Aug-20-2010 12:32(+2).
Now I have nothing in the Requirement based report after testing.
 
"There are no Requirements defined in this Test Project."

Other reports works.
(0010898)
asimon (developer)
2010-08-20 09:48

Yes, this was a little follow-up error. Already fixed on CVS.
(0011060)
fman (administrator)
2010-08-31 20:27

Release BETA 6 - 20100831

- Issue History
Date Modified Username Field Change
2010-05-07 00:13 Drops New Issue
2010-05-07 00:13 Drops Browser => IE8, Firefox 3.5.9
2010-05-07 00:13 Drops PHP Version => 5.2.10-Win32
2010-05-07 00:13 Drops Tag Attached: Requirements
2010-05-07 01:10 Drops File Added: InvalidRequirementsReport.zip
2010-05-07 01:16 fman Status new => assigned
2010-05-07 01:16 fman Assigned To => Julian
2010-05-07 02:52 Drops Note Added: 0009950
2010-05-10 21:55 Julian Assigned To Julian => asimon
2010-05-26 16:16 asimon Category Reports => asimon_thesis
2010-06-02 08:30 fman Relationship added has duplicate 0003488
2010-07-06 07:47 Julian Relationship added has duplicate 0003569
2010-07-06 16:22 fman Note Added: 0010564
2010-07-12 23:37 howea Note Added: 0010617
2010-08-18 07:46 asimon Relationship added related to 0003261
2010-08-19 16:26 asimon PHP Version 5.2.10-Win32 =>
2010-08-19 16:26 asimon Note Added: 0010886
2010-08-19 16:26 asimon Status assigned => resolved
2010-08-19 16:26 asimon Fixed in Version => 1.9 Beta 6
2010-08-19 16:26 asimon Resolution open => fixed
2010-08-20 09:31 Drops Note Added: 0010896
2010-08-20 09:31 Drops Status resolved => assigned
2010-08-20 09:31 Drops Resolution fixed => reopened
2010-08-20 09:48 asimon Note Added: 0010898
2010-08-20 09:48 asimon Status assigned => resolved
2010-08-20 09:48 asimon Resolution reopened => fixed
2010-08-31 20:27 fman Note Added: 0011060
2010-08-31 20:27 fman Status resolved => closed



Copyright © 2000 - 2020 MantisBT Team
Powered by Mantis Bugtracker