Mantis Bugtracker          
testlink.org

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0003428TestLinkTest Plan (builds, milestones, test assign)public2010-05-05 04:332010-09-19 15:11
Reportermedienwolf 
Assigned Tofman 
PrioritynormalSeverityfeature requestReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version1.9 Beta 4 
Fixed in Version1.9 Beta 5 
Summary0003428: Add capabiliy to copy test plan from previous project
DescriptionTestlink currently only allows to copy testplans within a "project".
So the "project" term is more related to a "product" and not to a "release".

This leads to a large amount of test plans, that is hard to manage over the
lifetime of a product.
We currently define a testplan per feature, as each test case needs to be
executed on different platforms.
Going from one release to the next, the testplans may changed to test only
as subset of test cases within a feature to minimize testing times.
This will require creation of a new testpland and as you go along with releases
the list of test plans will increase.

In order to make it more scalable, it would be great if Testlink can offer
the capability to copy testplans between different projects (right now
test cases are taken over from one project to the next, but not testplans).
Alternatively, this could also be solved by import/export of testplans.

Also, it would be beneficial, if Testlink had the possibility to copy "projects" including the testplans so testplans can be taken from one project (release) to the next and then be modified in the new project (release).
TagsNo tags attached.
Database (MySQL,Postgres,etc)
BrowserIE Explorer 8
PHP Version
TestCaseID
QA Team - Task Workflow Status
Attached Filespng file icon cptpro1.png [^] (9,467 bytes) 2010-05-05 12:20

- Relationships
related to 0003126closedfman Request the ability to copy test project and data associate to it 
related to 0003430closedfman Copy test project crashed if milestone defined WITHOUT start date 
related to 0003435closedfman Create Project - Copying Project Data Fails When Requirements Mgmt is enabled 

-  Notes
(0009901)
fman (administrator)
2010-05-05 12:23

>> So the "project" term is more related to a "product" and not to a "release".
this is de concept of project on test link, 'artifact under test'

>> n order to make it more scalable, it would be great if Testlink can offer
>> the capability to copy testplans between different projects (right now
>> test cases are taken over from one project to the next, but not testplans).
Because test project and INDIPENDENT and isolated set of test cases, in order to copy a test plan ( set of test case LINKS ) from one test project to another, you need not only copy the LINKS but also the test cases, relates keywords and lot of other items.


>> Also, it would be beneficial, if Testlink had the possibility to copy
>> "projects" including the testplans so testplans can be taken from one project >> (release) to the next and then be modified in the new project (release).
This feature is already present see attached image.
May be info about what will be copied is not clear.
Try it and give us feedback please
(0009902)
fman (administrator)
2010-05-05 12:32

I've found a bug on milestone copy, but I was able to copy test plans, builds, platforms
(0009909)
medienwolf (reporter)
2010-05-05 20:11

The issue is that testplans can only be copied inside each project, but you cannot copy a testplan from a different project.
The idea was the following:
a) Have Project X (= Release X of product A)
Contains a list of testplans
b) New Project Y (=Release X+1 of product A)
Contains a modified list of testplans of release X
Plus new testplans.

So in order to proceed with Project Y, copy the complete project X (including
all testplans that were in there), modify them if needed and add new ones.

When i created a new project, the testplans were not copied.
Also, when trying to create a new testplan in this new project, the list
of testplans is empty, so i couldn't copy a testplan form a previous project.
(0009910)
fman (administrator)
2010-05-05 20:20

>> When i created a new project, the testplans were not copied.
I've tested it this morning and it works.
Please give me detailed steps to reproduce
(0009914)
medienwolf (reporter)
2010-05-05 20:34

Ok,
maybe it is related to the version i have - this was a based on development versions of beta 4 and not the final 1.9 Beta 4.
I'll upgrade to the 1.9 Beta 4 version and let you know whether this is still an issue.

Thanks
Hans-Joerg
(0009916)
medienwolf (reporter)
2010-05-05 23:39

I just tested the new beta 4 version and found out what the reason is -


if you enable the requirements feature when creating a project from a new one (and the test case has linked requirements) the project creation is not successful.

When you leave everything at default, the copying works.

So you have the feature, but the implementation contains a bug with respect to
carrying over the requirements or links to the requirements from the test cases.

Thanks
Hans-Joerg
(0009917)
fman (administrator)
2010-05-05 23:53

OK, I will close this.
Please open an issue with this new bug
(0010518)
fman (administrator)
2010-07-02 18:36

1.9 Beta 5 released

- Issue History
Date Modified Username Field Change
2010-05-05 04:33 medienwolf New Issue
2010-05-05 04:33 medienwolf Browser => IE Explorer 8
2010-05-05 12:20 fman File Added: cptpro1.png
2010-05-05 12:23 fman Note Added: 0009901
2010-05-05 12:24 fman Status new => feedback
2010-05-05 12:32 fman Note Added: 0009902
2010-05-05 12:32 fman Relationship added related to 0003126
2010-05-05 12:56 fman Relationship added related to 0003430
2010-05-05 20:11 medienwolf Note Added: 0009909
2010-05-05 20:20 fman Note Added: 0009910
2010-05-05 20:34 medienwolf Note Added: 0009914
2010-05-05 23:39 medienwolf Note Added: 0009916
2010-05-05 23:53 fman Note Added: 0009917
2010-05-06 04:08 fman Relationship added related to 0003435
2010-05-06 04:12 fman Status feedback => resolved
2010-05-06 04:12 fman Fixed in Version => 1.9 Beta 5
2010-05-06 04:12 fman Resolution open => fixed
2010-05-06 04:12 fman Assigned To => fman
2010-07-02 18:36 fman Note Added: 0010518
2010-07-02 18:36 fman Status resolved => closed



Copyright © 2000 - 2019 MantisBT Team
Powered by Mantis Bugtracker