Mantis Bugtracker          
testlink.org

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000342TestLinkNew Featurepublic2006-01-14 05:052010-05-01 20:34
Reportergblaire 
Assigned ToEloff 
PrioritynormalSeverityfeature requestReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version 
Fixed in Version1.9 Beta 2 
Summary0000342: Save session configuration
DescriptionTestLink should provide a mechanism for keeping the state of the users last selections.

For example, if I select a Product to work on I'm likely to be working on that product for a long time. It would be nice for things like product, active build and test procedure to be a saved session.
TagsNo tags attached.
Database (MySQL,Postgres,etc)
Browser
PHP Version
TestCaseID
QA Team - Task Workflow Status
Attached Filesgz file icon save_tplan_cookie.tar.gz [^] (12,518 bytes) 2009-08-05 15:35

- Relationships
related to 0000221resolvedmhavlat Testlink 1.6.x User login should take you to the last product the user selected 

-  Notes
(0000592)
fman (administrator)
2006-01-14 10:55

What do you mean by "test procedure", Test Plan ???
(0000594)
gblaire (reporter)
2006-01-14 19:57

These were just some examples of what selections in the gui we should attempt to cache in a cookie. If I select a product and don't leave that product before my session times out then the next time I login, I the same product should be selected.

We have a long list of products, so having to fish through and find the one I want to work on every time (when I'm not using any other product) is kind of annoying.

Does this help?
(0000600)
fman (administrator)
2006-01-15 11:35

you have not reply to may question.
the rest is clear
(0000604)
gblaire (reporter)
2006-01-15 18:59

Ooops. Yes, Test Plan.
(0002219)
mhavlat (reporter)
2007-09-24 05:06

Ok. Cookie for Test Plan and Build should not be problem.
(0007725)
Eloff (reporter)
2009-08-05 14:36

Semms this one has been left floating. I'll start coding it
(0007730)
Eloff (reporter)
2009-08-05 15:33

Ok. Here is a small fix.
This one saves current testplan to a cookie in the same way testproject is stored.

(I ignored saving build id because this is not even saved in one session now => needs more work to fix and IMHO less important than testplan)
(0008488)
Eloff (reporter)
2009-12-15 21:50

Fixed in cvs HEAD

- Issue History
Date Modified Username Field Change
2006-01-14 05:05 gblaire New Issue
2006-01-14 10:54 fman Relationship added related to 0000221
2006-01-14 10:55 fman Note Added: 0000592
2006-01-14 19:57 gblaire Note Added: 0000594
2006-01-15 11:35 fman Note Added: 0000600
2006-01-15 18:59 gblaire Note Added: 0000604
2007-02-19 23:23 mhavlat Project Testlink 1.6.x => TestLink
2007-09-24 05:06 mhavlat Note Added: 0002219
2007-09-24 05:06 mhavlat Assigned To => mhavlat
2007-09-24 05:06 mhavlat Status new => confirmed
2009-05-18 13:55 mhavlat Status confirmed => acknowledged
2009-08-05 14:36 Eloff Note Added: 0007725
2009-08-05 14:36 Eloff Status acknowledged => assigned
2009-08-05 14:36 Eloff Assigned To mhavlat => Eloff
2009-08-05 14:44 Eloff Status assigned => work in progress
2009-08-05 15:33 Eloff Note Added: 0007730
2009-08-05 15:35 Eloff File Added: save_tplan_cookie.tar.gz
2009-08-05 15:35 Eloff Status work in progress => assigned
2009-08-05 15:35 Eloff Assigned To Eloff => fman
2009-08-05 17:35 fman Assigned To fman => Eloff
2009-08-05 17:35 fman Status assigned => work in progress
2009-08-05 17:35 fman Product Version 1.6.0 =>
2009-12-15 21:50 Eloff Status work in progress => acknowledged
2009-12-15 21:50 Eloff Note Added: 0008488
2009-12-15 21:50 Eloff Status acknowledged => resolved
2009-12-15 21:50 Eloff Resolution open => fixed
2009-12-16 00:17 mhavlat Fixed in Version => 1.9 (DEV)
2010-05-01 20:34 fman Status resolved => closed



Copyright © 2000 - 2020 MantisBT Team
Powered by Mantis Bugtracker