Mantis Bugtracker          
testlink.org

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0003415TestLinkUsers and Rightspublic2010-05-02 22:092010-07-02 18:36
Reportereliasn 
Assigned Tofman 
PrioritynormalSeveritymajorReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version1.9 Beta 4 
Fixed in Version1.9 Beta 4 
Summary0003415: Not possible reset user password
DescriptionWhen I try to reset password of a user I receive the following message: "The user couldn't be updated!"

I alter the file 'custom_config.inc.php' to put the rigth email configurations, but in the testlink log file I receive the message "fsockopen() [<a href='function.fsockopen'>function.fsockopen</a>]: php_network_getaddresses: getaddrinfo failed: Este host não é conhecido. - in C:\wamp\www\testlink-1.9beta4\third_party\phpmailer\class.smtp.php - Line 105"

When I put the email configuration in config.inc.php, the warning message above disappears, but I receive the some message in user account.

Steps to reproduce:
1. With no email configuration, go to the user details and click in the button 'Reset password'. The message "The user couldn't be updated!" will appears
2. See the log file (userlog1.log) to see what occurs
3. Alter the 'custon_config.inc.php' file with valid email configuration
4. Try again reset user password. The same message in step 1 will appears
5. Alter the 'config_inc.php' file with a valid email configuration. The same message ins step 1 appears.
Additional InformationPlease, see the log file since line 1166.
TagsNo tags attached.
Database (MySQL,Postgres,etc)
Browser
PHP Version
TestCaseID
QA Team - Task Workflow Status
Attached Filespng file icon tl_user_reset_password.png [^] (17,093 bytes) 2010-05-02 22:09


log file icon userlog1.log [^] (138,644 bytes) 2010-05-02 22:10

- Relationships

-  Notes
(0009844)
fman (administrator)
2010-05-02 23:43

>> 1. With no email configuration, go to the user details and click in the button >> 'Reset password'. The message "The user couldn't be updated!" will appears
See ISSUE 3417 that solves this problem

>> 3. Alter the 'custon_config.inc.php' file with valid email configuration
Tested locally on windows using hMailServer, works fine.
Please recheck your mail consiguration.
Consider add var_dump() on email_send() function on email_api.php to get more info
(0009851)
fman (administrator)
2010-05-03 16:18

any news ?
(0009874)
eliasn (reporter)
2010-05-04 10:59

@fman
In 1.9 beta 4 this don't occurs anymore.
(0010521)
fman (administrator)
2010-07-02 18:36

1.9 Beta 5 released

- Issue History
Date Modified Username Field Change
2010-05-02 22:09 eliasn New Issue
2010-05-02 22:09 eliasn File Added: tl_user_reset_password.png
2010-05-02 22:10 eliasn File Added: userlog1.log
2010-05-02 23:26 fman Issue cloned: 0003417
2010-05-02 23:43 fman Note Added: 0009844
2010-05-02 23:43 fman Status new => assigned
2010-05-02 23:43 fman Assigned To => fman
2010-05-03 16:18 fman Note Added: 0009851
2010-05-03 16:18 fman Status assigned => feedback
2010-05-04 10:59 eliasn Note Added: 0009874
2010-05-04 15:25 fman Status feedback => resolved
2010-05-04 15:25 fman Fixed in Version => 1.9 Beta 4
2010-05-04 15:25 fman Resolution open => fixed
2010-07-02 18:36 fman Note Added: 0010521
2010-07-02 18:36 fman Status resolved => closed



Copyright © 2000 - 2019 MantisBT Team
Powered by Mantis Bugtracker