Mantis Bugtracker          
testlink.org

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0003405TestLinkTest Specificationpublic2010-04-28 06:462010-08-31 20:29
Reportereliasn 
Assigned Tofman 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version1.9 Beta 3 
Fixed in Version1.9 Beta 5 
Summary0003405: Navigation Bar - Test Case Search - Crash when search a nonexistent testcase
DescriptionWhen I try search a testcase on the topbar and this testcase doesn't exist, some information appears on the screen:
Additional Information#0 database->exec_query(SELECT prefix FROM testprojects WHERE id = ) called at [C:\wamp\www\testlink-1.9.3b\lib\functions\database.class.php:514]
#1 database->fetchFirstRow(SELECT prefix FROM testprojects WHERE id = ) called at [C:\wamp\www\testlink-1.9.3b\lib\functions\database.class.php:532]
0000002 database->fetchOneValue(SELECT prefix FROM testprojects WHERE id = ) called at [C:\wamp\www\testlink-1.9.3b\lib\functions\testproject.class.php:853]
0000003 testproject->getTestCasePrefix() called at [C:\wamp\www\testlink-1.9.3b\lib\functions\testcase.class.php:1310]
0000004 testcase->getPrefix(0, ) called at [C:\wamp\www\testlink-1.9.3b\lib\functions\testcase.class.php:4015]
0000005 testcase->getExternalID(0, ) called at [C:\wamp\www\testlink-1.9.3b\lib\functions\testcase.class.php:3994]
0000006 testcase->buildDirectWebLink(http://localhost/testlink-1.9.3b/, [^] 0) called at [C:\wamp\www\testlink-1.9.3b\lib\testcases\archiveData.php:131]
TagsExcel
Database (MySQL,Postgres,etc)
BrowserFirefox 3.6.3
PHP Version5.2.11
TestCaseID
QA Team - Task Workflow Status
Attached Filespng file icon tl_search_testcase.png [^] (15,258 bytes) 2010-04-28 06:46


log file icon userlog1.log [^] (1,234 bytes) 2010-04-28 06:46
txt file icon serial do Mcaffe UOL.txt [^] (41 bytes) 2010-04-28 10:58 [Show Content]
zip file icon fix-3405.zip [^] (2,871 bytes) 2010-05-02 17:15

- Relationships

-  Notes
(0009825)
fman (administrator)
2010-04-28 13:23

@eliasn:
1. info you see is due to a DB CRASH
2. please give detailed steps to reproduce

@pucsampa:
please clarify your note
(0009827)
eliasn (reporter)
2010-04-28 19:08

@fman
just put a nonexistent TCID, like TC-9999 in TC form search (field localized near links 'events') and click in search

for the note from @pucsampa, delete it. it's a attached about a antivirus serial (probably a spanner)
(0009839)
fman (administrator)
2010-05-02 17:16

Try with attached fix, and give us feedback
(0009841)
eliasn (reporter)
2010-05-02 21:10

Now the info about db crash no longer appear anymore.
Issue corrected.
(0011216)
fman (administrator)
2010-08-31 20:29

Release BETA 6 - 20100831

- Issue History
Date Modified Username Field Change
2010-04-28 06:46 eliasn New Issue
2010-04-28 06:46 eliasn File Added: tl_search_testcase.png
2010-04-28 06:46 eliasn Browser => Firefox 3.6.3
2010-04-28 06:46 eliasn PHP Version => 5.2.11
2010-04-28 06:46 eliasn File Added: userlog1.log
2010-04-28 10:57 pucsampa Tag Attached: Excel
2010-04-28 10:58 pucsampa File Added: serial do Mcaffe UOL.txt
2010-04-28 10:58 pucsampa Note Added: 0009824
2010-04-28 13:23 fman Note Added: 0009825
2010-04-28 13:29 fman Status new => assigned
2010-04-28 13:29 fman Assigned To => fman
2010-04-28 19:08 eliasn Note Added: 0009827
2010-04-29 01:53 pucsampa Note Deleted: 0009824
2010-05-02 17:13 fman Summary Some information appear when I try search a nonexistent testcase => Navigation Bar - Test Case Search - Crash when search a nonexistent testcase
2010-05-02 17:15 fman File Added: fix-3405.zip
2010-05-02 17:16 fman Note Added: 0009839
2010-05-02 17:16 fman Status assigned => feedback
2010-05-02 21:10 eliasn Note Added: 0009841
2010-05-02 23:29 fman Status feedback => resolved
2010-05-02 23:29 fman Fixed in Version => 1.9 Beta 5
2010-05-02 23:29 fman Resolution open => fixed
2010-08-31 20:29 fman Note Added: 0011216
2010-08-31 20:29 fman Status resolved => closed



Copyright © 2000 - 2020 MantisBT Team
Powered by Mantis Bugtracker