Mantis Bugtracker          
testlink.org

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0003392TestLinkTest Specificationpublic2010-04-17 04:182010-09-19 15:11
Reportermedienwolf 
Assigned Tofman 
PrioritynormalSeverityfeature requestReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version1.9 Beta 3 
Fixed in Version1.9 Beta 5 
Summary0003392: Add functionality to "insert step" between already existing steps
DescriptionHi,

i just ran into the issue to have to insert a step between already
existing steps.
This seems not possible now, but would be good to have.

Thanks
Hans-Joerg
TagsNo tags attached.
Database (MySQL,Postgres,etc)
Browser
PHP Version
TestCaseID
QA Team - Task Workflow Status
Attached Files

- Relationships
related to 0003491closedfman reorder steps dose not work on internet explorer 

-  Notes
(0009760)
amitkhullar (reporter)
2010-04-17 21:35

Probably an other way could be a field order of test steps / similar to test execution so that you can create a new steps and reorder the same.
(0010169)
terryzuo (reporter)
2010-05-27 03:15
edited on: 2010-05-27 08:28

On 1.9b4 version, it seemed that the user can not re-order the steps,I'm checking this and will update the foudings later.

//Edit Julian:

do not let us guess what you want to express. in my eyes your comment has nothing to do with the issue described here.

(0010776)
medienwolf (reporter)
2010-08-03 22:11

Any news on this?
It is really a pain if you suddenly find out that
step 3 should be actually behind step 4 -- there is no way
to achieve a modified step series except deleting and recreating
all steps in the right order.

Is there an easy way to just implement e.g.
Current step New step
#x #y

and if the user chooses a step in the middle this will just bump all others up by on step?
(0010777)
fman (administrator)
2010-08-04 12:14

what about reorder ?
(0010780)
amitkhullar (reporter)
2010-08-04 12:19

i think reorder should be a good feature .
(0010783)
fman (administrator)
2010-08-04 13:03

step reorder already exists, can be done from page that display all test case info
(0010792)
medienwolf (reporter)
2010-08-04 14:34

Fman,
i tried to reorder with beta 4, click on the green arrow, which says show/hide reorder.
Now a button appears which says reorder. When i click on the reorder step button nothing happens, the screen goes back to where it was before (without the step selection).
I also tried to select one of the steps or drag&drop and can't figure out how it's supposed to work (manual also doesn't explain)on how.

Can you please provide a short info how you did this.
Also, does this work in 1.9 beta 4 or do i need to upgrade to 1.9 beta 5 to get this?
(0010793)
medienwolf (reporter)
2010-08-04 14:44

FYi for everyone who is looking for the functionality - I just verified on beta 5 - this works. Just click on green arrow - then line edits appear (didn't appear in my beta 4). Just type the number and then click reorder steps.

Bug can be closed.
(0010794)
fman (administrator)
2010-08-04 14:45
edited on: 2010-08-04 14:49

medienwolf:
Please do a search here, to understand is there is an specific issue for this with a patch attached.
REMEMBER ALWAYS to remove the HIDE STATUS filter, because closed issue are not displayed.

I've added a relationship to the specific issue.

If not you have to upgrade to 1.9 beta 5

Please let me know

(0010795)
fman (administrator)
2010-08-04 14:50

resolved via REORDER
(0011101)
fman (administrator)
2010-08-31 20:27

Release BETA 6 - 20100831

- Issue History
Date Modified Username Field Change
2010-04-17 04:18 medienwolf New Issue
2010-04-17 21:35 amitkhullar Note Added: 0009760
2010-05-27 03:15 terryzuo Note Added: 0010169
2010-05-27 08:28 Julian Note Edited: 0010169 View Revisions
2010-08-03 22:11 medienwolf Note Added: 0010776
2010-08-04 12:14 fman Note Added: 0010777
2010-08-04 12:19 amitkhullar Note Added: 0010780
2010-08-04 13:03 fman Note Added: 0010783
2010-08-04 14:34 medienwolf Note Added: 0010792
2010-08-04 14:44 medienwolf Note Added: 0010793
2010-08-04 14:45 fman Note Added: 0010794
2010-08-04 14:48 fman Relationship added related to 0003491
2010-08-04 14:49 fman Note Edited: 0010794 View Revisions
2010-08-04 14:50 fman Note Added: 0010795
2010-08-04 14:50 fman Status new => resolved
2010-08-04 14:50 fman Fixed in Version => 1.9 Beta 5
2010-08-04 14:50 fman Resolution open => fixed
2010-08-04 14:50 fman Assigned To => fman
2010-08-31 20:27 fman Note Added: 0011101
2010-08-31 20:27 fman Status resolved => closed



Copyright © 2000 - 2020 MantisBT Team
Powered by Mantis Bugtracker