Mantis Bugtracker          
testlink.org

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0003305TestLinkInstallerpublic2010-03-18 17:152010-08-31 20:27
Reporterpaulmccabe 
Assigned Tofman 
PrioritynormalSeveritymajorReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version1.8.5 (bug fixing) 
Fixed in Version1.9 (Prague) 
Summary0003305: Data migration from 1.7.5 to 1.8.5 fails with error reported in apace log
DescriptionAttempting to upgrade the testlink system from version 1.7.5 to 1.8.5. The first step, the automated schema upgrade, appears to work correctly. The second step, where automated data migration occurs, fails unexpectedly.

During this process, the browser window shows progress up to the point of updating Requirement Specification and Requirements, but nothing more occurs.

Looking at the appache log there is a one line error:

PHP Fatal error: Call to undefined function reportFatal() in /var/www/testlink/lib/functions/database.class.php on line 193, referer: http://testlink/install/license.php [^]


The essense of this bug report is that the upgrade process fails and no significant error information is supplied. If the user is at fault, the system should supply enough information for the user to determine where the fault lies.

Currently the upgrade process fails and not enough information is supplied to diagnose the issue.

Additional InformationThe upgrade process has been tried multiple times using a backup database, and the process fails 100% of the time. Various data has been input at the prompts to check if the user input is affecting the outcome of the process, but has so far yielded no positive results.

Testlink produces some log information:

[>>][4ba1f6a24ae61235313006][DEFAULT][/migration/migrate_17/migrate_17_to_18.php
][10/Mar/18 09:47:14]
        [10/Mar/18 09:47:14][WARNING][<nosession>][GUI]
                E_STRICT
mysql.inc.php - Line 21
        [10/Mar/18 09:47:14][WARNING][<nosession>][GUI]
                E_STRICT
n/migrate_17/migrate_17_to_18_functions.php - Line 51
][10/Mar/18 09:47:14][10/Mar/18 09:47:17][took 2.737928 secs]
[>>][4ba1f6c9c8da2714124933][DEFAULT][/index.php][10/Mar/18 09:47:53]
09:47:53][took 0.034323 secs]
[>>][4ba1f6c9e60fd348927909][DEFAULT][/login.php][10/Mar/18 09:47:53]
        [10/Mar/18 09:47:53][WARNING][<nosession>][GUI]
                E_STRICT
mysql.inc.php - Line 21
09:47:53][took 0.048729 secs]
[>>][4ba1f6c9f21ff262904285][DEFAULT][/login.php][10/Mar/18 09:47:53]
09:47:54][took 0.089269 secs]
TagsNo tags attached.
Database (MySQL,Postgres,etc)
BrowserFirefox
PHP Version5.2.10
TestCaseID
QA Team - Task Workflow Status
Attached Fileszip file icon database.class.zip [^] (5,559 bytes) 2010-03-18 18:12

- Relationships
has duplicate 0003679closedfman Bug detected function exec_query in file database.class.php 
related to 0003633closedfman Searching for non existing test case id in the main menu leads to error "Fatal error: Call to undefined function reportFatal()" 
child of 0003570closedfman Availables Fixes for 1.9 Beta 5 

-  Notes
(0009452)
paulmccabe (reporter)
2010-03-18 17:16

Are there any sources that will allow data migration to be performed manually? e.g. SQL scripts.
(0009454)
fman (administrator)
2010-03-18 18:12

migration can not be deone manually
try with attached file
(0009457)
paulmccabe (reporter)
2010-03-18 19:08

Please note issue 3306 which is also bears some relation to this issue.
(0009460)
paulmccabe (reporter)
2010-03-18 22:17

Thanks for the attached file, but it would appear that the file generates the same duplication errors that I've reported in issue 3306.
(0009509)
haslec (reporter)
2010-03-24 21:04

Did you managed to solve your problem?

I have the same error and it seems that the requirements data where not imported;
I have created a specific issue for this.
http://www.testlink.org/mantis/view.php?id=3330 [^]

Do you have some Requirements in your database?
Thanks a lot for your feedback
(0009510)
paulmccabe (reporter)
2010-03-24 23:23

No. Unfortunately we've not managed to resolved this issue, and because of time constraints we've reverted bug to version 1.7.5.

Tbe system being run has a large number of requirements; I'd estimate we have thousands of them stored in the system.

The log files indicate that the problem is related to the requirements; it appears that seem duplication of the primary keys in the DB are the issue.
(0009511)
paulmccabe (reporter)
2010-03-24 23:27

Sorry, ignore my last comment; I'm inferring this preoblem from the other issue that I've reported which appears to be very similar, and that IS to do with duplication of requirements.

For this issue I wouldn't be surprised if the issue was related to requirements also.
(0009547)
fman (administrator)
2010-03-27 04:15

if you can send me an export zipped of your DB I will run migration to understand problem (francisco.mancardi@gmail.com)
(0009567)
haslec (reporter)
2010-03-29 21:55

I have solved my problem. I was running the update of the database scripts but not the migration scripts.

But now I have another problem, in IE it is ok, but with Firefox 3.6.2 I can only see the three on the left part of the page.

(on the rigth page I have only this text

"You can manage Requirement Specification documents.
Requirements Specification

Requirements are grouped by Requirements Specification document, which is related to Test Project.
TestLink doesn't support (yet) versions for both Requirements Specification and Requirements itself. So, a document version should be added after a Specification Title. An user can add a simple description or notes to the Scope field.

Overwritten count of REQs serves for evaluating Req. coverage in case that not all requirements are added to TestLink. The value 0 means that current count of requirements is used for metrics.

E.g. SRS includes 200 requirements but only 50 are added in TestLink. Test coverage is 25% (assuming the 50 added requirements will actually be tested).
Requirements

Click the title of an existing Requirements Specification. If none exist, click on the project node to create one. You can create, edit, delete or import requirements for the document. Each requirement has a title, scope and status. A status should be either 'Normal' or 'Not testable'. Not testable requirements are not counted to metrics. This parameter should be used for both unimplemented features and wrong designed requirements.

You can create new test cases for requirements by using multi action with checked requirements within the specification screen. These Test Cases are created into Test Suite with name defined in configuration (default is: $tlCfg->req_cfg->default_testsuite_name = 'Test suite created by Requirement - Auto';). Title and Scope are copied to these Test cases.
".
(0009569)
paulmccabe (reporter)
2010-03-29 22:09

Francisco, thanks for your interest. Unfortunatley I couldn't give authorisation to release the information in the database. However I can tell you that we have several thousand requirements in the system, and they're all mapped to test cases. It's not a one-to-one mapping; many/most test cases have several associated requirements, and requirements are used in several test cases (to cover variation in user input, etc.)
(0009571)
fman (administrator)
2010-03-30 17:29

@haslec: open another issue is problem is different
(0011104)
fman (administrator)
2010-08-31 20:27

Release BETA 6 - 20100831

- Issue History
Date Modified Username Field Change
2010-03-18 17:15 paulmccabe New Issue
2010-03-18 17:15 paulmccabe Browser => Firefox
2010-03-18 17:15 paulmccabe PHP Version => 5.2.10
2010-03-18 17:16 paulmccabe Note Added: 0009452
2010-03-18 18:12 fman Note Added: 0009454
2010-03-18 18:12 fman File Added: database.class.zip
2010-03-18 19:07 paulmccabe Note Added: 0009456
2010-03-18 19:08 paulmccabe Note Added: 0009457
2010-03-18 22:17 paulmccabe Note Added: 0009460
2010-03-24 21:04 haslec Note Added: 0009509
2010-03-24 23:23 paulmccabe Note Added: 0009510
2010-03-24 23:27 paulmccabe Note Added: 0009511
2010-03-27 04:14 fman Note Deleted: 0009456
2010-03-27 04:15 fman Note Added: 0009547
2010-03-29 21:55 haslec Note Added: 0009567
2010-03-29 22:09 paulmccabe Note Added: 0009569
2010-03-30 17:29 fman Note Added: 0009571
2010-08-04 13:54 fman Relationship added related to 0003633
2010-08-04 14:10 fman Status new => resolved
2010-08-04 14:10 fman Fixed in Version => 1.9 (Prague)
2010-08-04 14:10 fman Resolution open => fixed
2010-08-04 14:10 fman Assigned To => fman
2010-08-04 14:11 fman Relationship added child of 0003570
2010-08-13 18:24 fman Relationship added has duplicate 0003679
2010-08-31 20:27 fman Note Added: 0011104
2010-08-31 20:27 fman Status resolved => closed



Copyright © 2000 - 2019 MantisBT Team
Powered by Mantis Bugtracker