Mantis Bugtracker          
testlink.org

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0003132TestLinkRequirement Managementpublic2010-02-02 23:072010-08-31 20:26
Reporteralbertdebruijn 
Assigned Toasimon 
PrioritynormalSeveritycrashReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version1.9 Beta 2 
Fixed in Version1.9 Beta 6 
Summary0003132: Requirements / Analyse causes crash in Top Req Specification
DescriptionStructure of Req:
1 Top level ReqSpec
several in lower structure, with or without req's

On analyse of the only Top ReqSpec, The following error occurs:
Fatal error: Function name must be a string in /opt/lampp/htdocs/tl19b2/lib/functions/requirement_spec_mgr.class.php on line 335
Additional InformationAnalyse works fine on other (lower) levels
No effect when changing nr of Req. needed fields (0 or value)

Added a 2nd Top Level ReqSpec, no error here on Analyse, Firstly added one still gives error
TagsNo tags attached.
Database (MySQL,Postgres,etc)
BrowserFF 3.5.7
PHP Version5.2.3
TestCaseID
QA Team - Task Workflow Status
Attached Files? file icon tl19b2.sql [^] (94,356 bytes) 2010-02-03 01:52

- Relationships
child of 0003104closedfman Analyse req.spec produces fatal error 

-  Notes
(0008932)
albertdebruijn (reporter)
2010-02-03 01:48

appears to be the first two faulty? requirements,
placing them into other req.spec causes the trouble there

Cannot attach sql of DB on this issue, drop me a mail at a.debruijn@debruijn.nl and I can attach SQL, or ak me to open a new issue relating to this one
(0008934)
albertdebruijn (reporter)
2010-02-03 01:53

file uploaded as now possible with status reopened ;-)
(0008935)
fman (administrator)
2010-02-03 02:02

1. your note is not clear
2. this issue has to be considered closed an solved on beta 1.3
open a new issue with clear description
I will reclose
(0009153)
albertdebruijn (reporter)
2010-02-24 23:27

Reproduced it on several machines:
- Req. Spec with requirements maded (no linked TC)
- Assign TC
- Analyse (or req.based report)
- Fatal error, as descibed
(0010093)
fman (administrator)
2010-05-20 20:39

Reminder sent to: asimon

would you mind to check if we can declare it resolved ?
(0010911)
asimon (developer)
2010-08-21 12:58

I'm not able to reproduce this error, so I think we can safely set it to resolved.
(0011014)
fman (administrator)
2010-08-31 20:26

Release BETA 6 - 20100831

- Issue History
Date Modified Username Field Change
2010-02-02 23:07 albertdebruijn New Issue
2010-02-02 23:07 albertdebruijn Browser => FF 3.5.7
2010-02-02 23:07 albertdebruijn PHP Version => 5.2.3
2010-02-02 23:24 fman Relationship added child of 0003104
2010-02-02 23:25 fman Status new => resolved
2010-02-02 23:25 fman Fixed in Version => 1.9 Beta 3 (Next Beta)
2010-02-02 23:25 fman Resolution open => fixed
2010-02-02 23:25 fman Assigned To => fman
2010-02-03 01:48 albertdebruijn Note Added: 0008932
2010-02-03 01:48 albertdebruijn Status resolved => assigned
2010-02-03 01:48 albertdebruijn Resolution fixed => reopened
2010-02-03 01:52 albertdebruijn File Added: tl19b2.sql
2010-02-03 01:53 albertdebruijn Note Added: 0008934
2010-02-03 02:02 fman Note Added: 0008935
2010-02-03 02:03 fman Status assigned => resolved
2010-02-03 02:03 fman Resolution reopened => fixed
2010-02-24 23:27 albertdebruijn Note Added: 0009153
2010-02-24 23:27 albertdebruijn Status resolved => assigned
2010-02-24 23:27 albertdebruijn Resolution fixed => reopened
2010-05-20 20:39 fman Note Added: 0010093
2010-08-21 11:56 fman Assigned To fman => asimon
2010-08-21 12:58 asimon Note Added: 0010911
2010-08-21 13:08 asimon Status assigned => resolved
2010-08-21 13:08 asimon Fixed in Version 1.9 Beta 3 => 1.9 Beta 6
2010-08-21 13:08 asimon Resolution reopened => fixed
2010-08-31 20:26 fman Note Added: 0011014
2010-08-31 20:26 fman Status resolved => closed



Copyright © 2000 - 2020 MantisBT Team
Powered by Mantis Bugtracker