Mantis Bugtracker          
testlink.org

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0003098TestLinkIntegration with Other Systemspublic2010-01-27 21:412010-05-01 20:29
Reporterpuru 
Assigned ToJulian 
PrioritynormalSeveritymajorReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version1.9 Beta 1 
Fixed in Version1.9 Beta 4 
Summary0003098: Not possible to add bug in Jira using bug mangement system from Testlink.
DescriptionTrying to add bug in JIRA using Bug management from testlink after the test execution. The popup window ask for "jira bug id". Both cases existing key from JIRA used as "jira bug id" or trying to use new value as "jira bug id" give as result providing information "Bug ID does not exist on BTS!".
TagsNo tags attached.
Database (MySQL,Postgres,etc)
BrowserIE7
PHP Version
TestCaseID
QA Team - Task Workflow Status
Attached Filespng file icon firstScreen.PNG [^] (70,805 bytes) 2010-01-27 21:41


png file icon secondScreen.PNG [^] (22,854 bytes) 2010-01-27 21:41

- Relationships
duplicate of 0003256closedJulian Bugtracker Integration: Adding Bug fails due to missing function in child classes 

-  Notes
(0008832)
fman (administrator)
2010-01-27 22:18

BUG must exists on BTS before been using on TL
(0008841)
roxio (reporter)
2010-01-28 05:34

+1 for this issue, although the author did not articulate the problem very well.

1. Setup the jira.cfg.php file
2. Add proper settings to the custom_config_inc.php file
3. Fail a test case
4. Click the bug icon to link a new defect
5. Type in an existing defect to the field and click "Add bug" button

Results - Testlink will always report "Bug ID does not exist on BTS!".

Expected - The bug does actually exist in my bug tracker (Jira) so Testlink should report it

Regression - This procedure works fine in Testlink 1.8.5. 1.9 beta does not.
(0008844)
puru (reporter)
2010-01-28 16:42

Exactly. Thanks Roxio for defining the problem step by step and providing me info how to submit bug in the future.
(0009362)
Julian (reporter)
2010-03-11 15:37

Please retest this in the next beta. should be fixed then.

- Issue History
Date Modified Username Field Change
2010-01-27 21:41 puru New Issue
2010-01-27 21:41 puru File Added: firstScreen.PNG
2010-01-27 21:41 puru Browser => IE7
2010-01-27 21:41 puru File Added: secondScreen.PNG
2010-01-27 22:18 fman Note Added: 0008832
2010-01-28 05:34 roxio Note Added: 0008841
2010-01-28 16:42 puru Note Added: 0008844
2010-03-11 14:05 Julian Relationship added duplicate of 0003256
2010-03-11 15:37 Julian Note Added: 0009362
2010-03-11 15:37 Julian Status new => resolved
2010-03-11 15:37 Julian Fixed in Version => 1.9 Beta 4 (Next public build)
2010-03-11 15:37 Julian Resolution open => fixed
2010-03-11 15:37 Julian Assigned To => Julian
2010-05-01 20:29 fman Status resolved => closed



Copyright © 2000 - 2020 MantisBT Team
Powered by Mantis Bugtracker