Mantis Bugtracker          
testlink.org

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0003063TestLinkCustom fieldspublic2010-01-13 23:322010-05-01 20:34
Reportermikromel 
Assigned Tofman 
PrioritynormalSeverityfeature requestReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version1.8.5 (bug fixing) 
Fixed in Version1.9 Beta 2 
Summary0003063: Behaviour of dropdownlists by creating/editing Custom Fields
Description1. the dropdownlist should not disapear when not applicable, it should be only disabled

and

2. the dropdownlist "Available for" needs to be directly under "Type" because there are always all options

i dont know how it works, but i assume, it should validate first the "Available for" and then enable/disable the other menus
TagsNo tags attached.
Database (MySQL,Postgres,etc)
Browserfirefox
PHP Version
TestCaseID
QA Team - Task Workflow Status
Attached Filesjpg file icon dropdown.JPG [^] (24,452 bytes) 2010-01-13 23:32

- Relationships

-  Notes
(0008673)
mikromel (reporter)
2010-01-13 23:34

see the attachment for how the arrangement of dropdownlists should be
(0008674)
fman (administrator)
2010-01-13 23:36

>> 1. the dropdownlist should not disapear when not applicable,
>> it should be only disabled
that's your idea of interface, nodoby said your proposal is wrong, but if our implementation works I would like to understand what problems created to users,
and why must be changed.

Please explain what issues do you see on this user interface, and avoid qualifiying things as 'not good', because do not add value.
Please point exaclty what are the drawbacks you see.
(0008678)
mikromel (reporter)
2010-01-14 16:44

maybe i used the wrong words (my englisch...)

Yes, the implementation works, and there is no problem with the functionality. But when a new user tries to create a new CF (like me yesterday) it can be confusing.

example:
i want to create a new field with timestamp, so i make this changes by creating the CF->
Name: Timestamp
Label: -
Type: Datetime

so far so good.

i want to have it Enabled on test execution. In that moment one menu disapaers (is not bad because it is not usable then, but its "jumpy?")

the problem is then with the Menu "available for". new users dont know what is usable with what so i try to select "requirement". and then even "enable on" disapears. I firstly didnt know why, just after i tried it few times i understood. the behaviour is confusing (maybe not just used to it) when something you selected before disapears.

this problem, or bettert said the feeling from this menus, would be less confusing and easier to use (user frendlier) when the order of the menu was as i wrote in point 2. in that case the disapearing of the other dropdownlists wouldnt be a issue
(0008679)
fman (administrator)
2010-01-14 16:57

ok thanks for explanation, think that changing order will be not a problem, Can be done with low priority

- Issue History
Date Modified Username Field Change
2010-01-13 23:32 mikromel New Issue
2010-01-13 23:32 mikromel Browser => firefox
2010-01-13 23:32 mikromel File Added: dropdown.JPG
2010-01-13 23:34 mikromel Note Added: 0008673
2010-01-13 23:36 fman Note Added: 0008674
2010-01-13 23:37 fman Summary Behaviour of dropdownlists by creating/editing Custom Fields not good => Behaviour of dropdownlists by creating/editing Custom Fields
2010-01-14 16:44 mikromel Note Added: 0008678
2010-01-14 16:57 fman Note Added: 0008679
2010-01-14 16:57 fman Status new => assigned
2010-01-14 16:57 fman Assigned To => fman
2010-01-22 06:33 fman Status assigned => resolved
2010-01-22 06:33 fman Fixed in Version => 1.9 (DEV)
2010-01-22 06:33 fman Resolution open => fixed
2010-05-01 20:34 fman Status resolved => closed



Copyright © 2000 - 2020 MantisBT Team
Powered by Mantis Bugtracker