Mantis Bugtracker          
testlink.org

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0003053TestLinkTest Plan (builds, milestones, test assign)public2010-01-12 22:392010-02-17 22:27
ReporterJgaudreau 
Assigned Tomhavlat 
PrioritynormalSeveritymajorReproducibilityalways
StatusclosedResolutionsuspended 
PlatformOSOS Version
Product Version1.8.5 (bug fixing) 
Fixed in Version 
Summary0003053: The number of Test Cases that can be added to a Test Plan is VERY Low
DescriptionBy performing some tests with Test Link, I created over one hundred Test Cases in the Test Specifications and tried to add them all to a Test Plan after. After selecting all Test Cases and trying to add them, I noticed that nothing was occurring, blocking me from adding them.

Just to make sure, I verified that this was not caused by the Import/Export feature. And apparently, it is not caused by this.

After further tests, I found out that I could only add 42 Test Cases to a Test Suite. This is quite problematic for our company since we have Test Suites that could reach over 300 Test Cases... Is there a way to make this limit higher?
Additional InformationTest Link 1.8.5
TagsNo tags attached.
Database (MySQL,Postgres,etc)
Browser
PHP Version
TestCaseID
QA Team - Task Workflow Status
Attached Files

- Relationships
duplicate of 0001934closedfman After adding large number of Test Cases ( 0000755:0001500), get fatal error when trying to assign users or execute 
has duplicate 0002960closedfman Not able to add TestCases to TestPlan in Bulk when number of test cases > 48 

-  Notes
(0008655)
mhavlat (reporter)
2010-01-12 23:39

This is duplicate of issue 0000755:0001500), get fatal error when trying to assign users or execute" class="resolved">0001934. Closed.
In addition user have had old HW or wrong configuration of webserver or PHP.
(0008657)
Jgaudreau (reporter)
2010-01-13 00:33
edited on: 2010-01-13 21:48

This is not the problem you think it is.
I checked with the technical assistance, and the limit was already at 256MB. Also, there is no Fatal Errors occurring unlike described in the other issue. I am just unable to add Test Cases to a Test Plan.

Let me give more details of the steps to reproduce the issue.

1. Login with an admin account to Test Link.
2. In Test Specification, select "Edit Test Cases".
3. Create more than 42 Test Cases (51 in my case).
4. Select "Home" to go back to the Main Menu.
5. In Test plan contents, select "Add / Remove Test Cases".
6. Select the Test Suite with more than 42 Test Cases.
7. Select all Test Cases and click on "Add/Remove selected".
8. Notice that nothing happens.
9. Select a total of 42 Test Cases.
10. Notice that the 42 Test Cases are correctly added.
11. Select the newly added Test Cases in the "remove column" and click on "Add/Remove selected".
12. Notice that the Test Cases cannot be deleted.

Do you know what could cause this issue? Apprently, the suggestion of increasing the limit value does not work.

(0008676)
Jgaudreau (reporter)
2010-01-14 04:47

Another bug related to that is occurring to me..
I have one Test Suite that for which it is impossible for me to add any Test Cases. This one has 129 Test Cases created, but none of them can be added for execution.

Hope it'll help you on discovering the source of the problem.
If you find the source of the problem, I can check with my technical assistance if they would be able to fix the issue.
(0008725)
fman (administrator)
2010-01-20 03:17

tested on 1.9 beta 2 with 72 test cases scattered in multifolder organization => no problem found
(0008726)
fman (administrator)
2010-01-20 03:41

tested on 1.9 beta 2 one test suiote with 69 test cases added on one shot => Ok
tested on laptop with postgres and php 5.3 and apache
(0008735)
Jgaudreau (reporter)
2010-01-21 22:42

Here's some feedback from our Technical Assistance department:

Right now testlink is currently running on:

ubuntu hardy lts 8.04.3
apache2 2.2.8
php5 5.2.4
mysql-server 5.0.51a

If he needs to examine conf files. I'll attach them.
(0008909)
fman (administrator)
2010-02-02 02:11

we are not able to reproduce
(0008926)
Jgaudreau (reporter)
2010-02-02 22:30

On my main page, there is the following message displayed:

There are security warnings for your consideration. See details on file: /var/www/testlink/logs/config_check.txt. To disable any reference to these checkings, set $tlCfg->config_check_warning_mode = SILENT;

Could it be related to that?
(0008927)
Jgaudreau (reporter)
2010-02-02 22:51

Our technical assistant is suggesting to send you conf files, but he would need to know what kind of configuration files you would need. (IE Bugzilla confs, testlink confs, php5 configuration files and such.)

Right now, we will try to create a freshly new Test Link and compare both databases and trying to see what is the problem while I am waiting for feedback on the conf files.

Thank you for your time and effort, it is very much appreciated,
Jonathan
(0008928)
fman (administrator)
2010-02-02 23:22

>> There are security warnings for your consideration. See details on file:
>> /var/www/testlink/logs/config_check.txt. To disable any reference to these
>> checkings, set $tlCfg->config_check_warning_mode = SILENT;
This has nothing to do with your problem.
Anyway is better is you read what is written in this file

I'm sorry but we will not analize users config files.
(0008945)
techieguy (reporter)
2010-02-04 17:59

my 2 cents : just chk the apache error log file for the error which is logged when u try to add the test cases to a test plan. that shud give u some hint to what is causing the issue.

tg
(0009055)
Jgaudreau (reporter)
2010-02-17 21:17

Thanks for your help guys, especially to you techiguy, after verifying the apache error log file, we managed to find out what was the problem.
According to the technical assistant, our proxy was detecting the add of Test Cases as an attack, we only needed to add exceptions related to Test Link and after that, everything worked perfectly.

THANKS A LOT !

- Issue History
Date Modified Username Field Change
2010-01-12 22:39 Jgaudreau New Issue
2010-01-12 23:39 mhavlat Note Added: 0008655
2010-01-12 23:39 mhavlat Status new => assigned
2010-01-12 23:39 mhavlat Assigned To => mhavlat
2010-01-12 23:40 mhavlat Relationship added duplicate of 0001934
2010-01-12 23:40 mhavlat Status assigned => closed
2010-01-12 23:40 mhavlat Resolution open => duplicate
2010-01-13 00:33 Jgaudreau Note Added: 0008657
2010-01-13 00:33 Jgaudreau Status closed => assigned
2010-01-13 00:33 Jgaudreau Resolution duplicate => reopened
2010-01-13 00:56 mhavlat Assigned To mhavlat =>
2010-01-13 00:56 mhavlat Status assigned => new
2010-01-13 21:48 Jgaudreau Note Edited: 0008657
2010-01-13 22:19 Jgaudreau Note Added: 0008669
2010-01-13 22:19 Jgaudreau Note Deleted: 0008669
2010-01-14 04:47 Jgaudreau Note Added: 0008676
2010-01-20 03:17 fman Note Added: 0008725
2010-01-20 03:41 fman Note Added: 0008726
2010-01-21 22:42 Jgaudreau Note Added: 0008735
2010-01-22 23:47 mhavlat Relationship added has duplicate 0002960
2010-02-02 02:11 fman Note Added: 0008909
2010-02-02 22:30 Jgaudreau Note Added: 0008926
2010-02-02 22:51 Jgaudreau Note Added: 0008927
2010-02-02 23:22 fman Note Added: 0008928
2010-02-04 17:59 techieguy Note Added: 0008945
2010-02-17 21:17 Jgaudreau Note Added: 0009055
2010-02-17 22:27 mhavlat Status new => assigned
2010-02-17 22:27 mhavlat Assigned To => mhavlat
2010-02-17 22:27 mhavlat Status assigned => closed
2010-02-17 22:27 mhavlat Resolution reopened => suspended



Copyright © 2000 - 2020 MantisBT Team
Powered by Mantis Bugtracker