Mantis Bugtracker          
testlink.org

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0002999TestLinkUser Interface Generalpublic2009-12-10 16:532010-05-01 20:31
ReporterJulian 
Assigned Toasimon 
PriorityhighSeverityfeature requestReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version1.8.4 
Fixed in Version1.9 Beta 3 
Summary0002999: Direct Link to Testlink items from outside Testlink
DescriptionDirect links to testlink items currently are possible but frames like navigation and tree are missing. This avoids direct editing of those items by the user.

To be able to create direct links to testlink items would help project managers to assign tasks to users by adding a direct link to their task.

How this feature works:
-----------------------
- direct link to testcase:
http://<testlink>/linkto.php?tprojectPrefix=<tproj_prefix>&item=testcase&id=<tc_external_id> [^] (see screenshot direct_link_tc.PNG)
- direct link to requirement:
http://<testlink>/linkto.php?tprojectPrefix=<tproj_prefix>&item=req&id=<req_doc_id> [^] (see screenshot direct_link_req.PNG)
- direct link to requirement:
http://<testlink>/linkto.php?tprojectPrefix=<tproj_prefix>&item=reqspec&id=<reqspec_doc_id> [^] (see screenshot direct_link_reqspec.PNG)

Specials:
---------
- tree for requirement specification or test specification are expanded to the level of the item you created the link to
- if a user has no right to view item he is redirected to main page
- if item does not exist an errormessage shows


limitations:
User has to login before clicking the link!
If user is not logged in he is redirected to login page. After login main page is shown. Clicking the link again - than it works!


Screenshots:
------------
Red frames added in image to show important things:
1. How to use direct link in adress bar of browser
2. How tree is expanded
3. what item was linked
TagsNo tags attached.
Database (MySQL,Postgres,etc)
Browser
PHP Version
TestCaseID
QA Team - Task Workflow Status
Attached Filespng file icon direct_link_tc.PNG [^] (73,071 bytes) 2009-12-10 16:54


png file icon direct_link_req.PNG [^] (65,911 bytes) 2009-12-10 16:54


png file icon direct_link_reqspec.PNG [^] (47,814 bytes) 2009-12-10 16:54


zip file icon 2999_direct_links.zip [^] (3,093 bytes) 2009-12-11 18:43
tar file icon 2999_direct_links_v2.tar [^] (122,880 bytes) 2009-12-14 20:29
bz2 file icon 2999_direct_links_v3.tar.bz2 [^] (47,418 bytes) 2009-12-15 23:37

- Relationships
duplicate of 0000526closedasimon GUI request: Allow redirection to login and back for extenal links pointing to TL 
has duplicate 0002739closedmhavlat It would be nice for a user to be able to send link to a specific test-case 

-  Notes
(0008456)
Julian (reporter)
2009-12-10 16:56

feature is ready and in review process
(0008474)
fman (administrator)
2009-12-12 23:55

1. documentation must follow TL standards
2.all messages must be retrieved used lang_get

refactor and re-attach code for review
(0008482)
asimon (developer)
2009-12-14 20:22

Just attached refactored tar, ready for reviewing.
(0008483)
fman (administrator)
2009-12-15 02:54

ok thanks
(0008485)
mhavlat (reporter)
2009-12-15 16:47

Guy, just see this request at the first time ...

I don't see a reason why there could be special URL for.
TestLink must allow to navigate for these items naturally also through frames.
I.e. link to TC is now:
http://verification.intinfra.com/testlink/lib/testcases/archiveData.php?version_id=undefined&edit=testcase&id=26813 [^]

What could be problem? Maybe project ID. TL should be able redirect to login, select a project defined in URL and navigate to view TC page.

Using extra script for external navigation is bad for usability. Please consider my proposal.
I check older issue for the topic and add relation here.
(0008486)
mhavlat (reporter)
2009-12-15 16:50

Found 0000526.

@Julian ... you can use "Send a reminder" link to notify us that you are looking for a review.
(0008487)
Julian (reporter)
2009-12-15 16:58
edited on: 2009-12-15 16:59

@martin:

what is described in your bug is the improved login method. i think this should be our target for TL 2.0 for this feature.
In your issue you are just talking about direct links without navigation frames etc. that is not very useful because you only get information about 1 specific item. user maybe has to take a look at other e.g. testcases in the test suite to avoid redundancy.

for us it is absolute must have to show testlink with every frame

(0008491)
asimon (developer)
2009-12-15 23:37

reopened, new version (with buttons for permanent links and additional bugfixes) attached for reviewing
(0008495)
fman (administrator)
2009-12-16 05:44

refactore and commited to CVS HEAD, please test
(0009151)
asimon (developer)
2010-02-23 23:08

Anchors have been added to this feature:
- If anchors are set (in scope, etc.) in the linked document, you can specify these by using &anchor=anchorname, e.g.
- http://<testlink_home>/linkto.php?tprojectPrefix=KAOS&item=testcase&id=KAOS-4&anchor=importantpart [^]
The frame jumps then directly to the selected anchor.

- Issue History
Date Modified Username Field Change
2009-12-10 16:53 Julian New Issue
2009-12-10 16:54 Julian File Added: direct_link_tc.PNG
2009-12-10 16:54 Julian File Added: direct_link_req.PNG
2009-12-10 16:54 Julian File Added: direct_link_reqspec.PNG
2009-12-10 16:56 Julian Note Added: 0008456
2009-12-10 16:56 Julian Status new => assigned
2009-12-10 16:56 Julian Assigned To => fman
2009-12-11 18:43 Julian File Added: 2999_direct_links.zip
2009-12-12 23:55 fman Note Added: 0008474
2009-12-14 15:31 Julian Assigned To fman => asimon
2009-12-14 20:16 asimon File Added: direct_linking.tar
2009-12-14 20:22 asimon Note Added: 0008482
2009-12-14 20:27 asimon File Deleted: direct_linking.tar
2009-12-14 20:29 asimon File Added: 2999_direct_links_v2.tar
2009-12-15 02:54 fman Note Added: 0008483
2009-12-15 16:47 mhavlat Note Added: 0008485
2009-12-15 16:48 mhavlat Relationship added duplicate of 0000526
2009-12-15 16:50 mhavlat Note Added: 0008486
2009-12-15 16:51 fman Description Updated
2009-12-15 16:51 fman Description Updated
2009-12-15 16:58 Julian Note Added: 0008487
2009-12-15 16:59 Julian Note Edited: 0008487
2009-12-15 18:18 fman Status assigned => resolved
2009-12-15 18:18 fman Fixed in Version => 1.9 (DEV)
2009-12-15 18:18 fman Resolution open => fixed
2009-12-15 23:37 asimon Note Added: 0008491
2009-12-15 23:37 asimon Status resolved => assigned
2009-12-15 23:37 asimon Resolution fixed => reopened
2009-12-15 23:37 asimon File Added: 2999_direct_links_v3.tar.bz2
2009-12-16 05:44 fman Note Added: 0008495
2009-12-16 05:44 fman Status assigned => resolved
2009-12-16 05:44 fman Resolution reopened => fixed
2010-02-22 21:04 mhavlat Relationship added has duplicate 0002739
2010-02-23 23:08 asimon Note Added: 0009151
2010-02-23 23:08 asimon Status resolved => assigned
2010-02-23 23:08 asimon Resolution fixed => reopened
2010-02-23 23:09 asimon Status assigned => resolved
2010-02-23 23:09 asimon Fixed in Version 1.9 Beta 2 => 1.9 Beta 3 (Next Beta)
2010-02-23 23:09 asimon Resolution reopened => fixed
2010-05-01 20:31 fman Status resolved => closed



Copyright © 2000 - 2019 MantisBT Team
Powered by Mantis Bugtracker